Dell xps 8900 wifi issue

My first post and I’m a newbie so be gentle.
I’ve combed the Internet and found no information specific to what’s happening.
I’m trying to get the wifi working on ANY linux install.
Everything works under Windows 10.
So far I’ve tried the latest installs of Manjero KDE, Mint Cinnamon, PopOS, and Ubuntu with the same level of success.
If I try to use the wifi it returns failed and doesn’t even show any available networks, if I use my cellphone hot spot, it shows the network and connects immediately.
Any Ideas would be helpful.

OK, then run Linux in a VM and use W10.

That’s not a solution, but a workaround at best. I bet there are Linux-native solutions to this issue.


I’ve used many Linux distros, including the ones you mention, and never had a difficulty with wifi. EXCEPT when I had a machine with a Broadcomm wifi chip. Your problem seems more hardware-related. Are you sure you followed the step-by-step instructions for dual-booting listed elsewhere on this forum?

1 Like

I’m not trying to dual boot.
Once I get this figured out I will be dumping Bill G.
I installed mint cinnamon on a USB drive and everything else works well.
I would tend to believe that it was a hardware issue but then my use of a hot spot would not work as well as it does.

No Linux distribution will be successful until they get Broadcom WiFi driver support for the newer chip sets. Normally, you’d get that from Broadcom, but they have little interest. They do have some source code, but you’ll probably never get it to work. Eventually, the new Broadcom WiFi chips will be supported in the Linux kernel. Unfortunately, that may take a while.

Lesson: Don’t buy hardware without checking Linux compatibility. For example, the Intel NUC10 has great compatibility.

Better still, buy a computer with Linux pre-loaded. I like but there are numerous options.

For now, your best bet is to buy a cheap USB Wifi adapter. The TP-Link Nano AC600 USB Wifi Adapter works for most Linux flavors and is only $18 at Amazon.

Good luck going forward with Linux. It really is quite rewarding once you have compatible hardware.

1 Like

Years ago there was a workaround for Broadcomm Wifi, but my memory is continuing to fail me. Probably one of the USB dongles would work in its place, I salute 7blade for flushing Windows and coming to the light side.

When you install Linux normally it detects the components inside and sets everything up for you automatically …

But (there is always a but)

Sometimes it needs a bit of help


With Linux mint any version

Launch Menu ‣ Administration ‣ Driver Manager.
You need to be connected by a cable at this stage to the internet
Here you should see a screen with what it’s using and what it recommends or offers
Hopefully you can see the driver for your broadcom device
Select it and accept to close
Restart your computer and disconnect the cable to the internet
You should be able to get the WiFi options

I have had the same issues with broadcom so you are not alone

If this fails as was suggested before a separate WiFi sub key may be the answer as they are so cheap now

1 Like

IF, it is what you and others suspect, “broadcom” then why does the cell phone hot spot work?
I’ve thought about the dongle deed as well and plan to give it a try when it AC600) arrives.
I too am leaning to POP-OS and have looked over their VERY tempting hardware.

No such luck.
The driver manager only lists my video card (NVIDIA).

Checking the Dell website it appears there have been issues with the standard card and it’s not clear which card they used during the life of this machine

The support recommend a replacement

But this needs you to take the box apart to replace … if you feel up to it and capable … not everyone wants to do this

Other option is to buy a separate dongle WiFi key like a sub memory stick

Please note I don’t work for Amazon and in no way do I get anything from them it’s just to give you ideas of what and where. You may find the same at a local computer shop (with free advice) or a large supermarket offering computer bits or a specialist supplier

To check your existing card

Although the guide is for Ubuntu the info works on mint

Go into terminal
sudo lshw -C network

This will give you more details which may help solve your issues

1 Like

I had no idea there was an update to the board.
I ordered one and it’s due tomorrow.
I WILL let folks know the verdict after the PC comes out of surgery. I’ve built more PC’s than I care to count so board swapping is a non issue.

Here is what my sudo cmd revealed:
XXXXX@XXXXX-XPS-8900:~$ sudo lshw -C network
[sudo] password for XXXXX:
description: Wireless interface
product: RTL8723BE PCIe Wireless Network Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlp2s0
version: 00
serial: 4c:bb:58:f4:db:93
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl8723be driverversion=5.4.0-54-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: irq:16 ioport:d000(size=256) memory:df200000-df203fff
description: Ethernet interface
product: Ethernet Connection (2) I219-V
vendor: Intel Corporation
physical id: 1f.6
bus info: pci@0000:00:1f.6
logical name: enp0s31f6
version: 31
serial: 64:00:6a:68:61:f9
size: 1Gbit/s
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.8-4 ip= latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
resources: irq:130 memory:df300000-df31ffff

Apparently the chip set is not an issue.
It smells to me like a firmware issue coupled with some components on the board.
I just couldn’t figure out exactly why the cell phone hot spot worked but not the local networks in my area that show up on my scans in windows and my cell phone. They didn’t even show up as options.

Ok thanks for the update and further information

It’s not a broadcom as first thought but as you can see a realtec 8723

I cannot check myself as I don’t have a machine in my workshop with this card but the following should help

Or more detailed info at


Again you run this through terminal … note you are using a debian version of Linux if on Linux mint

But if you have ordered a new card then you may want to just use the new one

I’ll give that a try before I install the new card.
Even if it works I’ll install the new card to avoid future headaches.
As for the hot spot connecting and nothing else, I think it might be a range issue as my cell phone is well within a meter of the PC.
I’ll be testing that as well before I perform surgery.

BTW, YOU have been FANTASTIC!!
Just saying thank you is so unworthy of what you have done.

1 Like

For me, the idea of Linux is a community effort, we are here to help each other, the more we put in to it then the more we get out.

So a pleasure to be of service.

Just a couple of questions
How far is your computer to the WiFi box, if it works on Windows without moving it should work the same on Linux
On mint bottom right of screen you have time / date etc and the internet connection icon like a cable and plug when connected or unconnected (hard to describe) in principal for WiFi it’s like steps … when you click you get different options for your connection, Ethernet, etc … what do you get ? Is there an option under the WiFi …

I ask as it’s a bit like is it plugged in and is it switched on … easy questions but not always though about - don’t want to offend you in any way, but been caught out on loose connections, hidden on off switches before

Look forward to hearing from you

1 Like

26 years USN, no way you could offend me. My skin thickness is measured in light years.

The wifi router is about 20 feet from the PC with a wall plasterboard (1953 built house) in between .
I have no issue connecting with wifi in Windows and there are several other wifi networks (neighbors) listed.
The Linux system shows a blank until I activate my cell phone hot spot. Then only that connection shows and it connects right away.
The new board should be in my hands later today and I’ll run the tests I said I would.
As for simple stuff, yes I checked. I remember getting called to a clients office because they couldn’t get the tape backup system to work. I got there and yep, I informed them they had to turn it on first. Worked like a champ after I flipped the switch. Lots of red faces that day.
I’ll post my test results when i get them.

1 Like

Definitely the card.
Hot spot would not connect unless sitting on top of the PC. No other nearby networks even showed up.
Did the kernel changes and update of Realtec drivers with no affect what-so-ever.
Swapped out the board and BINGO! Reading 5 by 5.
Thanks to all who bounced ideas around in my head with an ULTIMATE EXTRA SPECIAL THANKS to who is some kind of carpenter as he hits those nails right on the head EVERY TIME.

Thank you SO VERY MUCH!!
By this time next week Windows will be a distant (VERY BAD) memory.


Glad it worked in the end with a new card

Sometimes it’s hard to spot where the fault is on pcb and it’s cheaper to just swap them out… but such a throw away society

Not a diy or woodworker in any form … just 45 years in computing and 20 of them (happy to be) using linux…