Distro hoping - gedit

Ubuntu 18.04 - I had D/L it and installed it in one of my test partitions awhile back but did not really test it much. So yesterday, I ran across it and decided to test it a bit and also see what games were in the library. The problem I ran into (which I found a work around) but still curious as to what I may have done wrong is --> gedit had no header on top except for 'Open" and 'Save". When I check the internet, is showed gedit with the standard header like 'File, Edit, Search, Options, Help".

So next I check Ubuntu software collection. Yes indeed it showed gedit installed. I try installing “Text Editor” nothing changed. I next installed “Leafpad”. Now editing with Leafpad, I have the normal heading at the top. No big deal, just testing. I will be trying out Ubuntu 20 soon.

that’s how it’s “designed” to look… minimalist… I don’t mind it… stuff done from “File” can be done by clicking on the save button, or “Open” in the title-bar - everything else is in the “…” three vertical dot menu… and “Edit” functions can be done by right click (or just use "Ctrl+C or Ctrl+V or Ctrl+X)… I do most of my text editing in a terminal with vi, but often turn to gedit to paste / copy stuff…

1 Like

i hadn’t used gedit before so i installed it on bodhi 5.1 (ubuntu 18.04-based) and a mint 19.3 vm. both showed the minimal header you are describing with open, save and the three lines (on mine anyways) “hamburger” menu like @daniel.m.tripp mentioned.

had you used it previously and it looked differently or were you basing your question off of what you saw in your search?

I just start using gedit and was editing a file in the work area. I then wanted to copy / paste it to my save area and WOW! I could not find out how to do it. I’m still not sure. @daniel.m.tripp mention something about 3 dots, and you said 3 lines, so I need to go back and look. But I just could not believe an editor did not have the copy / paste function. So at Ubuntu documentation I saw a beautiful sample:
But that not what I was seeing. :crazy_face: I did not understand why I was only seeing only Open & Save. Being I was going to try out Ubuntu 20, I thought I might run into the same problem and decided to post a “Help” item.

1 Like

this is what i was referring to at top right:

i see the edit options when i right-click as well as the keyboard shortcuts (as foretold by master @daniel.m.tripp) in the community of foss:

As @01101111 - mentioned - clipboard functionality IS there, simply right click anywhere in your document (or use standard keyboard shortcuts like Ctrl+C et cetera).

My “pet peeve” about gedit is its lack of consistency as an X11 application, it only supports the X11 “select buffer” partially (and yes, I’m still using X11, not wayland), i.e. I select some text in terminal, switch to gedit, and press middle button (or emulate middle click by pressing both mouse buttons) where I want to paste the selected text from my terminal, and that works! BUT - it doesn’t work like that internally in gedit, or it’s inconsistent, at best, e.g. in gedit, I drag select some passage of text with the i-beam cursor, move to another part of the text document, and middle click and NOTHING happens! So annoying! This behaviour works nearly everywhere else in Ubuntu, e.g. even web browsers… I’ve noticed also that Libre Office is just as inconsistent as gedit…

Bring on minimalism! I for one LOVE the removal of all those waste of space menu bars! Put EVERYTHING in the title bar! Everything! I don’t have a window title bar in Chrome, or Firefox - even Microsoft Apps like Teams, on Linux, plonk a bunch of their menu stuff in the title bar (which point blank refuses to respect my Window Manager and does it’s own thing - but that’s another rant).

When I fire up an XFCE session (e.g. on my RPi) - I end up hiding all the application menus there too, like in xfce4-terminal, but can’t do that with mousepad text editor… So if this Pi4 becomes my daily driver, I’ll be in the market for another text editor for XFCE…

Yes. @01101111, that’s the screen. I went back and visited the 3 lines and now see “save as” which would have worked. But still no copy/paste! I’m glad Ubuntu was not my first Linux experience. I believe I would have thought, “An OS that does not have a good GUI editor!. Now I must go and find one and install it.” As I remember, even Win 95 had a good editor and that was 25 years ago!

1 Like

Well @daniel.m.tripp, you mind is a lot better then mine. I can not and don’t really want to learn the key board short cuts. I suppose maybe I’m a bit lazy, but I prefer using GUI. Thanks for your thoughts.

1 Like

When you select text with your mouse, right-click on it and a context menu pops up with the cut/copy/paste/ commands. Select your choice.


Notepad a good editor? Even with its 64K file size limit?

I used to drop to a CMD prompt and run the old MS-DOS “edit” command, because it was vastly superior to Windows Notepad… :smiley:

Try "Notepad++, instead.

I’m aware of Notepad++ - haven’t used it in over 10 years but…

I recently bought MobaXterm to use on about 10 different Windows servers I need to access for my job (up to 5 layers of nested jumps) - so - now I’ve got vi and a bash shell to use on Windows :smiley: … gimme “vi” anyday over anything else - but given my primary desktop is Ubuntu 20.04, for quick copy+pastes I just use gedit…