DNS keeps changing

ubuntu 18.04.4

memory 3.7gb, intel pentium [R] 3.20ghz x 2, graphics intel haswell desktop, grome 3.28.2, 64-bit

have tried some of the suggestions but they only last for a few minutes

can someone tell me how to fix this problem as I am not able to access
some sites one of them is linuxmint.com step by step instructions via

Thank you for any information
I am 80 years old and only use gmail youtube and search the web

Hi from germany.
What exactly seems to be the problem?
What do you mean with “DNS keeps changing”?
I assume that you are connected to some kind of router from your ISP (via cable or wifi).
Are there other computers (smartphones, tablets) in your home, that have the same problem?
When did this problem start?
Many questions, but we have to know some basics to get to the problem…

There would be something called " Network settings " ( they have in Ubuntu ) where you can set any DNS of your choice.

Its been over 6 months I changed to zorn and just tried to access mint this is what I got: This site can’t be reached

www.linuxmint.com ’s server IP address could not be found.


mem 3.7gb
intel pentum [R] G3250@3.20ghz = 2
graphics intel haswell desktop
grome 3.28.2
os typoe 64 bit

I looked on the net on how to fix dns problem and followed the instructions done via terminal
the change lasted about 2 minutes I was able to access linuxmint.com then when I tried to install
mint 19.1 was not able to access linuxmint again

I have a box in the house here that I plug the computer into for the internet
I can ping the internet service but how to change anything is beyond me
Thank you Fast.Edi


1 Like

So you can access the internet (e.g. amazon.com, debian.org, …), but explicitely not the domain “linuxmint.com”?
What exactly did you do in the terminal?

What do you mean by “I tried to install mint 19.1”?
Have you started your system with a DVD/USB of Mint 19?

Normally the router is set to provide (internal) IPs and DNS automatically and this works fine in most cases.
Have you tried to start the router/modem new (just take away power for a couple of minutes and plug it in again)?

This might help.