Downloads default pathway seems to be a root folder

I’m still getting acquainted with LMDE-6 and noticed something different from my experience with the LM ubuntu versions. Downloads defaulting to a Root folder makes me a little nervous, but luckily there are not any other user accounts on this computer.

I was Downloading a number of different .pdf files and I noticed that the suggested pathway was always outside of my Home folder and the last and desired location for the save was never retained.

Any ideas why it defaults to the pathway shown in the screenshot? More importantly, any ideas how I can prevent it and restore it back to what I am used to?

Thanks for the help.

It would not have permission to write a download there .
I wonder if you accidentally did the download while su’d to root?

1 Like

Good question Neville, thanks. I don’t recall doing so, but perhaps.

Is there anyway to correct the default pathway going forward?

I tried using the terminal to remove all of the files that are stored in the final folder because they were saved there inadvertently. Not sure why they aren’t named files but are some alpha-numeric code. Anyway, after trying to delete them with a sudo rm, I was denied permission.

I attempted the same using the file manager gui. The “doc” folder changed from a viewable folder with all of the alpha-numeric files names, into a non-folder that I couldn’t access once I elevated “Open as Root”.

Now watch what happens when I elevate permissions.

The folder disappears and because inaccessible in the elevated permission state.

Some downloads, eg pdf files, ask where to put the file. Others, eg iso files, dont ask, it just goes in ~/Downloads.

What happens if you retry, making sure you are not root?
It might self correct.
If not we are going to have to look for where it is set… somewhere in your dot files I guess… ~/.config or ~/.local
maybe. Or it may be globally set somewhere in /etc.

1 Like

This may help

1 Like

What are you doing in /run/user/1000/doc ?
It is not normal for downloads to go there
Things in /run are not real files… they are generated dynamically while linux is running, and they disappear on a reboot.
I am not surprised it refuses to let you change things in /run.


lol…Exactly! I wasn’t there. That’s my whole conundrum. I never once selected that obscure path for my Downloads, it was just there and I saved a number of files to it before catching on that the file I just downloaded wasn’t in the Download folder.

I now have to manually change the pathway every time I download anything because the default is always the /run pathway.

I should add that I’m using the Brave flatpak from the software manager. I went into the Brave download settings and it shows /home/…/Downloads as the Download pathway.

Oh, I misunderstood, sorry.
The setting in Brave is right, but it still goes to crazy locations.
I dont get it.
Have you rebooted?
Try deleting Brave and reinstalling.
Can you think of anything you did just before this issue occurred?
What happens if you try another browser?

  1. Rebooted? Daily sometimes multiple times per day

  2. Reinstalling Brave: just did after your suggestion. Got a checksum failure on the first attempt, but the second attempt was good and it seems to be behaving properly and going to the Download folder. However, I’m limited on what I can access. For instance, if I download a picture I can’t change the location to my Pictures folder. I’m basically limited to Desktop or Downloads. I don’t remember this happening in the Ubuntu version of LM. Not a problem just something I’ve noticed in getting to know LMDE.

I still don’t like that LMDE Downloads break the dark theme setting I use. I already posted about that in a different thread and was told it has something to do with different Libraries used by Debian that give this antiquated look.

  1. I can’t think of anything I did that I haven’t been doing for years with no problems.

  2. I haven’t tried another browser yet.

Thanks Neville.

1 Like

I have never tried that.
It looks like Brave may have a small bug .
It may happen again.
You can live with everything going to ~/Downloads, but watch it.

1 Like

Neville, thank you for all of your helpful suggestions.

I may have been wrongly blaming LMDE-6 for this issue, because I only noticed it after switching to LMDE from LM.

I think you may be right that the Brave(flatpak) may be the source of this. I always added Brave using the terminal commands. I never had any issues like this until I used the flatpak version.

Not sure why I assumed the apps in the Software Manager would work better than a manual installation. I’m half tempted to switch them out now to see what happens.

Thanks again Neville.

1 Like

Hi Ed
In theory, flatpaks and snaps are supposed to bundke everything a program needs, so it will work in any environment
if they bundle a bug in the flatpak, you are stuck with it, no fix is possible.

Thank you for kind words
Sorry I misunderstood at first.

1 Like

My curiosity got the best of me and I decided to exchange the flatpak Brave-browser with the terminal acquired Brave-browser.

Everything is working as it should, thankfully. I have full access to all of the folders not just Desktop and Downloads. It also retained my Dark theme as well.

Should I report this bug to LM or could it just be an isolated incident with my system?

1 Like

Not sure, but whoever puts the flatpak together is the responsible party.

It is unlikely to be something in your system. Flatpaks are containers, everything in it is isolated… like a little mini operating system inside a box.
It only talks to your system thru a few well defined channels.

Was the version of Brave in your Flatpak the same as the version you installed by hand?

I don’t think it is isolated. After reading your post yesterday (before you switched from flatpak) I was in my mom’s computer in Opera doing something (hers is a flatpak) and went to save something and could not believe that /run/1000/etc. was the prefix even though the end of the location pointed to her name/desktop (she saves her downloads to desktop). So I changed it to just uname/downloads but why on earth this would come up is beyond me. It certainly does not in my system on any browser. And I might not have noticed had it not been for this post.

You should probably report this.

Sheila Flanagan


You mean, it happened to you too.

I think that /run/… thing is a temporary filesystem that the OS
keeps, just for its own bookkeeping. Why Opera flatpak gets confused and hangs there is beyond me.

We now have 2 instances… So yes, I think report it.
Probably easiest to report to LM snd let them redirect it.


Hi Shelia. Are you using Linux Mint as well?

Yes, and so is my mom. That is why I mentioned it.

Sheila Flanagan

1 Like

Thanks. Just double checking to make a more accurate report to LM.

My report attempt was squashed by “The solution you provided was incorrect” upon Linux Mint forum registration.

Not sure what’s happening over there with their registration.

1 Like