Dual boot, loads of fault messages when loading Ubuntu after change of hardware

Use my computer in dual boot. Ubuntu 22.04 for serious work, Windows for gaming. Had to change MB, memory and CPU after just too many problems with outdated hardware/windows/gaming. Moved over the old SSD’s as these were only one year old and had no problems booting either windows or Ubuntu but for one except: I got a long list of fault messages before Ubuntu starts, just as crisp and pretty as ever. Cant read one line of message because it’s over so quick before log-on.
In case someone bothers to ponder upon this, i got questions:
Is this something to worry about?
In case it IS something to worry about, what do I need to do about it?
In case it it ISN’T something to worry about, is there something I can do to get rid of this list - it irks my need for tidiness :wink:
Additional info:
Asus UEFI Boot set to Ubuntu/Grub priority / Windows secondary

Not sure, it depends what the messages say.
You can view those scrolled messages by doing
dmesg | more

The sorts of things that might happen when you shift an OS on a disk to a new machine are

  • it might not load all the required drivers for the new machine
  • some required packages may not be installed
  • there may be issues with /etc/fstab
  • if the architecture is different, it may not work at all

Just done something similar moving a lubuntu disk from one machine to another but the errors changed each day and reported different things, to fix put the disk back in the old computer and changed the cmos battery plus added more memory.
Did not figure out why it would be an issue as done this many times with mint and no issues.
Did check driver issues but it reported nothing needed. Could not update as it was 32bit lubuntu and no upgrade path.
Now configuration of a new mint box and will move clients data next to that box. Historical the lubuntu was just a quick fix that spun out for 2 years for different reasons of time and cost for client as he was retired and in financial difficulty. Now it’s a free service on my part to stop him calling me.

1 Like

It’s just that everything just seem normal. I can read “error” in some of the lines, but it is gone in a blink of an eye. I have tried to hit scroll lock to halt the process but it just continues to the login screen and everything continues looking normal. One minor problem occurred after the upgrade, bluetooth was integrated with the new MB (dongle on the old) and I had some problems pairing my trackpad and earphones. Two days and one update later and I could dump the mouse in the drawer and listen to music without hearing the neighbors dogs yapping. No, cant say I have experienced any other driver issues or else but just that list, strange. Maybe because of the new MB Uefi Boot: asus “tuf gaming” splash even after grub boot loader start booting Ubuntu, a thought… I am no kind of specialist; I ask questions, search, do some careful terminal work and generally end up on the lucky side - touch wood.
Guess I have to learn to live with this, see what pops up when I bother to search for clues out there on the Wide World Web of Wonders.
Have a good one folks, I’m still open for input…

Did you try using
dmesg | more
It will recover those scrolled messages so you can read them.

My computer has quite a number of such messages during boot, but it does not affect operation after Linux is booted.


How long is that list, 5…6 lines, or a whole screen?
Can you catch something about “ACPI”?
Or “DMAR”?

1 Like

Please - please - try @nevj 's suggestion!

dmesg | more” will show those messages and errors that were displayed on your system console on boot up, from a terminal session window…

Recent versions of Ubuntu require to you run dmesg with “sudo” so more like :

sudo dmesg | more

and maybe even better :

sudo dmesg -T | less
(this will let you scroll UP and down (more will only scroll down) - and “-T” will format the date for humans)

If you’re going to paste the whole output here (of the above command) - can you please format it with the “</>” Preformatted text feature on the topic toolbar - just dumping unformatted text output in the middle of all the other text makes it tricky for us to help diagnose…

1 Like

Wow! Thank you all for the response, its greatly appreciated. That tail end (I guess) of the list I get before log on is about 15 lines and I can not see much more than one line saying something about “error”.
After doing Dan Tripp’s suggestion “sudo dmesg -T | less” I got far more than I was shopping for, whoa! :sweat_smile:, that was going on for a while. I could find lots of error messages around “ACPI” as kovacsit asked mentioned

(added screenshot). Messages I guess about the new MB and UEFI Bios. In addition a lot of messages about bluetooth and (not surprising) nvidia.
I could of course copy/paste the whole list for perousal/debugging here, but I was more in the line of maybe this:
If this means me spending the summer away on the computer and as I have a complete cloud copy of my home folder, how about me just wiping/formatting the entire partition, re-installing a clean copy of Ubuntu, then download my home folder?
I know, a horrible thought for many, but it can be done in under an hour.
But I’ll wait and see what will be the outcome of this.


According to my experience, those boot-time ACPI errors are harmless.
I had similar messages (not so many though) with my previous laptop, a Lenovo Z51-70.

Everything worked fine, it just hurts the boot aesthetically.
Added loglevel=0 to kernel parameters to suppress those messages.

Edit /etc/default/grub file, so that this line looks like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=0"

(For example sudo nano /etc/default/grub )
Save it, then run sudo update-grub and see if it really supressed those messages…
If yes, you’ll see the splash until the login screen appears.

1 Like

It surely won’t solve anything. You’ll reinstall basically the same kernel, which wil give you the same messages with that hardware.
If these messages hurt your eyes, try to add loglevel=0. It won’t solve the problem either, just hopefully cover it. If the messages don’t disturb you to a level that you kinda hate it, you can safely ignore them.

1 Like

:sweat_smile: So, if you could give me, please, a description how to run this in terminal I would be thrilled :). Mind me, I am not very accomplished in this, just asking for help. Sure would help to get rid of that eyesore, though…

1 Like
  1. Open terminal (ctrl-alt-T)
    enter command:
    sudo nano /etc/default/grub

  2. Navigate to the line which starts with GRUB_CMDLINE_LINUX_DEFAULT.

  3. Edit the line, so the text between “” contains loglevel=0

  4. Exit nano with saving the modification (press ctrl-X, and when it asks wether to save, answer yes (Y))

  5. Run update-grub with the command: sudo update-grub

  6. Reboot to see what happened :wink:


OK, I’ll rest assured with that. As I explained earlier I can’t see any problems running Ubuntu as it is now. It is just as fresh and fast as before, it was just a question around these extra lines of messages flashing in front of my eyes before login.
I far prefer and trust Ubuntu above windows for safety and use Ubuntu∕Linux for all office/bank/tax and family related work.


Ran into a bit of a problem:

Note the first slash…


Ah :sweat_smile:
The first slash…

Those lines of messages is still there and I wish I could do a screenshot just when it happens, but it just goes so fast…
Thinking about it; The excitement after the hardware change have settled and everything seem to work just fine and dandy. I have been told here that this is not uncommon, so I think it is for the best I just leave it be and live with it. Take the lessons I have learned here, go on and call it a solution.
Thank you everybody. It’s Foss community is the best!

Hey - stop torturing yourself mate!

Run the “sudo dmesg -T” - and PLEASE DON’T SCREENSHOT IT!

People who take RASTER / BITMAP screenshots of text output are the BANE of my life! IT’S text not imagery!

In your terminal select as much of the ouput from “sudo dmesg -T” as you can, or want (grab it all even :D), then paste it in here - but PLEASE PLEASE PLEASE - format it!

after you’ve pasted it - hit the “</>” (Preformatted text (Ctrl+E) button and format the pasted text so it’s readable…

If you can’t be arsed to format it - I really couldn’t be arse to read it, mate :smiley:


Well, I’m a bit embarrassed here, but in case you still bother to read about this; I tried to grab the whole dmesg -T but it ended up being too large to upload. All saved into a text editor file and I be damned if I know which part is which to solve any which problem :sweat_smile:
Probably silly but I rebooted the computer into Ununtu and filmed the screen to catch the “flash”. Then played, paused and did a screenshot of the last lines as the upper ones already gone dark. Blurry but readable I could see that these messages are nothing like the last lines in dmesg -T. Doesnt know what it’s all about except repeated messages regarding ACPI Bios error with different prefix.
So, a screenshot it is, although a small, weird one :no_mouth:

I leave it here.
Thank you all for all the good help I have received.