Dual Boot Problem with Linux Mint Cinnamon 20.3 / Windows 10

I have been reading about dual booting windows with Linux mint, i’m just a beginner and finally after two days, starting with DVD-r discs that failed, i used a USB drive instead and it worked, I had problem’s finding a usb installer that would work at first, i used Rufus, so from the usb drive i can live boot now, finally after moving the boot order of the usb boot to above windows boot. i installed it the way it shows in the video here How To Dual Boot Linux Mint And Windows 10 [Beginner's Guide] , chose “something else” and partitioned it for root, swap and home, but when i start it without the usb it doesn’t show the screen to boot in Linux or windows and just boots to windows every time unless i use the usb to live boot it. So do i need a boot partition for Linux Mint, but how do i do that now that it is installed with 3 partitions already? on windows do i allocate more free space then just live boot Linux and install it again and add a boot partition? and if i do that will it just overwrite files already there? I made it this far but now i’m stuck.

1 Like

No, you should not need a linux /boot partition. Linux is normally quite happy with /boot as part of the root filesystem.

The tutorial you followed has a link at the bottom

[Home](https://itsfoss.com/) / [Tutorial]
(https://itsfoss.com/category/how-to/) /
 Fix Grub Not Showing for Windows and Linux 
Dual Boot System

You should follow that

Basically what has happened is that the grub bootloader is either not i stalled or is installed but is not being invoked by the BIOS… so you dont get a grub menu where you can choose either Linux or windows. You are just getting the windows bootloader instead of grub.

Follow the link. This is quite easily solved. You have done all the hard work


This page should be of help:

Thanks for the help. It’s working now. I saw the post about the boot order before but when I tried to change the boot order it wasn’t giving me an option in the UEFI Firmware the first time i installed Linux to the unallocated partition. I just had to play around with the advanced settings in the Rufus app, so after installing and uninstalling the ISO file to the USB drive with different settings applied in the Rufus app several times I finally found the correct settings. I had to enable an option to “Add fixes for old BIOSes” and I had to change the format from FAT32 to NTFS in the Rufus USB installer app. When I did this I could see the option in Firmware screen then to change the boot order, then on startup it gave the option to choose Linux just as in the video, followed the partitioning instructions from the video during the install, restarted it and now everything works just like it’s supposed to.

1 Like