Dualbooting of windows and linux already installed on separate ssd and hdd

Hii name is Prakhar.I am a student and linux user.I have used it since around more than 1 year. My system acer aspire ES1 572 256GB internal ssd(windows 10) and a external hdd 1 tb(linux instaled} So in my hdd i have already linux installed and windows 10 on ssd.Some times before i have only hdd so made hdd external and installed on laptop with windows .but problem is i can’t access my linux now ,hdd is fully in good position .how to dual boot both? Even i tried to find linux on boot menu but didn’t find.So please help me as i don’t want to install anything. I have already ssd on windows and linux on external hdd.my windows boots fully without any eror. there is also a problem in my laptop isn’t it causing the eror. [[Fixed] "No Bootable Device" Error After Installing Ubuntu] ([Fixed] "No Bootable Device" Error After Installing Ubuntu)

So you are running the HDD via usb port? In my experience with laptops with single drives, it is far easier to run Windows and Linux from the same boot drive. Just shrink the Windows partition and install Linux in the unallocated space. Install and use grub for the boot menu.
Better yet, is too install VirtualBox in Windows and use Linux in a VM.

I too would go with just one drive as suggested.
If you then try mint on installation it does ask put along side existing windows system and it resizes automatically saves a lot of fuss

That seems to indicate that you have grub installed, but its configuration does not include linux, so linux does not appear in the grub menu.
it may be that you dont have grub installed, and the boot menu you see comes from somewhere else.

Can you verify that grub is installed, and can you tell us which disk it is installed on?

Got exactly same problem and this what i do to fix it, remove windows hdd installation and try booting only with linux (mint in my case) if you successfully boot with linux turn off your pc and put windows hdd back and go to bios and make sure linux is your default boot, if you can’t see the windows boot just ignore it and restart your pc. After success boot into linux go to terminal and run “sudo update-grub”. Linux should automatically find the windows grub, and when you restart pc there should be grub menu to choose between linux or windows.


Welcome to the “It’s Foss” @ted.
This suggestion for the problem sounds like an easy solution.

Well, assuming OS prober is enabled for GRUB. By default OS prober was enabled, since Ubuntu 22.04 it’s disabled by default (and I think that applies to derivatives too), so you need to take some actions to reenable it.


GRUB_DISABLE_OS_P{ROBER=false to enable =true to disable