Epson LQ1070 Dot Matrix Printer not being identified by Ubuntu

I am running the latest LTS version of Ubuntu and I am trying to install an Epson LQ1070 Dot Matrix Printer on my PC. However, it is not being picked up by Ubuntu. I cannot find a suitable printer driver online but has anyone been able to get the printer to work on Ubuntu? How was it done? Please advise.

Give this a shot.

yes that will work
@MikeSA use the link sent by @7blade

Thanks for the responses. I am afraid I have not been able to the printer working. What @7blade has suggested, I have given it a shot but I cannot find a workable driver on the link. TypeHrishi you say it will work but can please explain to be how to make it work. Thanks.

What version of cups are you using?
Have you tried using a generic driver?

Thanks for the response. Although the Epson LQ1070 printer is listed as supported on the Omni database, I could not make head or tail what I need to do to install the driver. Neither could I make head or tail of the instructions to install CUPS as I am not really clued up to be able to effect the various commands.

However, I happened to click on Ubuntu Software and then on Productivity and there I found CUPS. I then clicked on INSTAL and CUPS was apparently automatically installed. There is no indication what version of CUPS was installed but on the CUPS.ORG website, it appears that the current version is 2.3.3. I assume Ubuntu had installed this version.

Subsequently, after restarting, I clicked on ACTIVITIES > Printers but Ubuntu had not picked up the Epson LQ1070 printer. In consequence, no document could be printed and instead just an error message is displayed.

I searched further online and came across a download for a Generic IBM Dot Matrix Printer and installed it. But that did not work either.

Now when I click on **Activities > Printers, only the following is displayed;

Generic IBM Compatible Dot Matrix Printer

Yet the driver does not work at all.

In the circumstances, it is probable that I am not doing something right. Can you please advise further. Thanks.

It might be that a different printer driver will work.
I vaguely recall that Epson used a single driver to cover multiple models.
They weren’t 100% but they did work.
Have you tried the LQ-570 driver?

Bottom of that page.

The Epson LQ570 Printer is similar to the Epson LQ1070. The only difference is that it a 9pin printer whereas the LQ1070 is a 24-pin printer. I therefor did install the driver for the LQ570 but it also did not work.

Both the LQ570 and the LQ1070 have a parallel interface but my printer is connected to my PC via a parallel to Serial cable as my PC motherboard does not have a parallel port to which to connect the printer directly. But whether I choose to connect to an LPT port directly or to a COM port, it still does not work. Could this be the problem and, if so, would I have to install a parallel port card on my PC? Would that resolve matters?

On the other hand, it is probable that the printer is simply not compatible with a Linux operating system and the only solution would be to get a printer that will work with Linux or switch to Windows. Would you agree?