Epson Stylus SX420W - How to calibrate Scanner in Mint

Dear Friends,
I already installed the printer and scanner drivers, I had a problem with the scanner because the distro changed name the of libsane to libsane1 but I already solved this matter and both printer and scanner work well but the scanned files have a grayish/bluish color instead of a white hue
I already disassembled the scanner, cleaned the lamp and glass but the result is the same.
If I scan and print ( at the same time) the whites is really white.

So I ask you:
Can I calibrate the scanner through software with Linux Mint?
I already tested with simple-scan, xsane and iscan and the results are the same

Example of the scanned file:


This is the only tip I found but I think this cannot be applied to Mint:
https://help.ubuntu.com/stable/ubuntu-help/color-calibrate-scanner.html.en

1 Like

If it works on Ubuntu it will usually work on Mint . You could also try this page https://epson.supportprinters.net to get support by searching on it for your printer number. Epson are usually pretty good with things for Linux of all flavours

2 Likes

it is more of a workaround than a solution, but on my epson (xp-446) i have the option to scan directly to an sd card. of course the options are limited and i usually just use the default auto crop because i can always fix the edges of the scan in my image editor.

1 Like

@ElectricDandySlider and @cordx,
Thanks for your tips

2 Likes

i was playing around with my scanner again yesterday and was reminded of this thread. did you ever get any resolution for this? in all three distros that i tried (ubuntu mate, debian 9 and antiX) i get the same blue tint that you showed in your initial post. it just feels like somehow that regular white paper color is being misread by the os.

1 Like

@cordx,
I haven’t any solution yet
I tried with WIN10 and If I choose option “photo” to scan the same document I got it blue instead white but if I choose “document” I got it white…
I still haven’t give up on finding a solution for this problem but know this topic is in “standby”

1 Like