Error message appearing in running install, update or upgrade command

O.S. Ubuntu 20.04 64 bit

While installing signal messaging application through command line ( as suggested in the online guide line ) I entered one command line. Due to which Signal is not installed, rather an error message is appearing on every install, update or upgrade command.
The screenshot of the terminal is as follows:
$ sudo apt install nautilus-image-converter
[sudo] password for mfskanpur:
E: Type ‘“deb’ is not known on line 1 in source list /etc/apt/sources.list.d/signal-xenial.list
E: The list of sources could not be read.
E: Type ‘“deb’ is not known on line 1 in source list /etc/apt/sources.list.d/signal-xenial.list
E: The list of sources could not be read.

Please guide in the matter.

worked out of the box for me…

sudo apt install nautilus-im<tab>

(i.e. ZSH command line completion knows there’s a package “nautilus-image-converter” and finishes my sentence for me)

sudo apt install nautilus-image-converter

So you say you’re running 20.04…

But your apt databases seem to think you’re running 16.04 (xenial).

I’d suggest maybe you move /etc/apt/sources.list.d/signal-xenial.list somewhere else :


sudo mv /etc/apt/sources.list.d/signal-xenial.list /var/tmp/.

then update your apt

sudo apt update

then re-attempt install nautilus-image-converter :

sudo apt install nautilus-image-converter

But - now I’m really confused dude, what are you wanting to install?

“signal” or “nautilus-image-converter”?

I’m assuming you read some RUBBISH from a few years ago about how to install “signal” which was written for Ubuntu 16.04 users - but you’re on 20.04 and it’s probably irrelevant… doing that shit will break your Ubuntu install… don’t do it unless you’re 100% sure of what you’re doing!

the amount of times I’ve had to come along after some “developer” (i.e. stack overflow IP thief) has pasted bunches of shit all through the app config files, e.g. directly into /etc/apt/sources.list, and then had a big sook when they broke their server… I’ve seen MORONS paste stack overflow google-fu “help” apt stuff for Ubuntu into /etc/apt/sources.list on A DEBIAN SERVER! These f–kers never even got their computer license, never mind how to use text editors, or do a professional’s job…

Dear Sir,

You are very right. In fact, initially this mistake occurred when I was installing Signal ( Social Media Application ) on my Ubuntu 20.04 desktop. You have really caught the mistake. While giving command in installing Signal, in the command version Ubuntu 16.04 has been added ( because it was written by the sender ). But in fact I am using Ubuntu 20.04.3 ( the latest update.

Later on when Mr Abhishek Peakash in his regular It’s FOSS letter provided to install nautilus-image-converter; I issued the command

sudo apt install nautilus-image-converter

Now please guide me how to remove the line

echo “deb [arch=amd64] xenial main” | sudo tee -a /etc/apt/sources.list.d/signal-xenial.list

from my command history so that this so-called problem is solved.

Awaiting for your reply in the matter


mfskanpur ![:pray:]

Don’t find the line, or removed the line, or edit the line, just REMOVE the file like I suggested in my first reply :

That doesn’t “delete” it per se, it just places it somewhere “else” where apt cannot see it… After you remove it (move it elsewhere) run :

sudo apt update

and you should no longer see that message about xenial…