ethernet not working

Ethernet not working is there a work around in the network apt no wired but wireless using ubuntu budgie


and twenty characters.

can you provide some more details? there’s not a whole lot to go on here.

1 Like

installed it on raspberry pi 8 gb the wireless is good but the ethernet is not and does not show up on the network apts

what did you install? which distribution and which version of that distribution? which version of the pi might also be helpful. 3, 4?

can you run the command lspci -v | grep -iA6 network and paste the output in your response?


So you’re running a non-standard O/S on an RPi 4B with 8 GB of RAM? I tried Ubuntu on mine, wasn’t happy with it (e.g. running a last decade tech 4.x series kernel) - so I reverted back, again, to Raspbian / RaspbiOS… (but then removed Pixel and replaced with XFCE - which doesn’t give me a GUI to manage my ethernet - but I’d already set it to use DHCP from the Pixel “default” GUI during the initial install “wizard” on first boot).

Does this build of Ubuntu Budgie for ARM still have the “raspi-config” command? Was this from a “pre-rolled” image of Ubuntu Budge for Raspi (or did you boot the server build of Ubuntu for arm64 on Pi3/4 - then install Budgie using apt commands)? The builds of Ubuntu I’ve tried on both my RPi4 computers (I’ve also got a 4GB model) both came with the ability to use “raspi-config”.

Show us the output of either

“sudo ip a”


“sudo ifconfig -a”

I reckon you’ll have a device there (e.g. “eth0”), but the non-standard GUI doesn’t support management of ethernet in the GUI.

See if you can configure ethernet using raspi-config…

1 Like

I’ve read somewhere, that distributions for the Raspberry Pi usually offer raspi-config in the repositories (probably from the official Raspberry Pi respositories). So, even if it is not installed, there is a chance it still can be installed and used.