Fedora 36 won't update the kernel to 5.17

I’m running Fedora 36 on a VM on my M1 Mac. It’s running 5.11 and I’ve tried various command line ways to update the kernel with no success. Shouldn’t I be running 5.17? I’ve checked GRUB and 5.11 is the only available kernel.

I dont know fedora, but normal practice is to use the package system to do updates. Does your package system have a system update command? It should.
Maybe if your fedora version is very old, it will no longer do updates? Is fedora 36 old?
Grub can only see what is there. It will not do the update.

Yes, the updates have been running with regularity. In fact, I just ran a system update earlier today.

That means kernel 5.17 is not being distributed yet by Fedora 36.
They must have a reason.
It would not be wise to update it contrary to their package system

Well, Fedora advertises that 36 comes with 5.17.

I dont understand why you dont get it then.
Look in /boot… you can see what kernels you have.

Are you sure you have the correct repository for fedora 36?

5.17 is really new. My Void linux has 5.15 and it is rolling release.

Maybe their advertising is false. Check somewhere else.

Maybe this problem has to do with the fact that I’m running it through Parallels on an M1 Mac. Perhaps the ARM AArch64 won’t work with 5.17.

Nope. My own theory is inaccurate. I installed the KDE version instead of Gnome. It is running 5.17 right out of the box.

Thats weird, but congratulations, you solved it
Apparently the people who make the iso’s with different desktops have got them out of sync

Maybe not. I’m noticing that I cannot install Parallels Tools. Normally, I need to run all updates first to install Tools, but in this case, I’m unable to run updates. It says there are updates but it always says Fetching Updates and nothing every happens, the bar won’t move or progress.
Fedora 35-Gnome is installed through Parallels and then it updates to 36. Maybe 5.11 is the only kernel that currently works with Parallels.
Too bad Fedora doesn’t have the kernel manager from Manjaro. That is so much easier than the process Fedora offers for kernel updates and adding or removing kernels.
I’d upload screenshots, but your system won’t allow me since I’m a new user.

1 Like

This is a bit new to me. Debian keeps the same kernel unless there are serious security issues. Void updates kernels all the time, but there is no special kernel manager process, it just happens as part of the package updates. Every distro is different.

So I assume you were running an ARM64 / aarch64 version of Fedora 36?

I gave up trying to emulate on my M1 using VirtualBox, but then ended up buying the pro version of UTM (A LOT cheaper than Paralllels or Fusion) - and got it emulating a Sparc and running Solaris 9! I think UTM just uses QEMU, which is probably most varied CPU emulator ever invented!

I now also have an Intel MacBook (air) on my desk with a fully licensed VMWare Fusion (from my employer), but its a clunky i3 or i5, only 8 GB of RAM and 256 GB SSD - tried running a Windows 10 image on there - WHAT A CLUNKER!

Pretty sure my Thinkpad E495 Fedora 36 is running Kernel 5.17 - but haven’t turned it on for a while - got too many computers on my desk…