File rename with slow double click, i.e. click, count like 3 seconds, then click again

I first remember using this “feature” in Mac OS (16 bit OS 6.x or 7.x on 68000 Macs) and I loved it! And I was jealous we didn’t have this in Windows 3.0 and 3.1!

Windows didn’t get this functionality till Windows 95.

The first iterations of X Windows I used already had this feature, before Windows 95…

Some fucking genius at either Gnome, or Canonical, decided Linux users didn’t want, or need this “feature”. Just been hunting around - I seem to remember there was a way to enable this in Nautilus, but - no! They’ve completely removed it. Nemo users still get it, but I’m not jumping distros just to get nemo (it won’t install on 20.04 - and I am NOT installing it via PPA).

In nemo :


([ ] Click twice with a pause in between…)

Just read another forum (some other ubuntu forum) post where some ILL INFORMED MORON reckoned that its not enabled in Linux because its a Windows feature? Yeah fuck right off with your ill informed opinion!

I remember using this in X Windows running on Solaris!

I’m not asking for help here, I barely ever use the file manager anyway, to rename files (I vastly prefer using bash/zsh, and I love the “perl” rename command [lets you use regex to rename files in bulk]) - and - if I want to use a file manager to rename shit, I can just hit F2, or right click and rename, but what was so wrong with slow double click? If it was REALLY SHIT idea, Apple would have disabled it by now… I’m having a sook, a whinge, a whine! A good old fashioned spleen vent!

1 Like

Indeed, ill informed. Having any Windows feature optionally available in Linux is a huge plus. This especially is useful when comparing Windows to Linux while talking with people who think about switching.
Imagine a comparison chart, where half of Windows’ features are simply crossed out on the Linux side…

That said, I’m not sure how this functionality works on Linux, but I know how it works on Windows.
To be precise, you do not have to “slow double click” the item. The point of this feature is, that something that is marked/selected with a single click, can be renamed any time after it being marked, with another single click. Theoretically, you could wait an hour between the first and the second click, so it’s not really anything you have to actively wait for, as it has nothing to do with time.
I use this feature all the time and it’s useful due to how it works in the way described above. If I check out an item for whatever reason, marking it in the process, I can rename it any time within the whole situation of checking the item out, by just single clicking it, again.

3 Likes

I guess, it depends on the file manager, you’re using, not on the operating system.

E.g. in Dolphin (KDE default file manager), you click on the name and with a second click (not as quick as a double click for opening), the name becomes editable.

I just did a quick tryout :
dolphin
thunar
pcmanfm

none of them seem to have the feature I want…

dolphin also doesn’t show ANY icons for anything (e.g. folders) just blank space where an icon would sit
thunar doesn’t have the feature
pcmanfm doesn’t have the feature

I reckon if I want this feature, & I can’t live without it - I’m going to have to install Nemo via PPA… I don’t want it enough to install Mint though… It’s just annoying that something so simple, has been arbitrarily moved! I remember a few years back, the Gnome developers were actually considering REMOVING the X Select Buffer (i.e. drag select, middle button paste, text) until an outcry almost kicked off a lynch mob of angry users… Who are these people? Are they even people? Are they cybernetic aliens like Mark Zuckerberg?

2 Likes

Seriously?

It is available in Ubuntu 20.04, without the need to use PPA. I’m about to run Ubuntu 20.04 in VirtualBox, see if I can get it installed. I use Nemo in every OS I try out in VirtualBox, never tried it in Ubuntu only in other Ubuntu derivatives. Bare with me whilst I get Ubuntu installed, bloody massive ISO 3.1GB. I suppose it’s all that Snaps rubbish? Give me an hour or so, because no doubt it still has that annoying Apport Error messaging which I’ll switch off.

The reason I think I need to go down the PPA route, is that in my Ubuntu 20.04, I have unmet dependancies, which don’t get fixed by “apt install -f” or “apt install --fix-broken”, and when I try to manually install that dependancy, I get into dependancy hell (i.e. package x needs A, but A needs y, and y needs B, blah blah blah)…

sudo apt install nemo
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nemo : Depends: libgail-3-0 (>= 3.0.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

i.e. (apt install -f doesn’t fix) if I try to manually install libgail-3*, I get further unmet dependancies - and it becomes a case of “WHEN WILL IT END, OH PLEASE GOD LET THIS END…

1 Like

Have you installed with ext4 or zfs is it zfs the name of the optional file journal???

What version is your Ubuntu 20.04 is it a server version?? As I have installed from terminal in Ubuntu via virtualbox Nemo.

20.04 desktop (i.e. the default Gnome 3.x “experience”).

I’m using ext4 on LVM on this system, I very much doubt its a file system issue preventing me installing, it’s dependancy hell (or maybe limbo, or pergatory)…

@Mina

I’m not blaming Dolphin for this - it obviously needs a bunch more stuff, and it may not like the icon set I have installed… But in this state, its not usable…

I’m thinking the quick answer to my woes is to figure out how to make Nemo work on my system…

1 Like

True, this looks like complete shit…

OMG! (language)

1 Like

It should of downloaded a load of Cinnamon stuff gsettings and the like.

What a teeny talk. Watch your language! :laughing:

4 Likes

No wonder I gave up on Ubuntu altogether. Got bidirectional setup in VirtualBox, apparently error comes up saying not allowed. Why to hide desktop icons do you have to install Gnome-Tweaks? When all I have to do on my main machine is right click the desktop and go into Desktop Settings. Jeez

I just installed as ext4 and it installed Nemo no problem.

It would not let me drag and drop this picture, so took photograph with half window off of my Mint XFCE.
This next picture is Ubuntu 10.04 and that let me drag and drop in VirtualBox. How I wish Ubuntu stayed this way.

1 Like

Hey man… I should have told you earlier…

You really didn’t need to go to all that trouble man! Sorry!

I have a “newer” instance of 20.04 on my Thinkpad (those dependancy issues were on my older “build” of 20.04 on a desktop Ryzen 7 system)…

But hey - thanks!

I installed it on my Thinkpad running 20.04 and - I can set slow double click rename in preferences in Nemo… was that so hard? No! Why Gnome 3.x and Canonical did you think it should be removed?

I think my Ryzen 7 desktop system has its apt database knickers in a twist. Might be overdue for a rebuild. Rebuild is never a big issue as 95% of my data is in the cloud (or sync’d to my self hosted cloud solution).

2 Likes

No worries, you probably know this already but here is how to set Nemo as default

To run the desktop background settings

gsettings set org.gnome.desktop.background show-desktop-icons false

To have it run as default file manager

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

To have Nemo setup to open with Terminal

gsettings set org.cinnamon.desktop.default-applications.terminal exec Name Of Preferred Terminal