Firefox update notification

How can I prevent the " Firefox update checking " window from bothering me ?

I tried deleting updater.ini & Co in the Firefox folder , that did not help .
The solution with “policies.json” that I came across online, did not work either .

Here is a list of preferences I changed in " about:config " , without result : —> false
app.update.enabled —> false
app.update.silent —> true
app.update.timer —> false —> false
app.update.doorhanger —> false
app.update.disable_button.showUpdateHistory —> false
app.update.staging.enabled —> false
app.update.interval —> 9992000
app.update.badgeWaitTime —> 9992000
app.update.promptWaitTime —> 9992000
app.update.timerFirstInterval —> 9992000
app.update.checkInstallTime.days —> 9992000 —> false —> false —> 9992000 —> false —> 9992000

Any ideas ?

Does it pop up on every boot?
Is your Firefox up to date?

Doesn’t this make it worse?

it made no difference ( for the short time I tried it )

How long does the window pop up for?

How exactly?

I turn on the computer, into Linux Mint .
After an hour or so that Firefox is active, the update window pops up until I click on it to close it down .
It then stays away for the rest of the session .
The next time I start up the PC , after an hour or so that Firefox is active, the window pops up again and stays open until I click on it to close it down .

Completely remove Firefox and install the newest version.

1 Like

Weird, I don’t think I’ve ever seen a Firefox update message box since I stopped using Windoze?
Firefox updates do appear in Update Manager but only after I open it when I notice there are a number of updates. (or more likely I notice update manager no longer has a check-mark) After updating I do get Firefox nagging me to use the update though (Firefox needs to restart, etc) I usually do a complete reboot of computer (well, I usually turn computer off until next morning, seems to improve memory use?)

Thanks to all who responded to my question . I have finally found a working solution .
I had already read online how one can turn off Firefox application updates ( see ) .
The reason that this didn’t seem to work with my Linux Mint is because I tried it out in the Remaster ( LiveCD frugal install ) I use for safety .
More than 99% of tests of whatvever I want to experiment with, can be successfully done in the LiveCD system .
Disabling Firefox application updates belongs to the 1% that only works if applied directly in the mother system, that is installed on the hard drive .
The moment I placed the policies.json file in the Firefox installation directory under \distribution\ , it not only worked in the mother system but also in the remaster I made of it .
Problem solved !