Firewall Configurator app won't stay open

Recently switched to LMDE and I just tried opening the Firewall Configurator and it’s visible for a second or two and then disappears.

I found a thread on the Linux Mint forum that addressed a problem of a missing Firewall app from the GUI list. I ran the following command out of curiosity and I don’t know what to do with resulting information to fix my problem:

gd@red1:~$ sudo gufw
[sudo] password for gd:
/usr/bin/gufw: line 2: [: =: unary operator expected
ls: cannot access ‘/usr/lib/python*/site-packages/gufw/’: No such file or directory
No provider of eglCreateImage found. Requires one of:
EGL 15
/usr/bin/gufw-pkexec: line 10: 2220 Aborted (core dumped) python3 ${LOCATIONS[${i}]} $1


According to this bug report:

The issue is fixed in gufw version 20.04.1-3.

Could you please check if your gufw version is higher than 20.04.1-3?


I have version 20.04.1-3. It looks like my mirrors aren’t using the more functional version of the firewall.

d@red1:~$ apt-cache policy gufw
Installed: 20.04.1-1
Candidate: 20.04.1-1
Version table:
*** 20.04.1-1 500
500 | powered by Leaseweb bullseye/main amd64 Packages
500 | powered by Leaseweb bullseye/main i386 Packages
100 /var/lib/dpkg/status

typo…I have 20.04.1-1…not 20.04.1-3 as I typed incorrectly.

What is the easiest way to install the newest version of an app that currently isn’t packaged in LMDE 5?

Does anyone know if this problem would be eliminated by updating to LMDE 6?

There is no easy way, and it may turn out to be impossibly difficult.
What you have to do for a package not available in the package system is start from the source code and make your own port by compiling the source code. You need a knowledge of the language it is written in, plus you will have to use tools like automake, configure and make. Porting is a lot of work.

It would be far easier to install LMDE6, or there may be a method to upgrade LMDE5 to LMDE6…

1 Like

Thanks Neville. I found a few sources talking about using “backporting” but the suggested command lines didn’t work for me. The example was for Debian Stretch, not LMDE elsie, so I decided to stop there.

I’ll try LMDE 6.

Thank you for the linked article.

Best regards,

1 Like