Francesco Bizarro

No - not really the mass-murdering conquistador (they were all mass murderers weren’t they?) - more “bizarro” :

Had to reboot (pull the power) on my Orange Pi 2E+ running Armbian 16 (yeah - you read that right - ubuntu 16 for arm7l) earlier today - it just wasn’t “appearing” - tried a bunch of different ethernet cables… Issue earlier this week when I tried swapping in my old modem/router… got a different DHCP lease and my old NAT rule stopped working…

So I fired up “armbian-config” and set it to static IP address… Bang! Then set my NAT rule to go to that one… Bang!

Later that day? Somehow the pezzo di merda had reverted to f–king DHCP! WTF? OK - no dramas - change my NAT rule to point to the DHCP lease IP (which is a static one the DHCP server on my router)…

Today - this morning - pezzo di merda didn’t respond to ANYTHING - different ethernet cables, different ports on the gigabit switch - zip - nada - dead as a doornail… Doh! This thing - on last count had about FOUR HUNDRED AND FIFTY days of UPTIME!

Ethernet lights would flash on the board - but no “life”.

Hooked up a keyboard and a HDMI monitor - and - it boots - and it’s been so long since I deployed it - I’d forgotten it was running a GUI! And it’s set to autologin - YOU BEAUT! Use the desktop NM doohicky to connect to WiFi - YOU BEAUT! I think it’s a variant of Xubuntu (XFCE)…

Plug ethernet back in - says it’s dead! Doh! So I try setting static IP address (using “sudo armbian-config”) and bang - it works!

Come back 2-3 hours later - and it’s BACK ON F–KING DHCP?

Maybe it’s time to upgrade / crossgrade to something else to run Transmission-Daemon? DietPi might be a go… A shame - I built this thing BEFORE COVID! Well before - last decade!