Ftpd glob issue

I have 2 computers.
I use ftp to transfer files between them
Lately the ftp command mget * has stopped working, i get a message
“Cant check for file existence”
But a get command with a nominated filename still works

I went googling and found

So my daemon pure-ftpd does not support filename globbing any more.

Does anyone know of another ftp daemon that will allow mget ?

1 Like

I searched for pure-ftpd alternatives and found this.


One of the things they mention is Filezilla, but I don’t know that it can be used as a daemon like you’ve used pure-ftpd.

1 Like

It says
“The server is completely open-source and comes with the FTP servers”
so there must be a daemon. I shall look

That is a good list of alternatives
The other interesting one is Vsftpd… If it goes across Unix and Linux it must be near to generic.

I’ve used the Filezzilla client, but NEVER tried the server version which would be easy to get to start up during boot up. If you try the server version, I’d like to know how easy it was to setup. I never even heard of pure-ftpd. Filezzilla can us TLS as well for secure connections.

1 Like

The filezilla server is not available as a package in any of my distros. I will have to download it from the website and do an install outside the package system. I will do it just to see what it is like.

I have settled on vsftpd for my server. I have it going in MX, Void, Devuan, and Debian. . The package install set up the daemon autostart , except in Void, where I had to use runit to autostart the daemon.
It does mget * properly, so I am happy with that. It has a config file /etc/vsftpd.conf. The default seems fine for home use.

I use the plain old ftp as my client. But I do have filezilla in one distro, and I can verify it works fine with vsftpd as the server.

So , If you wanted a ftp server, I dont think I would bother with filezilla… just use vsftpd and all the setup will be done for you. You dont need a gui for the server.


I tried it. Downloaded the file
So it is a Debian specific package. There is a pdf manusl, but you have to pay. So it has a bit of a non-FOSS smell about it.
I tried in Devuan
`dpkg -i FileZilla_Server_1.6.6_x86_64-linux-gnu.deb’
It did the install, but one of the post-install scripts gave the message

/var/lib/dpkg/info/filezilla-server.postinst: 112: systemctl: not found
dpkg: error processing package filezilla-server (--install):
 installed filezilla-server package post-installation script subprocess returned error exit status 127

So it is looking for systemd commands which Devuan does not have.

I decided to go ahead anyway. Had to search, it is in /opt

root@trinity:/opt/filezilla-server# ls
bin  COPYING  etc  lib	NEWS  share
root@trinity:/opt/filezilla-server# ls bin
filezilla-server		   filezilla-server-gui
filezilla-server-config-converter  filezilla-server-impersonator
root@trinity:/opt/filezilla-server# ls etc
allowed_ips.xml  disallowed_ips.xml  settings.xml
certificates	 groups.xml	     users.xml

So I ran
filezilla-server &
and the daemon ran
then I ran
filezilla-server-gui &
and I got a gui admin window
then I ran
and I got a config window.
Used config window to setup a user and tried to ftp from other computer.
I was able to login, and could do get of a single file but it would not allow mget *.
So filezilla-server is the same as pure-ftpd - they have both gone security mad and disabled a feature that had been in ftp for over 40 years.

So goodbye to pure-ftpd and filezilla-server. I am going to use a daemon that works - namely vsftpd

just about every modern web browser has disabled ftp access… big brother nanny state bullshit IMHO…

That concerns me too., although I just want to use ftp on my local network at the moment.

Why not use ssh/scp ? Well in a multiboot computer, every time I move to a different OS ssh complains and says some key is wrong, so I spend half an hour setting up a new key when all I want is a couple of files from the other computer… Ssh just doesnt cut it in a multiboot scene.

I am leaning towards going back to rsh/ rlogin/ rcp. I could tar whole directories across the net with that.

I only use FTP for one thing - to scan documents (or images) from my Brother MFC - to BSD’s FTPD running on my TrueNAS box… Nautilus in Ubuntu and Mac Finder still both support FTP… I wouldn’t be surprised if they’ll be lopped off eventually, those KNOBHEADS at Nautilus or the Gnome foundation in their infinite wisdom (arrogance more like it) decided that slow double click rename should disabled in Nautilus, with NO option to enable it again! Pure arrogance… It used to be there in “Files” on Ubuntu - then one day it wasn’t there! Why? Windows and Mac have that…

Doesn’t really matter - 'cause the FTP location I write JPG and PDF to are also on SMB and NFS shares… But all this hairpulling over FTP, when it’s only running INSIDE my LAN! It’s annoying…

My feeling exactly.
All I ever do is use ftp at command line to get files from my other local computer.
I may have to freeze the source code of vsftpd, just so I can have my own version that does mget

Found this
“Instead of asking why a piece of software is using 1970s technology,
start asking why software is ignoring 30 years of accumulated wisdom.”