GIMP 2.10 Scanner?

Just wondering why no scanner is shown in GIMP 2.10 “Create” menu option. Only “From Clipboard” and “Screenshot” show.
All the other applications show the scanner but not GIMP.

Linux Mint 20
Brother MFC-J995DW All-In-One Inkjet Printer

1 Like

Perhaps they dropped this feature from version 2.10?

Not likely. Why would they do that?
It works in windows 10 with the exact same hardware.
Any known source for GIMP 2.0 for linux mint?

Surely NOT.
I use it regularly (GIMP 2.10.8. on Debian)

Maybe sane/xsane is not installed?
Maybe GIMP isn’t installed from a .deb package, but ran from appimage, or flatpak?

I’d try Kesselgulasch ppa, used it for GIMP while we where on Ubuntu/Mint:

Reading a bit more, that may not work for you, in that case try from this ppa:

I use Gimp 2.10.18 on Kubuntu, installed directly from the software centre, and I get the same dialogue as @kovacslt (just not in Hungarian :wink:), being able to scan directly.

If I were you, I’d try to update or reinstall the program from your software centre.

I’m running Mint 20 and Snaps is not an option, so here is what I done to get the create back was go here Pick the latest version which is 2.0.4 the 2nd one up from the bottom.After download Unzip it open it and open a file called scripts. Ctrl+a on your keyboard to choose them all, right click and copy then open up a terminal and type sudo nautilus in Ubuntu, pop password in go to usr/share/gimp/2.0/scripts and paste them in there. Close window. Back in Terminal add this ppa
sudo add-apt-repository ppa:ubuntuhandbook1/gimp This updates your scripts properly and Gimp will run just like Gimp 2.8.
After adding PPA sudo apt update
then sudo apt upgrade

First, I want to thank ALL posters here.
I tried uninstalling - reboot and reinstalling, this time from the Kesselgulasch ppa but the issue persists.
I have xsane installed but that is not the solution and I don’t care much for it.
Everything else (vuscan, document scanner, etc) that can scan does scan properly except for GIMP, which doesn’t show any scanner.

I don’t know Document scanner, but Vuescan is using it’s own libraries to handle scanner hardware, regardless of SANE installed or not. Vuescan happily works with scanners SANE does not support.
GIMP on Linux needs Xsane and SANE be installed, otherwise it won’t scan. On Windows, I guess it uses Twain interface.
So install xsane, that will bring sane as a dependency too. And then you’ll see the “device dialog” menu in GIMP.
Another question is that if SANE supports your scanner? If not, you will read in Xsane, that there’s no scanner found, or similar.

After many, many varied attempts to get GIMP to see my scanner.
I removed my current install of GIMP made using the snap store.
Used terminal commands;
Rid myself of the old PPA
sudo apt install ppa-purge && sudo ppa-purge ppa:otto-kesselgulasch/gimp
Add the new PPA
sudo add-apt-repository ppa:ubuntuhandbook1/gimp
Update the list
sudo apt update
Install GIMP 2.10.22
sudo apt install gimp gimp-gmic
Install xsane
sudo apt install xsane
BINGO - Scanner in GIMP
Kept getting the error: “Error during CMS conversion: could not open scanner ICM profile”
BUT-Scanner still worked ?!?!?!?!?!
CMS - Can’t Make Sense?, Custom Made Shoes?, Ah, How about, Color Management System?
ICM - I Can’t Make It? (too many letters), Insane Constant Migraines? MAYBE, More like, Image Color Management.
Opened XSane’s scanning dialog, then opened Preferences and voila “Enable Color Management” was checked so, I UN-checked it. No doubt XSane was looking for a non-existant file.
Now NO MORE ERROR MESSAGES and all is shinny.
NOW I can scan images directly into GIMP.
Side effect, GIMP now loads like a rocket. File, Create, XSane, scanner shows as it should.
Special thanks to those here who gave me great guidance.