Gnome desktop icons - is it possible to lock the size

I am using Ubuntu 18.04.4 gnome 3.28.2

The size of icons on the desktop seems to be be controlled by the sizes of icons in Files.
While I need to occasionally change the Files icon sizes temporarily to view picture thumbnails etc. that action also changes the desktop icons. This is often irritating.

Is there a way to lock the size of desktop icons such that any change in the Files icon size would not affect desktop icon size?

Thanks.

1 Like

This is possible in Ubuntu 20.04 for sure. Not certain about Ubuntu 18.04.

Do you really use the desktop icon? You may choose to disable it altogether.

1 Like

Don’t understand. What do you mean by “disabling the desktop icon”?
My desktop is always littered with many documents folders and misc items – all work-in-progress.
All these get bigger or smaller depending on how the icons are inside Files app.

According to OP, if you change the file icon size from 50 to a higher value through the 3 dots menu, it will affect on the desktop as well. If you change the Files > Desktop folder icon size to 50 ( default ) to 100, the icons in desktop will inflate accordingly ( and not in an aesthetic way as well ).

OP is trying to stop this inflation linked to Nautilus/ Folder icon resize.

It is possible to make sure that your desktop ( not Home > Desktop through Nautilus ) has no icons. There is a turn off option in " Tweaks " tool which you use to change themes.

Yes, that is possible. But only as a workaround for now.
Thanks.

Noted. Thanks…

1 Like

I finally solved it. I can now resize the icon size in the Files without it changing the icon size on the desktop. Here is the solution:

  1. As your normal user run this command:
    dconf read /org/gnome/nautilus/icon-view/default-zoom-level
    Take note of the output, for me it is:
    ‘small’
  2. Use root user for the rest of the steps below:
  3. Ensure that this file:
    /etc/dconf/profile/user
    contains at least these 2 lines(it may have others after these 2 lines, leave them there):
    user-db:user
    system-db:local
  4. Create this file:
    /etc/dconf/db/local.d/01-icon-view
    with these contents:
[org/gnome/nautilus/icon-view]

# After the = sign use the output from the cmd in step 1 for me it was 'small'
default-zoom-level='small'
  1. Create this file:
    /etc/dconf/db/local.d/locks/00-default-zoom-level
    with this content:
    /org/gnome/nautilus/icon-view/default-zoom-level
  2. Run this command:
    dconf update
  3. Log your normal user off GNOME.
  4. Log back in again as normal user.
  5. Use Files and change the icon size by clicking the hamburger icon and then clicking the - and + next to the percentage. The icon sizes will now change in Files but stay a fixed size on the Desktop.
2 Likes