GNU Grub Error whenever I Turn on my computer

Recently my CPU stopped working so I got it fixed and the moment I turned it on it shows a black window stating-

GNU GRUB version 2.02
Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

I don’t have any idea how to fix this as I’m new to linux.
I read a few articles related to that But the thing is I’ve no idea that after doing this I’ll have my data the way it is … or if I’ll lose all the data .

Can anyone tell me a safe way to fix this issue without formatting or without deleting the data on hard disk …or at least a way to save my data … like getting it’s backup or something??

My Sys. Config. :

Kernel: 5.4.0-70-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa
base: Ubuntu 20.04 focal
Type: Desktop Mobo: MSI model: H110M PRO-VH PLUS (MS-7A15) v: 1.0
serial: UEFI [Legacy]: American Megatrends v: 1.80
date: 07/20/2017
Topology: Quad Core model: Intel Core i7-7700 bits: 64 type: MT MCP
arch: Kaby Lake rev: 9 L2 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 57600
Speed: 801 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Device-1: NVIDIA GK208B [GeForce GT 710] driver: nvidia v: 470.57.02
bus ID: 01:00.0
Display: x11 server: X.Org 1.20.9 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: NVIDIA GeForce GT 710/PCIe/SSE2
v: 4.6.0 NVIDIA 470.57.02 direct render: Yes

As for the backup: the easiest way I think is to boot a live system from a pendrive.
Mount the internal drive, attach an external drive, mount it, then copy the data you want to backup.
As for making the system bootable, I think an easy way would be to reinstall GRUB.
But wait, tell the story, what happened when your system broke.

How did it brake?
Did you install something? Did you experiment with something?
If it just broke on its own, I’d check the HDD SMART attributes, just to be sure…


Hi @A_N_I_M_E ,
What you are getting is a grub command prompt.
That happens when grub can not find its configuration files, or if it can find grub.cfg but it is faulty.
You can boot by hand from that grub> prompt , but it is complicated and would be difficult for anyone but a grub expert.

The important question is why cant grub find its configuration file?. It is stored in Linux in /boot/grub/grub.cfg.
There is no way that replacing the CPU could remove grub.cfg. This suggests that there may be something wrong with the disk , as suggested by @kovacslt .

So, you should first attend to saving all your files with a backup.
The simplest way is to use Clonezilla booted from a dvd or usb drive and let it backup the whole disk device to an image on an external disk.
If you dont have clonezilla on a cd or usb drive, get someone to make you one



You stated your “…got it fixed…” suggesting someone else had their paws in you machine. IF, they tampered with the BIOS your issue could be there.


Do you mean changed the bios settings, or something drastic like update the bios?

1 Like

No nothing like that … what actually happened was my niece pushed the CPU down .
when I tried to turn it on nothing worked.
And in the end I got to know that the main port was broken and also the cabinet got cracked , so I just got a new cabinet . Just that .

When I turned it on - it just shows GNU Grub error.

Can I use Linux Mint bootable Flash Drive and access the disk to copy paste data ?

If not then … then any steps on how to use clonezilla for this?

You’re on the right track. The flash drive should recognize your installed drives once it’s done booting. I used that method before to recover data.


So we are talking about a desktop computer, that fell off from the top of the desk?
While it was running, it was switched on?
IF there’s a (or there are more) HDD in that computer, and that (or those) were spinning, while crashing into the floor, multiple things could have happen.
The most innocent is that a cable were detached by the shock, either a data cable or a power cable. Anyway, that disk disappeared from your system, and IF you have more HDD’s, that could cause the symptom. Say, you have GRUB on HDD1, and your system was on HDD2, which is now detached, GRUB cant find the kernel to boot…
However, this scenario is the least probable, I’m afraid…
HDD’s, especially while spinning, likely don’t survive such a crash-landing.
The head of a HDD is flying above the plate, which has the magnetic surface to store the data, The head doesn’t touch the plate. When the HDD is switched off, it parks the head beside the plate. When such a crash landing occurs, it produces a shock, there can vibrations arise, so that the head touches (and scratches) the plate. If that happened, the best you can do is to save the data you are still able to save. And then replace the drive. My #1 priority would be to save all data which is still accessible.
So backup as much as you can as soon as you can!
Then we might help diagnose further what’s behind the problem.

1 Like

I’m not sure, but… what is the “main port”?
Or you wrote this by “hearing” and you were really told “the mainboard was broken”?
If your computer was switched off while crashing into the floor, and cabinet and mainboard was replaced, that tells me just BIOS settings may be incorrect.
(Still, backing up data is not a bad idea…)

Yes that should work. If not let me know and I will give you a rundown on clonezilla.

If the HDD is damaged , nothing may work.



Thanks everyone I finally recovered all my important data with the help of mint bootable flash drive.

The thing is … I actually wanted to dual boot it earlier but this grub situation was unexpected.

So how can do It now ? I just copied important data and haven’t fixed the Grub error.

How can I have both windows and Linux mint now ?

If that worked , the disk is probably OK
So back to the grub> prompt
That is a catch22 situation… grub cant find its config file so you dont get a grub menu to boot from, and you cant fix the grub config file because you cant boot into Linux.
What you need to do is either

  • learn how to use the commands needed to boot at the grub> command line, or
  • use a Super Grub2 Disk to boot into the Linux that is on your disk

Then when you are in your own Linux, all you need is
then reboot, and the grub boot menu should come up.

On the Windows and Mint multiboot question, what do you have now?
Are Windows and Mint both on your disk?


1 Like

I’ve been using only Linux Mint for a year .
I wanted to get windows too … I’ve been thinking about it for sometime now … but this grub error happened all of a sudden.

So I think I should do it now since I’ve copied all of my important data . So what to do now ?
Can I delete linux mint completely then first install windows and then linux ??

Hi @A_N_I_M_E,

I found this on the web and that’s the way I have always done it.

“Linux Mint (and most Linux distributions) detects other operating systems and builds a menu from which you can choose which system to boot. For this reason, if you want to dual-boot or multi-boot with Windows, it is easier and recommended to install Windows first, before you install Linux Mint.”

1 Like

I see . Okay so since I haven’t fixed this grub error and I can’t access my computer what should I do first?

How do I delete linux mint?
Should I download windows 10 iso and make a bootable usb and use that ??

Yes you can.
Just use gparted from a cd or a usb drive, delete all the partitions, make a new partition table, and make the partitions you need including formatting them to ext4 for linux and ntfs for windows.
The installs will be much easier if you have already formatted the partitions.

Follow what @easyt50 said. .
There are probably some itsfoss documents detailing all the steps in setting up a multiboot computer.

1 Like

Okay .
So I think first I’ll fix this Grub error with the help of itsfoss guide Fix Minimal BASH like line editing is supported GRUB Error In Linux - It's FOSS

And after that I’ll make that windows bootable drive to install windows and delete Linux mint and at last I’ll install linux (dual boot)

1 Like

I have no idea what happened.
I took out my usb and turned on my system and idk how but everything works fine just like before

1 Like