Good video quality in KDE Neon Live, bad video quality when installed


I’m new here, so hi to everybody :slight_smile:

I have a new Asus VivoBook_ASUSLaptop X515UA_M515UA Ryzen 7 with Radeon graphics. The graphic is an AMD Renoir (see below the results of sudo inxi -Fxmz).

The problem is that when I open a video in a KDE Neon live USB the video quality is fine, but when I install the SO, video quality is very bad (very pixelated, but no other issues that I can see). SO looks fine, but chromium contextual menu shows blank. That’s easy to solve unchecking hardware acceleration, but I think it points to an issue with the graphic card. However, as far as I can see, I have the latest amdgpu automatically installed.

I cheked a few commands that I found here and there:
inxi -GS
lshw -c video
lsmod | grep amdgpu
dmesh | grep -i amdgpu
And the outputs of the Live and the installed versions are the same.

One of the outputs (I can share them if you want) detected a missing file in the radeon firmware folder “renoir_ta.bin”. I found the file in the internet and copied to the right folder (/lib/firmware/amdgpu). Reboot and still bad video quality.

SO is KDE Neon up to date and fresh install. KDE plasma version 5.23.4, KDE framework 5.88.0. The bad video after installing replicates in X11 and Wayland, and also in a fresh install of Kubuntu LTS. I used VLC but it also happens with Kaffeine.

Not sure if related, but VLC fails to close properly after opening a video and then it refuses to open. I have to kill -9 it. Again, this also point to issues with the card, but no idea what could be happening. Maybe this is OS version related because it also happens in the Live version.

Also maybe unrelated, but KDE fails to come back after turning monitor off automatically. This is solved by turning off the option of turning the monitor off after some time, but I don’t know what to make of all these little issues that may be graphic related but that may be SO version related. What do you think?

I would think of a damaged graphic card if not for the live usb showing good quality. I would appreciate any suggestion about what can be happening or where to look at. What does the Live version of an OS does that the installed version doesn’t?


sudo inxi -Fxmz
System: Kernel: 5.11.0-41-generic x86_64 bits: 64 compiler: N/A Console: tty 1
Distro: KDE neon 20.04 5.23 base: Ubuntu 20.04 LTS Focal
Machine: Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X515UA_M515UA
v: 1.0 serial:
Mobo: ASUSTeK model: X515UA v: 1.0 serial:
UEFI: American Megatrends LLC. v: X515UA.302 date: 02/26/2021
Battery: ID-1: BAT0 charge: 37.2 Wh condition: 37.2/37.1 Wh (100%)
model: ASUSTeK ASUS Battery status: Not charging
Device-1: hidpp_battery_4 model: Logitech Wireless Mouse
charge: 55% (should be ignored) status: Discharging
Device-2: hidpp_battery_5 model: Logitech Wireless Keyboard K540/K545
charge: 100% (should be ignored) status: Discharging
Memory: RAM: total: 15.04 GiB used: 3.67 GiB (24.4%)
Array-1: capacity: 32 GiB slots: 2 EC: None max module size: 16 GiB
note: est.
Device-1: DIMM 0 size: 8 GiB speed: 3200 MT/s type: DDR4
Device-2: DIMM 0 size: 8 GiB speed: 3200 MT/s type: DDR4
CPU: Topology: 8-Core model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64
type: MT MCP arch: Zen rev: 1 L2 cache: 4096 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 57488
Speed: 1404 MHz min/max: 1400/1800 MHz Core speeds (MHz): 1: 1416 2: 1404
3: 1497 4: 1396 5: 1397 6: 1397 7: 1564 8: 1368 9: 1398 10: 1396 11: 1397
12: 1397 13: 1397 14: 1397 15: 1839 16: 1590
Graphics: Device-1: AMD vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 03:00.0
Display: server: X.Org 1.20.11 driver: amdgpu,ati
unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.11.0-41-generic LLVM 12.0.0)
v: 4.6 Mesa 21.0.3 direct render: Yes
Audio: Device-1: AMD driver: snd_hda_intel v: kernel bus ID: 03:00.1
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: ASUSTeK
driver: N/A bus ID: 03:00.5
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 03:00.6
Sound Server: ALSA v: k5.11.0-41-generic
Network: Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: AzureWave driver: ath10k_pci v: kernel bus ID: 01:00.0
IF: wlp1s0 state: down mac:
Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a
bus ID: 2-2:2
IF: enx000ec6ea8b9d state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 476.94 GiB used: 184.41 GiB (38.7%)
ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ512HALU-00000 size: 476.94 GiB
Partition: ID-1: / size: 28.52 GiB used: 9.82 GiB (34.4%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: /home size: 19.10 GiB used: 3.19 GiB (16.7%) fs: ext4
dev: /dev/nvme0n1p3
ID-3: swap-1 size: 9.77 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p7
Sensors: System Temperatures: cpu: 51.2 C mobo: N/A gpu: amdgpu temp: 47 C
Fan Speeds (RPM): cpu: 2400
Info: Processes: 349 Uptime: 2h 09m Init: systemd runlevel: 5 Compilers: gcc: 9.3.0
Shell: bash v: 5.0.17 inxi: 3.0.38

[EDIT: SOLVED: It wasn’t a hardware issue, but a VLC option. Solved in Tools → Preferences → Output, change from Automatic to XVideo (XCB)]


I was about to suggest using a different video player with proper codec installed. But it seems you have managed to fix the issue already :slight_smile:

For others who might stumble upon this issue later, OP solved this issue all by himself with this:

1 Like