Grub timeout not working (SOLVED)


#1

Greetings!
I’m using Linux Mint 19.1 and recently the grub prompts stopped appearing on boot up (again). I fixed it a few months ago and can’t remember how I fixed it. I’m trying to get it to pause for 20 seconds or so before auto-booting to the default system. This is not a dual boot system. I’ve used the Grub Customizer program and ran ‘sudo update grub’ afterwards but it still doesn’t work - it just boots right to a signin screen. Any ideas oh wise ones?
Thanks, Jim


#2

The solution is pretty simple, you just don’t connect to the internet when installing and it just installs. When it completes after the reboot you have to do the settings then to get things right and after you connect to the internet you get the updated grub through update manager along with the other updates as usual. This works fine. I seem to remember there was the same problem with 18.3 due to a Ubuntu update and that is why I remember this way of doing it. I did this the other day when I run into the same problem which is I why I know this solution works.
19.1 doesn’t have this problem, I don’t know why, so if you have it just install that. Otherwise update to 19.1 after you’ve got 19 on which you can easily do through update manager.


#3

Thanks for the response! I’ve edited my original post. Sorry for the confusion - I’m already on 19.1.
Anyway, here’s what etc/default/grub looks like:

If you change this file, run ‘update-grub’ afterwards to update

/boot/grub/grub.cfg.

For full documentation of the options in this file, see:

info -f grub -n ‘Simple configuration’

GRUB_DEFAULT=“0”
GRUB_TIMEOUT_STYLE=“hidden”
GRUB_TIMEOUT=“20”
GRUB_DISTRIBUTOR="lsb_release -i -s 2> /dev/null || echo Debian"
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
GRUB_CMDLINE_LINUX=“reboot=efi”
GRUB_RECORDFAIL_TIMEOUT="$GRUB_TIMEOUT"

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD …)

#GRUB_BADRAM=“0x01234567,0xfefefefe,0x89abcdef,0xefefefef”

Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=“console”

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo’

#GRUB_GFXMODE=“640x480”

Uncomment if you don’t want GRUB to pass “root=UUID=xxx” parameter to Linux

#GRUB_DISABLE_LINUX_UUID=“true”

Uncomment to disable generation of recovery mode menu entries

#GRUB_DISABLE_RECOVERY=“true”

Uncomment to get a beep at grub start

GRUB_INIT_TUNE=“480 440 1”

GRUB_RECORDFAIL_TIMEOUT="$GRUB_TIMEOUT"


#4

I just tried commenting the line "# GRUB_TIMEOUT_STYLE=“hidden” " and it seems to work. I’ll mark this as solved. Thanks for reading and posting! Jim


#5

Great :smile: Glad you managed to solve it and marked it as solved :+1: It’s easy to make a mistake, as we all know and you edited which is great as well. Must admit it is the first time I had come across, at least we know of a solution if anyone else does.


#6

There are probably more correct ways to solve this but I got tired of trying to figure out all of the GRUB parameters and this is working for me. :slight_smile: Jim