Having trouble to completely shutdown ubuntu

i have ubuntu 20.04 LTS, and after one week of installation i am facing issues to completely shut down my pc. the screen gets off but the fan is still on and cooling pad is still working.
I tried all fixes given on askubuntu, but still…
please help me////////

1 Like

@Rajeev_Gupta Pls post screenshot as well .

1 Like

This is not really helpful.

In order to determine what went wrong, you should try two things:

  1. Give your PC a long time to shut down, like: Try to turn it off and go to sleep, or make your grocery shopping.

  2. The tool journalctl provides all kind of messages about what happens on your machine. Try to look of what happened at the end of the last session:

journalctl -b -1 > last_boot.txt

Read the last entries in last_boot.txt carefully. There might be a hint to what is going wrong.

1 Like

Are you sure your monitor is good? Run a video cable to your TV and see what happens.

BTW, Welcome to the group.

1 Like

At first I am thankful, that you replied for my question.
@Aman_Bhatnagar I didn’t understand that which type of SS you want, but I am attaching SS of grub file, because on askubuntu some were using to change arguments in it. But it didn’t work for me so I put it back to default.

@7blade yes of course my hardware is going well, and 1 thing I want to add is that, I have used mint(mate) but didn’t found any problem but switching to ubuntu – works fine for one week and then issues occurs.


@Mina Yes, the system is powered off in night and i tried journalctl but it didn’t open any file and the command just executed…

1 Like

Mina’s journal command creates a file called last_boot.txt in the directory you were in when you ran the command. Try the command

vi last_boot.txt


Just a remark: Don’t you ever try vi *something*, unless you know what you’re doing. vi is an extremely old text editor program for the terminal with absolutely non-intuitive commands.

The most probable thing that will happen is that you won’t be able to exit it.

Open the text file from the file manager to open it with the default editor program or use nano last_boot.txt.

nano is also a text editor for the terminal, but it displays its most important commands.
Note: ^X means: Ctrl+x, i.e. pressing the Ctrl and x keys at the same time.


hello guys, thank you for your support, I am replying very late, actually by some sources I got my problem resolved. But I forgot to update here.

The problem was resolved by updating the kernel because from somewhere I got that the problem is in kernel so some were degrading the kernel but I updated it and it got done…

1 Like