Help! Can't Restore Virtual Box Saved State

Hi there, this is my first post. I’ve been using Linux Mint for close to a year on a Win 10 host using Virtual Box (current ver 6.1). About a week ago, my Win 10 machine auto-rebooted (curse them) and when I powered my Linux Mint VM back on it appears I’ve been restored to the Snapshot taken months ago. I don’t have any files or applications on the VM that were installed/created since.

I’m pretty sure (but not certain) that when Win 10 rebooted that I had already closed the VM using “save state”. So, when I look at the Snapshots directory for my VM I see a saved state from 11/1, that I think would contain everything I need, but when I start the VM it is restoring me to a point from June. The VDI files are after I tried opening the VM and found everything was missing.

It’s possible that I am misremembering and I did not close with “save state”.

Can anyone help?

Isn’t this more like a temporary saving, which content gets overridden on every new iteration?
If yes, there should be only a single saved state, not two, I think.

That said, the newer saved state also has a much smaller size than the older one.

Additionally, at least with snapshots, they usually are based on each other. So if you take away a single one from the chain of snapshots, all younger snapshots may break. Perhaps something similar can happen with saved states.

I believe that yes, the SAV files are temporary. As to how many Virtual Box would store…? I really have no idea. I’m hoping the 11/1 file has my data and can somehow be restored to, though I think it would be in addition to one of the snapshots.

But thinking further, I’ve read that when taking a snapshot, if it is done when the VM is actively on, that there will have to be a SAV file in addition to the snapshot. So perhaps when I first ran a snapshot back in June it was open and created a snapshot + a SAV file. What doesn’t make sense is that there is no June VDI file which I’ve read is the snapshot, only a state file.

The way I backup VM,s is to exit the VM and VM manager.
Go to the folder where the VM,s are.
Right click on the VM of interest.
Click copy.
When copying is done you have image copy.

To use the backup image exit VM and VM manager.
Rename original VM folder to something like vm-old.
Now rename the backup copy to the original name.
Start VM manager and VM.
You should now be running the backed up copy.

It works for me.


Hi Ken, not sure I see how that changes anything other than just allowing a copy of the same thing I’m already running to restore from.

I think the problem is that I had “saved state” and had the VM closed, and then Windows 10 restarted the computer and when I next tried to open up my VM, Virtual Box maybe forgot to open up the saved state? I’m not sure.

Either way it is strange that there is a 11/1 SAV file and yet I can’t reopen from a state from 11/1. Shouldn’t I?

I have had save state fail. That’s why I use the copy folder method. Only caution watch naming.

I have used this method and it has saved my butt.

Good luck!

Thanks. Sounds like I’m out of luck on the lost data. But going forward I’m going to be more careful.