How can I disable kinetic scrolling in Ubuntu 22.04.3?

I use two finger scrolling on my laptop’s touchpad. If I scroll quickly and lift my fingers the scrolling continues to coast along for a bit. How long depends on how fast I’ve swiped. I’d like to disable this feature as I find it annoying.

It took me a while to stumble onto the correct name for this; it’s called “kinetic scrolling”. I’ve been unable to find out how to turn this feature off. I’d prefer the scrolling motion to stop the instant I remove my fingers from the touchpad.

Does anyone know how to disable kinetic scrolling?

1 Like

Does this work?

Edit > Preferences > Touchscreen > Disable GTK's built-in touchscreen scrolling
should resolve the issue

I cant test it… do not have a touchscreen

Neither do I. I’ll look, though, for anything of a similar name that refers to the touchpad.


Sorry, I got that wrong… touchpad not touchscreen.

I had another look.
Apparently synaptics driver supports kinetic scrolling, but
libinput driver does not.
So one answer would be to switch drivers… that may affect other things.

In /etc/X11/xorg.conf.d there are files that configure
input devices ( and other X things) . Not sure what happens with Wayland.