How can I speed up print rendering?

#1

I have a black and white HP laser printer. Certain PDF documents take a long long time to render before they’re printed; for example, airline boarding passes. There’s a color to B&W conversion, the image has to be scaled to fit the margins and I don’t know what else is involved. But it takes five to eight minutes before a page comes out of the printer. Other kinds of documents (for example .doc, .txt, or .png) print immediately.

The computer is an i7-7700k with 16 GB of RAM running Ubuntu 18.04.2 LTS.

I’ve searched online for ways to speed the print rendering. I am guessing that it might help if I can give printing a high priority among the running processes. However, I’ve had no luck at all finding a way to do this.

Does anyone have any suggestions?

       Don
1 Like

#2

Hi Don, have you tried changing the quality of the print to Draft? I tend to use it all the time unless I am doing Photographic printing, it does seem to speed things up without noticeably making a different to the quality of the printed document. Also are you doing the printing via wifi if so then perhaps you could try using a USB connection. Sorry that is the best I can come up with for you.

2 Likes

#3

I like ElectriDandySlider’s suggestions. Also, try different drivers for your Laserjet, both open source and hp proprietary. For proprietary drivers, you can visit https://support.hp.com/us-en/document/c01174360

3 Likes

#4

I just checked and the printer was already set to the lowest resolution choices and was in “Econo-mode”. I’ll dig around for different drivers: good suggestion.

      Don
1 Like

#5

Thanks Don. If you get your solution, can you put it on here for everyone to see. It will help others if they have a similar problem.

0 Likes

#6

Yes, you can give high priority for the process, follow me :slight_smile:
1- The command nice is used for this job.
2- Using nice: nice go of -20 until 19 ( -20 19 ) negative values Increase priotrity task.
all Linux programs works at nice 0. Increase this values ( POSITIVE ) lower the priority.
3- For use nice, make so: sudo nice --17 < name of executable > double signal minus and 17.
4-Not use -20, it make your cpu works in Real Time ( dangerous ).
5- For a job that already is running, you can to use renice, see:
6- sudo renice -12 -p 4314 ( 4314 is the process ID ) use pid or top for see the PID.
7- Caution with renice, because that the program run with root privileges.

Hope have helped you, if works then please mark as solved thread.

1 Like

#7

Thank you 76ron. I’ll try your suggestion.

     Don
0 Likes

#8

Hi Don, I recently got the HP Laser jet Pro m15w. After failing with the Ubuntu 18.04 driver list. Installed the HPLIP 3.19.7 as dunaybd was pointing you to. Everything was fine and it prints 18 pages a minute with excellent print quality. Here is a link as a install reference.

http://ubuntuhandbook.org/index.php/2018/12/hplip-3-18-12-released-ubuntu-18-04-support/

Hope this helps.

1 Like

#9

I have been using HPLIP throughout and have not had any driver issues.

Today I got the chance to apply ‘sudo renice’ to the cups process on a print job that was taking a long time to render. I set the priority for cups at -17 and could see that the change was accepted in the ‘top’ command display. It didn’t appear to make a difference.

I couldn’t figure out (reading the process list provided by the ‘top’ command) if there was an HPLIP-specific process to re-nice as well.

I’m still working on this question but no success yet.

      Don
1 Like

#10

After multiple reboots and much noodling around the problem seems to have gone away. I’m not sure it was due to anything I did.

The problem appeared to vanish after I clicked “connect to cups server” (or words to that effect) in the Ubuntu printer settings even though the printer was already connected.

Just because it improved after I did this doesn’t prove it was fixed because I did this. Since I can’t re-create the problem and test the fix I’ll have to wait til next time the issue crops up to see if this was truly the answer. In the meantime I’m happy to have a normally working printer again.

     Don
1 Like

#11

it’s great to hear printing isn’t such a pain anymore :slight_smile: thanks for sharing what might have worked. maybe someone else will get some help out of that tidbit some day.

0 Likes