How install app after download and extract

I have downloaded maybe ten or twelve apps not available under Ubuntu store or generic store. I have extracted them, causing special folders to appear containing many files each, but no file is an installer.

It could be an app doesn’t need to be installed. You simply unzip/untar/extract it and there is a directory structure with an executable file.

It could be you need to compile the app before it’s ready to run. There is normally a readme that let’s you know what to do and a ‘make’ file so it can be compiled.

Can you list an example of one or two of the apps you downloaded?


Hi @ubuntuyou ,
Follow what @pdecker 's reply says.
I just wanted to remind you about filesystem considerations when installing.
If you install with the apt package system, the files installed go into /usr… mostly into /usr/lib and /usr/bin.
If you install other apps that are not supplied by the Ubuntu package system, you should put them somewhere separate from the package system directories. Traditionally in a multi user system you would put
non-package installs in /usr/local, but if you are the only user in a home system it is OK to put them in your home directory, which is probably where you unpacked them anyway.

The reason for keeping the package system file areas clean is that foreign stuff can upset package upgrades.


Hi, Neville. Thank you for the advice. I did look in those directories, I will however look again.

Also, I have heard of packages and package managers, but I have yet to see anything resembling a package manager during the download and extraction process. I have Ubuntu 20.04 and included is something called Synaptic Package Manager. I have toyed with it but I cannot tell that it does anything useful. It certainly doesn’t have any connection with the several app archives I have downloaded and extracted. There is also an Archive Manager but its function appears to be creating not dealing with archives. At least not manually. When double-clicking on a .tar file it opens and allows extraction. But that is the only use for it that I can see. Besides, the archive question seems moot since I have extracted all those archives already so that the files I need to deal with are no longer archives.

1 Like

Let’s try to give you a bit of clarity. The main purpose of the package manager is to take care of installing software into the right places.

Say, you want to install a certain app, e.g. the video editor shotcut.

You don’t go to

and download the package from there. Instead, you open your package manager (or even better: the Ubuntu software centre/store), search for “shotcut” and install it from there.

Alternatively, you can open a terminal and type sudo apt install shotcut.

Either way, you don’t need to bother about dependencies and where to install the stuff. It will also be automatically updated.

Now. If you really can’t find the app in the software centre, you might have to download the archive. You already managed to extract a tar archive, take a look at its content:

There is usually a README file or a text file with installation instructions. If you’re still at loss, name us the particular app, you’re trying to install, and some of us will probably try to guide you gently through the process. (no guarantee though, we do this when we’ve got spare time)


Sorry @ubuntuyou ,
I used too much jargon.
Packages are bundles of software ( mostly binary, but can be source code.

There are official Ubuntu packages, These can be downloaded automatically using Ubuntu’s package manager, which is called apt. Synaptic is just a graphic interface to apt. Top use apt from the command line you just use commands like apt install packagename or apt-search searchitem.

There are also unofficial packages. I was assuming that the apps you downloaded were unofficial packages - ie you did not use apt to download them. Is that correct?

Official packages all have a consistent content. They are called .deb files.
Unoficial packages can be of various formats, quite commonly archives like tar . How you unpack and install an unofficial package depends on what type ofarchive it is. You dont have to unpack official packages, apt does it for you.

I hope I have not confused you. I dont use Ubuntu, what I have said applies to Debian, which is similar to Ubuntu.


1 Like

Thank you Mina and Neville. I have tried using the package manager in that way, I never can find the app. Instead there are seemingly dozens of apps I have never heard of. I know about the text files and readmes too. So far none of the ones I have opened have indicated how to install the app. And yes, the apps I am talking about are not found on the Ubuntu store. Tried there also. The apps I gave downloaded and extracted are: Cairo Clock, Crater Invoice, Easy Invoice, Simple Invoice, Citrus, Directory Assistant, Ruffle, and Solid Invoice. Thank you again for attempting to help a noob.

You have to,get the package name right.
For example
apt install cairo-clock
should do a download and install
of that package.

To search for package names, you can do
apt search cairo
apt search clock
and it will list everything with cairo (orclock) in its name.

It is not always easy to find out the exact name of a package

When you install a package with apt it will also install all of its dependent packages. That is a big simplification compared tp doing it by hand.

This is basically what @Mina recommended you do in response #6


Neville, thank you. I tried your example just now. I get a message in terminal saying, “unable to locate package cairo-clock”. I was supposed to put “sudo” in front of that, correct? I tried it without “sudo” and got a message saying “permission denied” and “unable to locate the dpkg frontend lock”.

There are 4 possibilities

  • cairo-clock package has been abandoned… That would be unusual, I will check in Debian and get back to you.

  • The package system does not have its repositories enabled… a likely cause. In Debian repositories are enabled in /etc/apt/sources.list. Ubuntu may be different, I dont know about Ubuntu. Maybe someone else can help here?
    If you have /etc/apt/sources.list… can you show us what is in it?

  • You have never done an apt update. The most likely cause. This downloads a database of the repository contents. It needs to be up to date so you should do
    apt update
    apt upgrade
    Then try your apt install cairo-clock again.

  • your internet connection is down so it cant access the repositories You can easily check that

Yes apt commands always require sudo .



@ubuntuyou Many times you get better results by searching for a package in google, since you don’t have to know the correct name of it. I might be wrong, but Cairo clock could be an old project, not maintained anymore so they removed it from depositories. You can still install older versions of it, it should work just fine, except if they also removed dependencies.
Here is one of the many results, I searched for “Cairo clock .deb”
You can easily install .deb packages with Gdebi installer. It will tell you if there are missing dependencies and if you really-really want that package, then keep searching, until you find a website that tells you what are the missing files and how to find them. Or, you can install everything from your distro’s older version/archive. (not recommended, but who cares, what can you lose??) To me, it’s one of the beauty of Linux, you can play with it, try things with it, until it becomes totally yours. Of course, you can brake your system too, that is why it’s important to ALWAYS have a backup before you do anything new!
Good luck to you my friend and enjoy Linux!


Hello my thought is that not only follow the above advice about update form @nevj and that is important
The other thing is it could be Ubuntu specific quirk, I’ve just searched in SpiralLinux and well let’s

apt search cairo
results in a very long list associated with plugins for cairo

and then

apt search cairo-clock
Sorting… Done
Full Text Search… Done
cairo-dock-clock-plug-in/stable 3.4.1+git20201022.a0d3415c-1 amd64
Clock plug-in for Cairo-dock

In your distro ubuntu I don’t know, in the distro I use spiralinux, only need sudo for install and/or remove
sudo not needed for searches it is not an admin only task.

cairo-clock is listed in Synaptic no need to search all over the web,
IF I look for something and it’s not in Synaptic = Do I really need this IS there an alternative

You are doing things right by asking when in doubt

@shamu advice about backups is really spot on
Hope this helps

That is correct.

apt search cairo-clock
Sorting… Done
Full Text Search… Done
cairo-dock-clock-plug-in/stable 3.4.1+git20201022.a0d3415c-1 amd64
Clock plug-in for Cairo-dock

So cairo-clock is not a standalone app, it is a plugin for cairo-dock.
That is OK. Some pacpckages are plugins.

Did the install work? Have qe solved your problem?

1 Like

Hi @shamu ,
That is important.
I have always struggled with apt-cache search and apt-cache show .
To find out a package name, Google may be a better way to go, but one needs to be aware that package names are not consistent across distros… For example the popular Docker app’s package is called in Debian and Devuan, but in Void Linux it is called docker.

App names are chosen by the person(s) who wrote the app. Package names are chosen by the distro makers.


1 Like

Hi, got the same results with Mint which of course is based on Ubuntu.

Yes, 100% it is there.

Thats because the system search for the word cairo in each package available.

Actually. when you create a GitHub repo…it automatically creates a README file and everyone always fills it!

I have perused a few extracted files for different apps recently and not found a single ‘readme’ or ‘exe’ file. Drove me to snap. Must be my fault of course.

You’ll probably NEVER find an “exe” file in ANY package on a Linux system *

“EXE” files are from DOS and Windows platforms…

Linux (and most UNIX systems) don’t have a special dedicated filename extension for binaries, most EXEcutable binaries on Linux systems have NO extension. Packages may, or may not, have README files, however most good packages will install man pages.

╭─x@titan ~  
╰─➤  which find
╭─x@titan ~  
╰─➤  file /usr/bin/find
/usr/bin/find: ELF 64-bit LSB pie executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/, BuildID[sha1]=de16ca2001be2a135694bec040511087405c1422, for GNU/Linux 3.2.0, stripped

this tells me that /usr/bin/find is a 64 bit executable…

╭─x@titan ~  
╰─➤  man find

FIND(1)                                          General Commands Manual                                         FIND(1)

       find - search for files in a directory hierarchy

       find [-H] [-L] [-P] [-D debugopts] [-Olevel] [starting-point...] [expression]

       This  manual  page  documents the GNU version of find.  GNU find searches the directory tree rooted at each given
       starting-point by evaluating the given expression from left to right, according to the rules of  precedence  (see
       section  OPERATORS), until the outcome...
       chmod(1), locate(1), ls(1), updatedb(1), xargs(1),  lstat(2),  stat(2),  ctime(3)  fnmatch(3),  printf(3),  strf‐
       time(3), locatedb(5), regex(7)

       Full documentation <>
       or available locally via: info find

 Manual page find(1) line 1272/1309 (END) (press h for help or q to quit)

* note : I do have *.exe files on my system, they’re EXEcutable Windows binaries for games I run through Steam’s “SteamPlay” system (i.e. wine and proton)…