How to fix blurry icon on Plank Dock?

I like it too!
But I don’t use it due to just one problem,
Sometimes, it makes the icons blur of the application. Here is an example:

See the icon on which I have focused.
Any fixes about this?


You can try to fix (rescale) it with GIMP or just replace the icon in your icon theme, or through Whisker Menu. In my Docky + Xfce4 Panels I’ve been using my own icons that I collected over the years.

That’s Settings Icon if I’m not mistaken? Is this on a Laptop or Desktop?? If you’re running a Desktop, have you mucked around with the color or the brightness, contrast settings on your monitor??? Sorry for the questions, but need more info please? If this is on a Laptop then you should be able to alter the brightness. If it’s just this Icon that’s causing the blur, try a darker Icon set. I use Sardi icons to go with my own theme. They have a whole host of different styles, when you unpack them, the different styles will be in individual folders, inside the master folder. So you’ll have to unpack them all away from main folder that says sardi-icons-22-05-02. These have never let me down. Just a suggestion you don’t have to use these.

I just have RedShift enabled for color temperature adjustment.
But it is still blurred even when I disable it.

THe problem is not with the icon image, its with the plank dock.
I tried to use Numix-Square theme too, but, for that also the icon is blurred.

Blurred or pixelated?

Are you talking about just that one icon in Plank when you hover over it and the zoom effect takes place? Or it happens with all icons in Plank?


Rest of all are clear.

Then it must be that icon or Plank is picking up a wrongly scaled .svg one. You could just change it in Whisker and see what happens…you have hundreds of icons in the system to choose from. It’s a pretty ugly looking icon anyway, nothing to lose…

But what is the relation of Whisker Menu and Plank Dock?

I’m only writing terminal commands as I don’t know what you’re running, as in Linux Mint, Xubuntu, Arch.
So on that, changing the Icon in Whisker Menu will not help, as it will go back to the original icon.
In case you do not have open as root or as superuser, or administrator when you right click empty space in Thunar, that is why I am going to write Terminal Command.
In a Terminal type or copy and paste sudo thunar
Pop your password in and now you have administrator privileges.
Open these folders /usr/share/applications
Scroll down till you see the Settings icon right click it left click properties, then left click the icon in the window. You have to wait a while for a window to come up. There should be alternative icons for settings, either in the category or menu list, that you can change at the top of the opened window.

For me, it never does. Works perfect about 98% of the time, but I use Docky. I tried Plank and as far as I remember it worked too but only about 80-85 % of the time. I run Mint-Xfce Xubuntu and Linux Lite. In Whisker you don’t need “sudo thunar” either, it opens the same window. I heard that opening Thunar in terminal as “sudo thunar” is a bad idea but I don’t remember the reason why…there is an other command to do it. Maybe because there is a difference between “root” and “administrator”. Best way to do it to have the option in the right-click menu on desktop, if it doesn’t exist, you can create it in Thunar custom action.

Nothing. But changing icons in Whisker (at least for me) is the easiest way. Open Whisker>right click application>edit application>click icon. It opens a window with tons of icons that you can choose from. Then restart Plank or remove the app from Plank, open it again in Whisker, pin it to Plank, or log out and back in again, and you should have your new icon showing up. It works 80-85 % of the time with Plank. If it does not, there could be many reasons. But it’s another story…Right now, you just want to know if the new icon will be clear or not.

That was why I asked which XFCE, as Xubuntu does not have the option to open as Superuser in their Thunar. Leaving the User to either use the Terminal, or adding pkexec script to actions. I know to change my icon through /usr/share/applications as I don’t use Docky or Plank. I have a regular transparent panel, with Docklike taskbar plugin on. Changing the icon through Whiskermenu does not set it through out the system, so when opening said app from Docklike, the default icon appears alongside of the one changed in Whiskermenu.