Hplip on Mint 21 - am i missing something?

Another upgrade annoyance.
I have hp 1020 laserjet usb connected. It worked great everywhere, until last night on Mint 21.
I checked settings (localhost not cups.sock, shared, and service started), removed and reinstalled repeatedly.
Then i realized i needed hplip. But Mint said i had hplip. So i downloaded the latest version from the HP website. It could not install on Mint 21 due to unmet dependencies that could not install either.

Is there a trick I’m missing?

If you are trying to install the latest hplip inside the package system , that is not a good way to do it. The version of packages that come with Mint21 are tested to work together. If you add in a newer version of a package it may have incompatabilities, as you gave seen. you might get away with it sometimes, but it is not a good practice

The right way, if you want to add something that is outside Mint21 , is to install it in either /usr/local or on your home directory.

What makes you sure the new hplip is needed? Mint21 will have a fairly recent version. I think your problem is likely to be somewhere else, probsbly in the CUPS setup.


I can now set this as SOLVED.
I went into Synaptic, searched for hplip and lo and behold, there were several important packages that had not yet been installed.
I installed them, did a little fiddling, the HP software found the prnter and set it as default.

1 Like

Well, Mr Neville, I wish I had read your answer earlier.
The reason hplip is necessary, though, is that test pages are reported as printed, but the printer remains silent.
I just ran a test page and it now works.

1 Like