I cannot boot into Ubuntu 18.04. How do I fix it?

I adopted a Dell XPS 13, updated the Ubuntu 16.04 to 18.04, and gave it the MacBuntu environment for my girlfriend to use. Everything worked great! Then I got it in my head to run Steam, mainly to play Civilization 6. Experiments creating a swap file to manage resources however seemed to backfire, (“Challenges to Creating and using SWAP files in Ubuntu 18.04”) and now I can no longer boot! I enter recovery mode, try FSCK, and it gives me a clean bill of health. When I resume normal boot however… Nothing. Just a cursor. When I attempt to boot past it I hang on the Ubuntu splash screen. I hit escape, and get a long list of Failures, a few OKs, and one or two Dependencies. Here’s a partial list I retyped myself.

Failed to start network name resolution, see systemct1 status systemd-resolved.service

Failed to start network time synchronisation see systemd-timesyncd.service for details

Failed to start Bluetooth service: systemct1 status bluetooth.service for details

Failed to start Modem Manager: systemct1 status ModemManager.service for details

Failed to start Avahi mDNS/DNS-SD Stack: see systemct1 status avahi-daemon.service for details

Failed to start Accounts Service: system ct1 status accounts-daemon.service for details

Failed to start Disk Manager: status udisks2.service for details

Failed to start Network Manager: see systemct1 status NetworkManager.service for details

DEPEND Dependency failed for Network Manager Wait Online.

Failed to start Tool to automatically collect and submit kernel crash signatures; see systemct1 status kerneloops.service for details

Failed to start Login Service: see systemct1 status systemd-logind.service for details.

Failed to start System Logging Service: see systemct1 status.rsyslog.service for details

Failed to start Network Manager…

Failed to start Login Service: see systemct1 status systemd-logind.service for details.

Failed to start Gnome Display Manager: see systemct1 gdm.service for details

Failed to start System Logging Service…

Failed to start System Login Service…

…Every time it says “Started D-Bus System Message Bus.” It fails at something… This is a partial list. WPA supplicant and Accounts Service aren’t listed. Then it tries

snapd.servicessnapd.serice

Alsa-restore.servicelsa-restore.service

…then a dbus service.

I liked the environment I crafted for my girlfriend, and don’t want to admit to my brother I might need his used Windows laptop to play Civ 6. How do I retrieve this distro?

with that much gone wrong all at the same time, i would run diagnostics on the memory and hard drive.

1 Like

It looks like you’ve wipe some of the needed files to boot. at this point I think a reinstall would be the fastest way to get back on track, But this time create the swap partition and separate home partition also. Good Luck.

1 Like

Which diagnostics would you like to see? I ran parted, fdisk, Disks, and Memtest.




I’ve included the FSCK, Bash History immediately before things went south, and Memtest.

I feel let down by the community. Having run a number of diagnoses, and pursued actions including the creation of new swap files I’m no closer to understanding what happened to this MacUbuntu distro. How could running MKSWAP destroy an installation beyond reasonable repair? Someone on AskUbuntu asked “what (I) did to break (my) system?” I don’t know, and without an explanation my confidence suggesting Linux to computer users is diminished that much more.

i would take a run at smartctl or gsmartcontrol just to see if there are any obvious disk errors. your fsck output looks like it is still being run on the live usb (most likely sda) instead of the system drive.

that’s unfortunate, but to be expected if you think someone is going to show up with a magical fix for a system that is failing to load multiple necessary components. you have already received probably the most common linux advice for errors that aren’t fixed by a decently thorough web search:

if you insist that you have to bring this particular install back from its ailing state, then it seems only reasonable that you should at least accept responsibility for the fact that you are making that choice and the community has no part in it. start running web searches for the error messages you are getting. run the suggested commands to see what the system has to say:

systemctl status systemd-logind.service - that’s systemctl instead of systemct1.

a lot of the changes you made to the system are probably in your home directory. you should be able to sudo cp -r /home/username to an external drive if you want to try and transfer it to a new install. rsync might be a better option. i’m not really sure. i’ve never tried either.

comm -23 <(apt-mark showmanual | sort -u) <(gzip -dc /var/log/installer/initial-status.gz | sed -n 's/^Package: //p' | sort -u) (thanks @Rosika :slight_smile:) will get you a list of most of the programs you installed manually. my list has some lib*s in the middle that i didn’t install, but in general it is really accurate.

i didn’t realize it myself when i first installed ubuntu mate 16.04 that it would be as much work to keep things up and running. just this week my system went down i think because of a bad video driver upgrade. luckily i had a decently recent clonezilla image to restore to when timeshift failed to correct course. point being, preparation before the crash is key.

expecting someone else (especially volunteers donating their time and advice) to fix what broke (regardless of the how or why - mkswap or wonky hdd, doesn’t really matter) doesn’t sound very :penguin: to me.

4 Likes

Format it, and re-install…Then, do what you did, but one thing at a time, and you may discover the issue.

3 Likes

Granted, I don’t always understand what I did to “break” my system but most of the times I do . Just because I know what broke it does not mean I can undo it.
I restore to my last back up and learn from my mistake.
What’s the old saying, “No use in beating a dead horse (system)”.

1 Like

It would help if you would use Gparted and take a screenshot of your partitions?

Here’s what I ran for Parted.
ubuntu@ubuntu:~$ sudo parted -l
Model: ATA SanDisk Z400s M. (scsi)
Disk /dev/sda: 128GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 538MB 537MB fat32 EFI System Partition boot, esp
2 538MB 128GB 127GB ext4

Warning: The driver descriptor says the physical block size is 2048 bytes, but
Linux says it is 512 bytes.
Ignore/Cancel? Ignore
Model: SanDisk Cruzer (scsi)
Disk /dev/sdb: 16.0GB
Sector size (logical/physical): 2048B/512B
Partition Table: mac
Disk Flags:

Number Start End Size File system Name Flags
1 2048B 6143B 4096B Apple
2 2042MB 2045MB 2523kB EFI

ubuntu@ubuntu:~$ ^C

I hadn’t yet tried smartctl or gsmartcontrol, but will this weekend. You made an earlier comment about the fsck return coming from the liveUSB. As I couldn’t run it on the mounted drive using recovery mode I ran it there. However the following provides more detail, but not by much…
ubuntu@ubuntu:~$ sudo fsck -f /dev/sda2

fsck from util-linux 2.31.1

e2fsck 1.44.1 (24-Mar-2018)

Pass 1: Checking inodes, blocks, and sizes

Pass 2: Checking directory structure

Pass 3: Checking directory connectivity

Pass 4: Checking reference counts

Pass 5: Checking group summary information

/dev/sda2: 405979/7782400 files (1.1% non-contiguous), 14845711/31127296 blocks

ubuntu@ubuntu:~$ sudo fsck -f /dev/sdb2

fsck from util-linux 2.31.1

fsck.fat 4.1 (2017-01-24)

/dev/sdb2: 4 files, 1214/1221 clusters

This is my responsibility. No magic here. I broke it; I get to learn from it. Thank you for your assistance!

Why not just go for plane jane vanilla Ubuntu (e.g. 18.04.x or 20.04.1) - then install gnome tweaks (e.g. “sudo apt install gnome-tweaks”)…

Then read up on how to install themes (they usually go in your home directory in “hidden” folder .themes [shorthand reference is ~/.themes] - me? I’ve only recently started coping / unarchiving them in ~/.themes - previously I’d just use sudo and install them in /usr/bin/share/themes [and icon packs in /usr/share/icons]) and install a Mac theme?
e.g. :

I usually run a hybrid of Mojave Dark theme, but with adwaita or yaru icons (I really HATE that smiley face finder icon for files/nautilus)… and I always install gnome-tweaks and move the Window Control widgets to the left (where they should ALWAYS have stayed!).

Seriously - Ubuntu installation is usually painless… the rest is just bells and whistles… making Ubuntu gnome look like OS X is a mere 3 or 4 commands away, and 35 clicks…

What were you hoping to get out of “MacUbuntu” that Ubuntu can’t give you?

4 Likes


This is more like I wish to see.

2 Likes


That’s kind of what I’m seeing! I also checked the disk for defects as offered through GRUB, and the File system through DISKS. Both received clean bills of health.

FYI, that is not Gparted as requested, but may show @4dandl4 what he wanted to see.
Note the type of disk @4dandl4. It is a Scan Disk M.2. I read the other day of someone with lots of problems with this type of SSD.

He ended up sending all the laptops back!

2 Likes

My first ? is why are you using GPT instead of MBR disk partitioning, unless the
SanDisk Z400s M.2, or your PC, will not support MBR. I see the EFI partition that is needed for
GPT and should be mounted at /boot/efi. I see no / partition that should be mounted
@ Filesystem Root, I have ran Linux in a VM without a swap partition but a stand alone Linux install would more than likely need a Active Swap partition.

This is Gnome Disk layout for Debian 10. Grub is installed to /dev/sda
/dev/sda1 is bootable and mounted at Filesystem Root
/dev/sda2 is mounted at /home
/dev/sda3 is Swap and active.
Does this PC run Linux only?
Good Luck!!!

Thank you all for your commentary and advice. It seems clear to me now that, while the file system seems healthy enough, the community indicates the boot service is FUBAR and I should reinstall. I ask, would I rather repair a boot service for the first time, or reinstall 18.03 and modify to Yosemite MacUbuntu a second time? I will go with the latter, creating an active swap partition to afford that memory as need be. Consider this closed.