I thought I was Brave enough

Using Ubuntu 20.04 mate. fter 20+ years of faitthful Firefox use, my old friend sorely disappointed me…it stopped recognizing ALL web certificates = NO internet. Same deal on the Win10 machine. I installed Brave and am still learning the new way of doing things…so far “bravely” flying with no add ons (except captcha widget). Brought in my old Firefox bookmarks, but some of the logins don’t work. Any ideas on improvements are welcome!

1 Like

I’ve been “Test Driving” Brave for about 3 weeks now…

On Linux (Ubuntu 20.04 and 21.04), on MacOS (M1 Macbook Pro) and Windows 10 (Dell Latitude 7470) and so far so good… Got Sync working across all four devices…

There’s a few niggles and annoyances here and there (like when it tries to highlight stuff for me - but makes it UNREADABLE on “Dark Mode”), but I reckon I could extend this testing phase into full on use…

Note - I don’t know about everyone else, this could be my colourblindness, but I cannot read that highlighted text.

Some things I learned, early on, ONLY EVER import settings from another browser one time, if you’re going to sync across multiple computers - I made this mistake and ended up with UGLY duplicated, in triplicate, bookmarks for ALL my bookmarks… I imported ALL my settings from Google Chrome on my Linux Desktop, and also imported all my settings from Google Chrome on my Macbook…

Anyway - once I sorted the triplicate bookmark disaster, it was all good, and mostly plain sailing, 97% of all my saved usernames and passwords (from Google Chrome) and cookies are working in Brave…

I did see a bizarre anomaly using Youtube in Brave last week :
Screen Shot 2021-07-28 at 6.34.10 pm
Screen Shot 2021-07-28 at 6.46.31 pm
Note : Philip H Anselmo IS NOT a “Hip-Hop Head” - and Tropical Fuck Storm could not give two shits (never mind one) about the death of Slipknot founding member Joey Jordison… Somehow Brave got all it’s tags screwed around…

This “anomaly” was enough to make me switch back to Google Chrome, for maybe half an hour, until I remembered how much I DETEST YOUTUBE ads, and this “anomaly” became more of a “charming quirk” than a serious bug :smiley:

I can still read it, but it’s pretty hard to do that. Perhaps it’s also related to the screen, too. If you have a not so good colour-aware screen, it might worsen the situation.

I relate to that a lot. Every time I watched YouTube without my Firefox setup, i.e. without serious amounts of ad block, it became unbelievably annoying, as soon as the first ad is shown. I always ask myself “how do people live withut ad block”?
I am pretty sure, I would visit the internet 90% less of the time I currently spend on the internet, if ad blocks simply didn’t work.
I just wouldn’t be able to stand all the crappy ads trying to sell me shit I don’t even want for free.

I have also been test driving brave for about three weeks. I use Startpage as a search engine and it appears to search much more quickly than it did on Firefox. When I look on the Brave forum it looks like most of the questions are about brave awards…that does annoy me.
I use the brave app to block Amazon…works very well.
What however really annoys me is that when I search and then try an open a website mainly I get a message from a google ad Server telling me they have blocked the connection. That drives me crazy because it forces me to use Chrome and Google to get the information I want.

Here’s one thing in all the Chromium based browsers, i.e. Brave, Google Chrome, Chromium (only three I’ve tried) that REALLY CHEESES me off!

Some time ago, Google removed the ability to open FTP sites and URLs - e.g. like being able to anonymously FTP to my NAS, where my Brother MFP uploads (via FTP) scans…

So - it was easy enough to re-enable it it chrome://flags and “Enable-FTP”, my daughters were able to figure out how to do that on their Macs too - simple… But guess what? In the last 3-6 weeks (time’s a bit slippery these days) - Google have REMOVED even that flag - and - it’s NO longer in Chromium or Brave!!!

WTF? OK - so some Russian hacker might have an FTP site on the intertubes with some nasty shit on it - I dunno - but would my NAS? Would non-routable private addresses? i.e. this side of my firewalls and routers???

IT CHEESES ME OFF! What’s wrong with FTP? Yeah - it’s insecure, don’t do it on the public cloud - yeah - I get that! But what about my private LAN? I don’t want to dig out some separate client (filezilla? ncftp?) just to copy three files.

OK - I can do it in Nautilus - i.e. FTP anonymously from my NAS - but I’d rather just use whatever browser I have at hand, but no longer…

BTW - FTP still works in the “portable” non-updating Firefox-ESR I run from my $HOME… So I guess I’ll just use that …

Well, it’s time to say goodbye to my old friend, Firefox…good riddance my faithful (until recently) internet brother…It’s been a couple days now (or so it seems), and I’ve got Brave working almost just as I like it…I actually like it better than Firefox, and it’s definitely faster…Thanks for all your comments…

1 Like

IMHO, I stopped using Startpage after I read, it was no longer secure… I now use Duckduckgo exclusively.

Tonight, I couldn’t take it anymore…Just got tired of the “brave” way of doing things…Even if it’s slower, I went back to my old pal… Lucky for me, Firefox took me back, and everything is as it was before the big fight… everything works as it’s supposed to… Since I have no idea why Firefox stopped working, I can only pray it stays my friend… I guess I was only “Brave” for a few days after all.


I am sorry about your problem. I am running FireFox on Ubuntu 20.04 without issue.

Have you tried a sudo apt purge firefox then reinstall?


I never experienced Firefox silently self-updating in the background, which was a problem for you @daniel.m.tripp if I remember correctly.
I wasn’t sure it’s just my luck or not.
I run Debian 10, and my daily browser is Firefox ESR, I also have Chromium and Google Chrome installed “just in case”, but I don’t use them.
I don’t have the unattended-upgrades, but run apt update; apt upgrade regularly, when it’s comfortable to me. So, there are zero upgrades installed automatically, especially not, when I don’t want them.
Today I ran update&&upgrade, and among other new packages my Firefox got updated to 78.13ESR.
I don’t know exactly when this FF update was announced, I updated my system last week.
At the moment I’m quite sure FF ESR on Debian does not update itself silently in the background.
I run it from /usr/bin/firefox, according to which :wink:
On the machine/OS you had trouble with auto-updating FF, is there installed anything like unattended-upgrades? I could imagine, that’s the culprit -talking about unwanted auto-updating Firefox.

As I see, according to others experience, this does not really help. (I read other forums in my country in my native language :D)
So far Whenever FF stopped working, in the background there was a failing addon, which just stays there after purging firefox, as it’s stored in the users home folder. The first I’d try in such a case is look for hung Firefox instances among processes, and kill them, after that rename the .mozilla folder in my home. Upon the next start of Firefox a new .mozilla will be created with a clean, brand new profile.

If you install FF with out add-ons does it work OK?

This seems to be unique to Ubuntu… it’s the same on my 2 x RPi4B 8 GB machines with 21.04 , and my Ryzen 5 Lenovo laptop running 21.04 - and - confirmed on Ubuntu 20.04… Good onya Canonical (NOT!)…

Restrictive security policies, which are unworkable, actually make things LESS secure, because they encourage people like me to use backdoors and other less secure things, when they could have just implemented a rational but PRAGMATIC security approach… Google and Brave (and Chromium) do NOT stop you loading / opening more browser tabs if they’ve been updated… It may seem like a small thing - but - as previously mentioned, if I’m working, and I have 20 tabs open in firefox, and I need to open one more (e.g. a ticket in Service Now, or a CMDB entry for a servers in Service Now) but I cannot without restarting Firefox, then that makes Firefox unusable for me…

1 Like

No, just reinstalled and sync…woking so far!..
But I learned an important lesson:
back up everything THREE (3) different places! (not on same device as the source).

I have a solution! I forgot the exact name but should not be too hard to find but there is a FF Extended Version or Special Extensions, anyway it is exactly what you want it is the older version that still allows you to have more than the 12 only approved recommended chewed up diluted extensions left in all of Firefox but yes, there is a special version that you can still use.
Hope that helps!

Isn’t that Firefox ESR?
Debian delivers it as default, and I think it’s for a good reason :wink:

Just spent the last NINETY minutes (it felt like 3 hours!) trying to get Brave to sync - brand new install of Pop!Os on my desktop machine.

REFUSED to sync! I pointed a sawnoff shotgun point blank at its face an it still refused!

Purged it from apt… rebooted… re-installed… Tried to sync… Fired up the brave:\sync-internals page…

Tried a bunch of things - and then FINALLY it started sync’ing!

But I clickety-click-click-clicked, SWORE a lot of offensive expletives, clickety-click-clicked some more - and NOW I have NO idea how I fixed it!

What a pile of stink… but it’s the best “ad free” browser I’ve used to day… and works / runs everywhere - or seems to, when its working…

When it’s working it feels like black magic, when it’s not it feels like VERY bad juju - reminds me of bluetooth… However it works - it STINKS and pongs to high heaven like a shonky kludge!

All of our browsers are ad-free, regardless of being it Chromium on Linux, or Lightning on Android, Opera or Firefox…
The secret: private DNS…
My network at home uses my home server as DNS, it runs dnsmasq, which does some prefiltering, based on a huge list, then forwards queries to Opendns, where I have some categories blocked, but the contents of those categories are community-updated.
Cellphones use my VPS as private DNS, which implements the same 2 level filtering. The result: we get zero ads on ANY browsers, hopefully most of the trackings are stopped too.
The script that collects list of hosts blocked by dnsmasq in the first place:

wget -O hosts.txt $1
sed '/^#/d' hosts.txt >> collected_hosts.txt

rm *.txt
touch collected_hosts.txt
download https://www.adawayapk.net/downloads/hostfiles/official/3_yoyohost.txt 
download https://www.adawayapk.net/downloads/hostfiles/official/2_ad_servers.txt
download https://www.adawayapk.net/downloads/hostfiles/official/1_hosts.txt
download https://getadhell.com/standard-package.txt
download https://raw.githubusercontent.com/notracking/hosts-blocklists/master/hostnames.txt
download https://raw.githubusercontent.com/StevenBlack/hosts/master/hosts
#download http://hostsfile.mine.nu/Hosts.txt
#download https://curben.gitlab.io/malware-filter/urlhaus-filter-hosts.txt
download https://raw.githubusercontent.com/AdAway/adaway.github.io/master/hosts.txt
#download https://raw.githubusercontent.com/FadeMind/hosts.extras/master/add.2o7Net/hosts
#download https://raw.githubusercontent.com/FadeMind/hosts.extras/master/add.Spam/hosts
#download https://raw.githubusercontent.com/hoshsadiq/adblock-nocoin-list/master/hosts.txt
download https://raw.githubusercontent.com/shreyasminocha/shady-hosts/main/hosts
#download https://raw.githubusercontent.com/Ultimate-Hosts-Blacklist/Ultimate.Hosts.Blacklist/master/hosts/hosts0
#download https://raw.githubusercontent.com/Ultimate-Hosts-Blacklist/Ultimate.Hosts.Blacklist/master/hosts/hosts1
download https://winhelp2002.mvps.org/hosts.txt

cat collected_hosts.txt | awk '{print $2}' > collected_hosts_filtered.txt
cat badhostlist >> collected_hosts_filtered.txt
cat viberlist >> collected_hosts_filtered.txt
#cat league >>collected_hosts_filtered.txt
cat collected_hosts_filtered.txt | tr -d '\015'| sort -u | awk '{print $1}' > sortedlist.txt
sed '/^localhost/d'  sortedlist.txt | grep "\."  | awk '{print " ",$1;print "::0 ",$1}' > /etc/badhosts

The dnsmasq is setup to use /etc/badhosts as addon hosts, via a line in dnsmasq.conf:

As you run couple of servers yourself too, maybe you could implement something similar, so you could use ANY browser ad-free as well.

Edit: I have some lists collected myself, such as a list of servers used by Viber (which I consider a more severe privacy risk than Facebook+Google together…),
and some nasty porn sites list in an other file too…
Maybe I could upload them somewhere, but they don’t fit here.
Are you interested?

1 Like

I used to run PiHole - but both my daughters complained that it interfered with the use of their Apple devices (iPad and iPhones) - so I disabled it on my DHCP server (on my WiFi router) but I kept running it for a number of years - first on a Pi3B, on 64 bit raspbian… then on a pi4B (4 GB) effectively off the same boot medium as the Pi3B (I eventually migrated the Pi4B to boot off external USB 3 SSD)…

But I found PiHole was stopping me watching SBS TV (On Demand) - and it wasn’t blocking ads (e.g. couldn’t block youtube ads)…

Brave? It blocks youtube ads and it blocks SBS On Demand ads!

Brave sync is a PITA, and a kludge, but I’m too wedded to Brave now to contemplate divorce :smiley:

So - I stopped using PiHole, disabled the service on the Pi4B, but I’m still using it to SSH (non standard SSH port and fail2ban installed) to my home network from “outside” and OpenVPN server…

My concept is the same.
My solution differs that it lacks a convenient user interface, but it’s configurable via shell, and it’s more flexible, as I can modify the list of blocked sites at any time.

It is possible to have dnsmasq to log queries. So it’s easy to debug, what sites are blocked by a ‘badhosts’ entry, and remove them if necessary. :wink: