"Immutable Distro" BlendOS

After reading ITSFOSS Article because someone was looking for a way to run Android on Linux outside of VMs, etc. I am intrigued by the possibilities, specifically in the new version released.

My question first is: can you really have some Android apps run on Linux outside of a VM or other container? How does that work in this OS? Switch to Android to use those apps?

Thinking of my portable Linux tablet, (not sure if tablets are supported on this) it would make having some apps I use that are Android-only (i.e., my home security cams app) available on the tablet (this is not available in a browser).

Considering I have no idea how it works, looking for input on the pros & cons as well as testing it, maybe on a separate drive?

Thanks,
Sheila

2 Likes

Hi Shiela,
There are some ‘Android’ apps that run in Solus.
I am not sure whether they have been ported, of whether they
use some sort of container/emulator.
Cheers
Neville

Interesting @nevj . I could try running Solus and see which apps would run. One might be ported as it has a desktop app for Windows as well (and I have run it via Crossover in Linux). But the other I cannot get to run even in an emulator in W11.

Thanks,
Sheila

I dont run Solus at moment. Cant remember, but I think Google Earth was one of them
They are in the Solus Software Centre.

Now that would be a helpful app. I’ll check the Solus Software Center, but I figured if you can run Android (like mentioned in the BlendOS) you can surely use FDroid and other app stores to see if they are there as well.

I’ll keep checking.
Thanks,
Sheila

There is an opensource “fork” of ChromeOS - and it’s a lot easier to get to the Linux underneath than it is on Google “sanctioned” Chromebooks - and - I believe you can now run Android apps “natively” on ChromeOS on Chrome books (but I don’t know if that’s possible on the free OSS fork)…

I actually tried it on a spare laptop - i.e. the OSS fork of ChromeOS… Can’t remember the name though and didn’t spend very long on it…


I think what I tried / used was NeverWhere Cloudready perhaps ? :

You can do ChromeOS Flex and it even has a live boot thingie to try it out…

I like the live session. I assumed all Linux distros had them…I was wrong.

I’ll see if I can research running android apps natively on it. Wonder if that might be a good use for the Surface I replaced. If not, I certainly have a very old laptop I could test it on.

Thanks,
Sheila

Just saw this come up today from a story on GamingOnLinux.com : https://waydro.id/ (I think it needs Wayland - and I can’t run Wayland thanks to Synergy KVM)