INKSCAPE Installed isn't opening

“Extension “Export to PDF via Scribus” failed to load because a dependency was not met.” What does this mean and what should i do? (I think it was in an error log).

FIRST: I have tried a few things to increase my ability to resolve issues on my own and may have lost myself in the process and/or messed up my Ubuntu.

2nd; I did load 22.04 jammy-thinking it might be a fresh start. (I am still a newbie be gracious). :upside_down_face:

(As well, I attempted to sign onto a “forum” in Inkscape but apparently it was in the wrong area and I got some weird email in return.)

3rd; I attempted to remove Inkscape but errors suggested it was “locked” in root. I have attempted so many ways to unlock it but I have failed.

4th I used Synaptic and checked off every Inkscape box hoping it may be the missing “link”- :roll_eyes:.

Being frustrated I went on to getting fun things; Clementine, VLC, some KDE and played alotta mahjongg.
(I probably used all the wrong tags here too.)

Maybe terminal time?

sudo apt purge inkscape

I might also suggest sudo purge inkscape* (asterisk, but not sure what the impact of that might be).

sudo apt clean

sudo apt install inkscape
(note/copy ALL the ouptut / errors and paste it here if there’s errors)

If it complains about unmet dependancies or something,try :

sudo apt install -f
(and note/copy ALL the output / errors and paste it here)

Note : Is this “Export to PDF via Scribus” something you want or need? I don’t know what that is.

Note : I wouldn’t be running 22.04 if I was you - but its too late now, I guess. I’m not running it - still on 20.04 - 25 year linux user, who uses “Vanilla” Ubuntu, LTS - but I don’t usually try the LTS release till it’s had at least one revision, e.g. I probably won’t go to Ubuntu 22.04 until it’s 22.04.1.

I usually find the Inkscape forums pretty friendly, I’ve found posts that describe a symptom I’m having (e.g. recently I had issues exporting to PNG - but turns out I had “Export Area” set to “Custom”, when I needed to either have it set to “Drawing” or “Selection”). I don’t know what this Scribus export thingie is - there’s no scribus option - just plain old ‘PDF’ in the filetype dialog box for “Save As” in my install of Inkscape 0.92 on Ubuntu 20.04. Are you trying some later version of Inkscape?

Do you have Scribus installed? Maybe try purging that as well?

sudo apt purge scribus

Thank You. I see on this forum, most times your advice is pretty much “right on” and I will try these suggestions.
I believe; I have to have the most current version of Inkscape a/c InkStitch is where I am headed. (Embroidery software.)
I had struggled with it, not bringing it’s extensions into Inkscape.

In all honesty here; I have been on/off deleting and purging both and suspect I may have created a mess within my pc and Linux!
BUT “purge Scribus” never occurred to me. I’ll let you know. AND Thanks again.
Just a spit-ball; what if I did have a an older version of Inkscape…then tried my Inkstitch, after I upgraded to The current Inkscape?

OK - I see where you’re coming from now…

I did see your other post about InkStitch but didn’t put 2 and 2 together.

My version of InkScape on Ubuntu 20.04 is 0.92, but you need InkScape 1.01 or later to run InkStitch.

I installed InkScape on my Mac via brew the other day, and it’s version 1.1. Hmmm. Apples and Oranges…

Sorry - I’m not game to try getting a later version of InkScape on my Ubuntu machines, I use it too often and would hate to have a broken Inkscape install.

Hmmm - seriously considering “trashing” the Ubuntu 20.04 install on my Lenovo Thinkpad, so before I do I might try installing Inkscape 1.1 from PPA (I kinda HATE PPA’s) and see how I go, and whether or not I can get InkStitch on there. My missus used to do a fair bit of cross stitch, and we had some Windows 3.11 software she’d use sometimes (but she mostly used pre-bought patterns).


Here’s my series of “things” that successfully got me Inkscape 1.1 and InkStitch 2.x (it was all terminal stuff).

Get rid of Ubuntu repo version of Inkscape (0.92)

╭─x@fenrir ~  
╰─➤  sudo apt purge inkscape
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libgsl23 libgslcblas0 libgtkmm-2.4-1v5 libgtkspell0 libimage-magick-perl
  libimage-magick-q16-perl libmagick++-6.q16-8 libpotrace0
  python-backports.functools-lru-cache python-bs4 python-chardet
  python-html5lib python-lxml python-numpy python-pkg-resources python-six
  python-soupsieve python-webencodings
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
0 to upgrade, 0 to newly install, 1 to remove and 55 not to upgrade.
After this operation, 80.8 MB disk space will be freed.
Do you want to continue? [Y/n] y
Requesting to save current system state
Successfully saved as "autozsys_kr93ak"
(Reading database ... 311363 files and directories currently installed.)
Removing inkscape (0.92.5-1ubuntu1.1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
(Reading database ... 310522 files and directories currently installed.)
Purging configuration files for inkscape (0.92.5-1ubuntu1.1) ...

Note “apt purge” implies the asterisk anyway :smiley:

╭─x@fenrir ~  
╰─➤  sudo add-apt-repository
 The Inkscape Stable PPA is intended to provide the current supported release of Inkscape.
 More info:
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Hit:1 focal InRelease
Hit:2 stable InRelease                                                               
Hit:3 focal-updates InRelease                                                                   
Hit:4 resilio-sync InRelease                                                     
Hit:5 focal-backports InRelease                                                                 
Hit:6 stable InRelease                                                                        
Ign:7 disco InRelease                                                                               
Get:8 focal InRelease [17.5 kB]                                      
Get:9 focal-security InRelease [114 kB]                                                           
Hit:10 stable InRelease                                                               
Hit:11 disco Release                                                                                
Get:13 focal/main amd64 Packages [1,520 B]
Get:14 focal/main i386 Packages [516 B]                 
Get:15 focal/main Translation-en [976 B]                
Get:16 focal-security/main amd64 DEP-11 Metadata [40.7 kB]                                                       
Get:17 focal-security/universe amd64 DEP-11 Metadata [66.3 kB]                                                   
Get:18 focal-security/multiverse amd64 DEP-11 Metadata [2,464 B]                                                 
Fetched 244 kB in 8s (32.1 kB/s)                                                                                                                   
Reading package lists... Done

╭─x@fenrir ~  
╰─➤  sudo apt update

blah blah blah

Install Inkscape (from the PPA) :

╭─x@fenrir ~  
╰─➤  sudo apt install inkscape
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libgtkmm-2.4-1v5 libgtkspell0 python-backports.functools-lru-cache python-bs4 python-chardet python-html5lib python-lxml python-numpy
  python-pkg-resources python-six python-soupsieve python-webencodings
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  adwaita-icon-theme-full python3-appdirs python3-bs4 python3-cssselect python3-html5lib python3-lxml python3-packaging python3-scour
  python3-soupsieve python3-webencodings
Suggested packages:
  dia | dia-gnome libsvg-perl libxml-xql-perl python3-serial pstoedit python3-genshi python3-lxml-dbg python-lxml-doc
The following NEW packages will be installed:
  adwaita-icon-theme-full inkscape python3-appdirs python3-bs4 python3-cssselect python3-html5lib python3-lxml python3-packaging python3-scour
  python3-soupsieve python3-webencodings
0 to upgrade, 11 to newly install, 0 to remove and 55 not to upgrade.
Need to get 27.0 MB of archives.
After this operation, 194 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 focal-updates/universe amd64 adwaita-icon-theme-full all 3.36.1-2ubuntu0.20.04.2 [6,936 kB]
Get:2 focal/main amd64 inkscape amd64 1:1.1+202202050950+0a00cf5339~ubuntu20.04.1 [18.4 MB]
Get:3 focal/main amd64 python3-appdirs all 1.4.3-2.1 [10.8 kB]           
Get:4 focal/main amd64 python3-soupsieve all 1.9.5+dfsg-1 [29.1 kB]
Get:5 focal/main amd64 python3-bs4 all 4.8.2-1 [83.0 kB]
Get:6 focal/main amd64 python3-webencodings all 0.5.1-1ubuntu1 [11.0 kB]
Get:7 focal/main amd64 python3-html5lib all 1.0.1-2 [84.3 kB]
Get:8 focal-updates/main amd64 python3-lxml amd64 4.5.0-1ubuntu0.5 [1,384 kB]
Get:9 focal/main amd64 python3-packaging all 20.3-1 [26.8 kB]
Get:10 focal/universe amd64 python3-scour all 0.37-4build1 [45.5 kB]
Get:11 focal/universe amd64 python3-cssselect all 1.1.0-2 [16.4 kB]
Fetched 27.0 MB in 13s (2,073 kB/s)                                                                                                                
Requesting to save current system state
Successfully saved as "autozsys_lt102n"
Selecting previously unselected package adwaita-icon-theme-full.
(Reading database ... 310522 files and directories currently installed.)
Preparing to unpack .../00-adwaita-icon-theme-full_3.36.1-2ubuntu0.20.04.2_all.deb ...
Unpacking adwaita-icon-theme-full (3.36.1-2ubuntu0.20.04.2) ...
Selecting previously unselected package inkscape.
Preparing to unpack .../01-inkscape_1%3a1.1+202202050950+0a00cf5339~ubuntu20.04.1_amd64.deb ...
Unpacking inkscape (1:1.1+202202050950+0a00cf5339~ubuntu20.04.1) ...
Selecting previously unselected package python3-appdirs.
Preparing to unpack .../02-python3-appdirs_1.4.3-2.1_all.deb ...
Unpacking python3-appdirs (1.4.3-2.1) ...
Selecting previously unselected package python3-soupsieve.
Preparing to unpack .../03-python3-soupsieve_1.9.5+dfsg-1_all.deb ...
Unpacking python3-soupsieve (1.9.5+dfsg-1) ...
Selecting previously unselected package python3-bs4.
Preparing to unpack .../04-python3-bs4_4.8.2-1_all.deb ...
Unpacking python3-bs4 (4.8.2-1) ...
Selecting previously unselected package python3-webencodings.
Preparing to unpack .../05-python3-webencodings_0.5.1-1ubuntu1_all.deb ...
Unpacking python3-webencodings (0.5.1-1ubuntu1) ...
Selecting previously unselected package python3-html5lib.
Preparing to unpack .../06-python3-html5lib_1.0.1-2_all.deb ...
Unpacking python3-html5lib (1.0.1-2) ...
Selecting previously unselected package python3-lxml:amd64.
Preparing to unpack .../07-python3-lxml_4.5.0-1ubuntu0.5_amd64.deb ...
Unpacking python3-lxml:amd64 (4.5.0-1ubuntu0.5) ...
Selecting previously unselected package python3-packaging.
Preparing to unpack .../08-python3-packaging_20.3-1_all.deb ...
Unpacking python3-packaging (20.3-1) ...
Selecting previously unselected package python3-scour.
Preparing to unpack .../09-python3-scour_0.37-4build1_all.deb ...
Unpacking python3-scour (0.37-4build1) ...
Selecting previously unselected package python3-cssselect.
Preparing to unpack .../10-python3-cssselect_1.1.0-2_all.deb ...
Unpacking python3-cssselect (1.1.0-2) ...
Setting up python3-webencodings (0.5.1-1ubuntu1) ...
Setting up adwaita-icon-theme-full (3.36.1-2ubuntu0.20.04.2) ...
Setting up python3-packaging (20.3-1) ...
Setting up inkscape (1:1.1+202202050950+0a00cf5339~ubuntu20.04.1) ...
Setting up python3-html5lib (1.0.1-2) ...
Setting up python3-lxml:amd64 (4.5.0-1ubuntu0.5) ...
Setting up python3-scour (0.37-4build1) ...
Setting up python3-cssselect (1.1.0-2) ...
Setting up python3-appdirs (1.4.3-2.1) ...
Setting up python3-soupsieve (1.9.5+dfsg-1) ...
Setting up python3-bs4 (4.8.2-1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.7) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...

Downloaded the DEB file from there (inkstich URL “above”)

╭─x@fenrir ~/ResilioSync/bigguns/binaries  
╰─➤  ls -al inkstitch_2.1.2_amd64.deb 
-rw-rw-r-- 1 x x 188457682 Mar  7 12:29 inkstitch_2.1.2_amd64.deb
╭─x@fenrir ~/ResilioSync/bigguns/binaries  
╰─➤  sudo dpkg -i ./inkstitch_2.1.2_amd64.deb
Selecting previously unselected package inkstitch.
(Reading database ... 318508 files and directories currently installed.)
Preparing to unpack ./inkstitch_2.1.2_amd64.deb ...
Unpacking inkstitch (2.1.2) ...
Setting up inkstitch (2.1.2) ...

Then read some of the basic usage stuff here :

I drew a star polygon using the InkScape “primitive” or whatever you call it, then converted it to a Path (Path > Object to Path).
Then from the InkScape Extensions menu I chose “Ink/Stitch” them “Params” (per the basic usage guide) :

Note the following takes a bit to display :

Then in Inkscape - I hit “Save As” and there were a bunch of InkStitch export options, including stuff like *.u01 - so I saved in that format… (sorry - cannot get a screenshot) no errors or crashing or whatever. Just a bit sluggish at times (e.g. the preview) - but that could be attributable to my general laggy / slowness on this Thinkpad which I put down to ZFS and ZFS encryption.

OKAY - I’m now going to format that Thinkpad and install Garuda…

Your Mileage May Very due to you running 22.04 (alpha/beta pre-release) - there may not be installers in that PPA for 22.04 - sorry. If you haven’t invested too much time / effort into that Linux install, I suggest you go back to 20.04 (i.e. from scratch - “back to the drawing board”) - sorry.

I hope this helps you!

1 Like

Hats Off Man! I spent lots of time today and finally believe i was able to purge the Inkscape that apparently was locked. One step forward 30 back. (Busy watching the war story.)

2morrow, I intend to follow your actions…and see what I can do.

Several months ago I began w/LinuxMint-Cinnamon and liked it but got so lost I gave up. So, due errors and a fresh start I ran with Ubuntu…at first, easier to understand and follow, now🤔 not so sure. You are right about running to 22.04, i now wish I would have mastered my way to Inkstitch first.

Iam thinking your Mrs’ would be able to create her own xstitch designs on same software.

Thank you again.

HI and Thank You again. :wave:
You are right: 22.04 didn’t have the right version for me…BUT it did have PPA for inkscape.

So in Synaptic I forced it to the next level and it works well, although I had to finally install from the software/snap.

However, Inkstitch will not install! :cry:Packages are broken before I could trouble shoot. Terminal was already removing them!

JA tomorrow is another day! :penguin:

Can I suggest you try again, and when it says stuff about “Packages are broken” - run :

sudo apt install -f


sudo apt-get --fix-broken

or even both ?

sudo apt-get --fix-broken
sudo apt install -f

Then it might either finish installing partially installed pkg (from dpkg -i BLAH.deb) - or you can try it again
sudo dpkg -i ./inkstitch_2.1.2_amd64.deb

Some info : How to Fix Broken Packages in Ubuntu {4 Methods}


Inkscape keeps crashing on my Fedora 35 system!


Inkscape 1.1

I’m updating my fedora (there’s no updates for Inkscape) and will reboot… then I’ll try the same on my Thinkpad running Fedora on the same operations / documents… if it happens there too, I may well end up going back to Ubuntu… I guess I can try Ubuntu 22.04 in a VM and see if that bugs out on Inkscape 1.x…

Never had so much trouble with Inkscape 0.92 on Ubuntu 20.04…


Crashes in Fedora EVERY F–KING TIME! Fedora 35 on my desktop Ryzen, and Fedora 35 on my Thinkpad Ryzen… Always during font operations… on BOTH! I found some stuff from 2018 about Fedora 28 and it was happening BACK THEN on FEDORA!

So - looks like I might be going back to Ubuntu 22.04 as it looks like Fedora are not remotely interested in fixing this issue.

I think it’s a SNAP on Ubuntu 22.04… It’s frigging annoying…

It was working perfectly only just over a week ago when I made a meme relating to my success getting Path of Titans working on Fedora :

Note : Path of Titans, which is supposed to be all dinosaurs, also includes the extinct pleistocene Australian monitor “megalania”, which was 3-4 times the size of a Komodo dragon… And the name reminds me of a the former Flotus…

Going to try the snap package on Fedora before jumping out of the frying pan, into the fire…

It seems snap install of inkscape is one answer… not happy with that… seems to deploy its own “snap” based file save dialog boxes, and doesn’t use any of the gnome stuff … piece of crap… but I won’t be jumping back to Ubuntu… :smiley: but it doesn’t crash…


This is crazy. Inkscape is a major package. It ought to work anywhere.

I wonder are we entering a stage where distro makers are too lazy to keep package dependencies up to date , so they are forcing us all into snap or flatpak?

Inkscape installs OK in Debian. So it might be some recent version that has your issue.? Try an old version.

1 Like

That would straight up be a major argument to me for opting out of a specific distribution if its maintainers would implicitly do that.


I was hoping there would be some way to resist it. We have 2 cases today of package failures . Not saying they are deliberate, but I am watching for any trend.

1 Like

I’d say it’s not deliberate, at all. I’d say it’s natural. If one form of packaging becomes less popular and less people care about it, then naturally its quality will degrade. It’s a natural process. If you keep your sword out in the garden, without oiling it up and keeping it safe from any weather condition, then it will eventually rust up and break, after degrading in quality for a large amount of time.

1 Like

Use it or lose it.
Applied to packages that means we should support distros like Debian that log our usage, so they will at least know what is popular.

I think Void had this problem… they dont log usage… some of their packages update more frequently than others , and it is not supply driven either, because some packages get behind makers releases, so I have no idea how they decide what gets most support.

The ironic part about this is, that a majority of users switch to platforms like these, because they want to get away from tracking, altogether. They are so traumatised from what Google and Microsoft has done to them, that they don’t even allow legitimate logging/tracking of seriously minor stuff.

I personally allow the logging during the installation half the time, I guess. Sometimes, I disable it, sometimes I enable it. It depends on the situation.

At least you get the choice, and it is rather innocuous stuff that they log… nothing like the personal stuff Google has access to.

I think Void’s problem is lack of support people. Lots of distros face that issue and they mostly deal with it by pruning the repository and slowing the release cycle. Void has a large repository and rolling release … that makes for a lot of work.

The other issue is with derivative distributions to begin with.

For example, Artix and Arch Linux are quite similar. Right? Wrong.

Even though, they seem so similar and it seems like Artix should be at least as stable as Arch, that’s not the case in reality.

Artix is actually much more unstable than Arch and sometimes doesn’t even get basic things to work, like for example displaying fonts correctly in Firefox. This issue does not exist on Arch Linux.

One should not under-estimate the power of breaking things, when making a derivative distribution of a bigger, more popular one.

Quote of the day.

Void, of course, is not derivative. In some ways it is a simplification and that in theory should break things less. That seems to be true in practice… the independents like Void and Solus dont break a lot… they just struggle to keep up with limited resources.

And my own power of breaking things exceeds that of any distro.

I see, didn’t think about it being independent. The problem with independent distributions is that they are always unfinished. By the time they are pretty stable and usable, at least 20 years passed. This is one of the major reasons, people usually rely on the originals or derivatives based on the biggies, like Ubuntu, Debian, Arch, Fedora, etc…

Okay, Ubuntu is based on Debian, but I’m certain such a success is not the norm. Ubuntu is that one celebrity that made it to the top 3. However, a billion others didn’t make it. They are performing in an underground café for a handful of people for the past 15 years…

Perfect QA Tester. :laughing: