Install Cozydrive on Linux Mint

This has become my obsession I know, but solving it seems the only way to overcome my frustration. In answer to one query, I find nothing about Cozy in /var/log.

I have wondered if I might get somewhere by sharing my experience when trying to follow instructions given in the web site

It is noted that after download, all I need do is activate the permission, and I am off. To integrate there is the following instruction: chmod +x ./.AppImage, but when I try that I get the message: chmod: cannot access './.AppImage’: No such file or directory. I get a similar message after every instruction I try.
The Cozy response is that the download must be elsewhere else but can’t help further, and I have tried opening a cozy file wherever I can find one, but none will sync.

It would be good if this might show up an error in my approach that someone might recognise.

Many thanks again.

Where did you down load the appimage to? If in downloads then you have to navigate to where the appimage is and change the permissions there. In the gui in mint all you need to do is right click on the appimage and select properties and then permissions and make sure there is a check mark in the box in front of allow executing file as program That is it, you can the click on the appimage and it will launch the client. if you want to add it to you menu you can manually do that.
I would suggest moving the appimage to a different folder you create in your home directory say name it appimages. or whatever.

The message means exactly what it says… ./*.Appimage does not exist.

Do what @kc1di recommends. Downloads directory is not a good place to work from. Move the downloaded appimage to your home directory, and work there.

./*.Appimage is a relative file path. It looks for things called *.Appimage in your current directory. So your current directory has to be where tbe .Appimage file(s) are, or it will not find them

Exactly what I mentioned in my tutorial, well ish :laughing:

1 Like

I am very appreciative of all the helpful suggestions I have had and for the patience of those making them. I would like to comment on the advice, but I think that I shall have to admit defeat. This has taken hours of my life and has produced nothing but frustration.

First of all, when I type ./*.Appimage I am told there is no such file or directory. However, if I go to Home/myname/.AppImages/. there is a file that contains the cozy appimage that I downloaded, and I can access cozy from that.
As I have written before, I have a folder on my desktop labelled ‘files’ (and that has seven subfolders). When I set up Cozy, it transfers that desktop folder to cozy. But it does not sync anything that I subsequently add. That has been the problem all along.

As for kc1’s query I have (repeatedly) downloaded cozy to ‘downloads’. Following instructions on the cozy website, I executed the file as program, and that is supposed to do the job, although they suggest moving the folder to a new one labelled ‘Applications’ in order to prevent an unwanted deletion from the downloads file. Again, I can open it, download existing files, but not sync. Following KC1’s latest suggestion, I have gone to Home and downloaded the drive to the desktop home/myname/.appImages. That produces exactly the same result.
I truly feel that with instructions from the cozy website and the help from these pages I have done things correctly. But whatever I do the result is the same: initial connection works, but no syncing.
I apologise if I have missed the points made by nevj, but I have also tried as best I can to do what he suggests.
Is there a way to find where appimages are stored? They seem to be where I put them, but apparently are not.
Kind regards, beacon

Thanks. I think I will leave it to you. I have no experience with appimages

I was joking you know? Isn’t it weird though? It happens time and time again.
Do a tutorial with everything outlined and it doesn’t get used? Explain with a couple of lines and it does?

I’m afraid I am a bit out of it with this exchange. I obviously have made a faux pas of which I am unaware but for which I sincerely apologise. It must involve the tutorial kindly provided by clatterboardslim which I may seem to have ignored. That is not at all the case, as I tried to follow the instructions, but failed the test. At the outset, there was no need to create the new applications folder, as it already existed. But when I tried to go further my ignorance stopped progress. I shall try again tomorrow to see if I can do better.
I’m sorry for any offence.

There are two reactions

  • “just tell me which buttons to press”
  • “explain to me how this works”

I dont claim to be a teacher, but until people get to the latter they remain dependent on some form of help

You have a lot of patience and write detailed replies. When I read your reply I thought, gee if they cant follow that there is no hope. I bave no idea why it was not followed.