Install Cozydrive on Linux Mint

I wonder if anyone else has used or tried to use Cozydrive on Linux Mint (I am using Cinnamon 20.3). I have used it in the past and found it the best backup and storage app I have used. However, after re-installing my os, I cannot for the life of me get it to work. I download the app image and activate it, and Cozy downloads perfectly. Yet it will not sync with the desktop as it should. I have had so much help from the help team that I am embarrassed to ask them for more. Has anyone been successful, and if so, could you possibly explain what I am failing to do. I’ve been tearing out my hair for several months on this, and I dislike giving up when I got it working before.
Many thanks.

Hello @ljohn,
I have Cozy Cloud up and running fine on my mint 20.3 machine.
And it’s working fine. Have you been able to sign into your Cozy Cloud account?
I simply downloaded the appimage and made sure it was executable then signed in and all my back ups were there.

Hello kc1 and thanks for the quick reply. How I envy you. As I said earlier I have had problems since February. I have done as you did: downloaded Cozydrive appimage, made it executable and signed in. I can access the account, and it loads my ‘drive’ but always stops short of the present date; for example, although the message states the ‘my cozy is up date’, there has been nothing added since the 5th of June. I simply can’t get the system to sync.
I wonder if you could help a bit more. The Cozy help team keep telling me that the drive is downloading files somewhere else, but I don’t understand. If I go to home, I find cozydrive listed in applications, desktop, and downloads, as well as a separate folder called cozydrive. I copied the last of those to the desktop, but it did nothing to help. I feel that I am doing or not doing something quite infantile that has messed things up, but weeks of loading and downloading and using other distros have done nothing to help.
If you ,or anyone else, has suggestions, I’ll be eternally grateful.

a couple things you can look at are under settings have you tried Reinitialize botton?
They give you 5gb of space is that by any chance full?

@kc1di Thank you once again. I have tried what you suggested many times. And I have connected and unconnected devices and configured over and over. I think perhaps that may be the problem. I have tried so many avenues that I probably have made a complete mess.
I’m sorry to trouble you again, but perhaps you could answer one other query about the set- up. I have downloaded cozydrive and activated it in the download folder. Then, according to the installment suggestion I have copied that to the Applications folder. I have then copied that to my desktop. I wonder if that procedure has anything to do with the issue.
Many thanks again.

Sorry I’m afraid I can not answer that because I’ve never done that… Only thing I did is run it sign into my account and copy one folder into the cozy drive folder and it syncs fine.

With AppImages always inside your hidden files, in your home folder create a .AppImages folder. Then create a CozyCloud.desktop file like the one below which you can use as a template. Saved and activated like your Cozy Cloud AppImage, but in your .local/share/applications folder.

When you get to the Categories=Network; always put semi colon on the end, don’t know why but it works with it.

Thank you again kc1di and also to clatterfordslim for the helpful suggestions. I started over (for the umpteenth time) and did exactly as kc1 described. I am still not certain that it has worked. I wonder if I am expecting too much, so may I ask another question? I have on my desktop a folder labelled ‘files’ which has six sub-files. I feel sure that when I had Cozy working at one time that I could write something, put it in one of those folders, and it would also go to Cozy drive. Now there seems to be no interplay between the two. That is a restatement of the issue.
Thanks for the other suggestion, clatterfordslim. I appreciate the directions, but I am stuck at the first hurdle, owing to my lack of skills. Setting up the template is clearly laid out, but how do I get to the first stage; i.e. [desktop entry]?
Gratefully, beacon

I dont know Cozy, but I gather that it works like Dropbox but within your own computer… ie it syncs files between your folders and some backup filesystem.
Given my limited understanding, I think that it might be something very simple that is preventing it from syncing

  • have you checked file permissions.
  • is the cozy daemon running… there must be a background process ( called a daemon) that periodically runs something like rsync to copy any new files.
  • is there a cozy user? is there a cozy group? Do you as a user have to belong to a ‘cozy’ group?

If you dont understand these questions , it is a good chance for you to learn about file permissions, users, groups, daemons.
There will be a solution, but you may have to negotiate a learning curve


You will have to move the Desktop folder you want to sync to the cozy drive folder in your /home directory. It will then sync the folder.
there may be other ways to do it but that is the simplest.

So, correct me if I have the wrong impression, but it seems to work like Dropbox… you have to put the stuff you want to sync into a particular directory?

That’s what it looks like to me. very similar to dropbox.
There may be a way to sync other folders but haven’t found it yet.

Maybe put a link in the ‘Dropbox’ folder

I had tried that (in the Cozy Drive) folder but did not work. There must be a way but I haven’t found it yet. The OP seems to indicate that he had it working before. But I’m not sure how he did that. It’s not intuitive anyway. I prefer to back up my system using timeshift to an external medium it works well.
Or just copy important files to a USB drive. So have limited experience with cozy drive.

1 Like

Inside Nemo file manager push CTRL and H together on your keyboard, alternatively at the top next to Edit is View tab left click it and you’ll see Show Hidden Files. Left click it with your mouse.
You’ll see a bunch of folders with . at the beginning find the one that says .local. Open it you’ll see a folder that says share. Open that and you might see a folder that says applications? I remember in past versions of Cinnamon that it was not there, so if not create one. Right click on your mouse inside empty space, what I mean is do not highlight anything like folders or text that you see. When you right click empty space there will be a list that comes up, you want the first one Create New Folder. Call it applications then open it right click again and choose Create New Document Choose Empty Document. Open it with Xed, in here you can go back to my previous post or download template below.

I know this seems like the long way round and yes I could of given you a bunch of Terminal commands to put in to set it up, but doing it this way actually teaches you some stuff too. Once you have created your file using template above, save it as Cozydrive.desktop. Do not put the full stop at the end, that was only to finish that sentence. Remember to use your name in the script and not mine. Remember to create a .AppImages folder in your hidden files in your home directory, the . keeps it hidden. Also once your file is created you’ll need to go into properties of this file and tick the box in permissions Allow Executing As Program If you run into any trouble with this file, then please let us know. We are all here to help.

1 Like

I have been without the internet for three days, so I have just now seen various replies. All are appreciated, and I’ll do what I can with them today and write about the outcome.

Hello again to the helpful contributors. I feel certain, as was stated in one item, that there is something quite simple that I am doing wrong. What is almost inexplicable is that I once had Cozy working well (I think on Mint 19) with no problem at all. Like kc1, I simply downloaded, gave permission, and then had not further difficulty. I have today gone through all the suggestions that have been made, and still have had no joy. That is, except for Clatterboardslim’s proposal. I am following it up, but as he says, there is a learning curve that may take me some time. I have, however, read up on permissions, and that has been helpful. I’m not certain yet how to check if cozy daemon is functioning.
I have been puzzled throughout this saga that whenever I put ‘cozydrive’ in the terminal, the message is that there is no such file or directory. Ditto for ‘ls - l’, but I assume that is because it is an AppImage.
I’m losing confidence, but I don’t want to give up and very much appreciate all the help I have been given.

You can look to see if any job is running with
ps ax | more
There will be several pages of jobs listed one per line, so it would help to know the name of the daemon.
If I had to guess, I would think it might be called cozyd. does anyone know?

An update. I’m still trying. I had a friend much more knowledgeable than I look briefly at my computer, and the suggestion was to find an alternative to Cozy. I simply dislike giving up, as when it works, Cozy is unsurpassed in my opinion. I followed the suggestion by nevj and found endless lines about cozy Here is only one sample:
1274 ? Sl 15:50 /tmp/.mount_Cozy-DMP4Bgx/cozydrive-bin --hidden
1281 ? Ssl 0:05 /home/larry/Applications/Cozy-Drive-3.35.0-x86_64_8
d098ea64ab4dc88d47af161b5ef7e84.AppImage --hidden
1314 ? S 0:00 /tmp/.mount_Cozy-DMP4Bgx/cozydrive-bin --type=zy

There are many more.
Regards, beacon

I think you can conclude cozy is actively running.

Now, is it configured so that if you put files in a particular directory, they are backed up?
If yes… then what happens if you put a file in that directory?
If no … then how is cozy supposed to know you want a file backed up?

And… does cozy make log files? They should be in /var/log. If they are present, have a look at them, they might give us some clues.

Keep at it