Installation of Linux Mint 20.3 on Acer aspire ES 15

Have installed Linux Mint on various PC’s. Now I have tried to install on my newly bought used Acer Aspire ES 15. I have used your procedure, and tried Linux installation guide. I used Etcher to make bootable USB. I looked at the partions, running a live session. and the Linux is not mounted . There was a FAT partition, a
ext4 partition, and a free partition. The lap top will not boot in installation.

Does it run the live session? If so go to a terminal and type the following and post the output here.

Inxi -Fxxzr 

My partitions

This may sound like a silly question but if you are not able to boot into the installed Mint system, how are you posting the disk screenshots? Are you using a live session here?

I have the USB in the laptop and running a live session.

I thought so.

I can see the EFI and Linux partition and technically, it should work.

Since it is not booting into the system, may I suggest going into the BIOS and checking the boot settings? What do you see in the boot order? What boot options are available there?

I have also been into ACER Community. There , In My toppic “Boot problems with ACER ASPIRE ES1-531-C7Q1”, I got new ideas,
Now the Linux Mint is working. THANK YOU for ALL HELP!!!