Installation of Linux Mint 20.3 on M.2 leaves it unbootable [solved]

Hello alltogether.
I try to install a Linux Mint 20.3 on a newly installed M.2 (WD Blue SN550 NVMe PCIe M.2 Typ 2280), thought it would be a piece o’ cake…

Unfortunately it isn’t. That’s why I now seek some advice from my fellow GNU/Linuxers…

What have I done so far?
The M.2 is supposed to replace a SSD.

Bootet up with a Linux Mint 20.2 (on later tries 20.3) and startet the installation.
Here is my current setup:

/dev/nvme0n1p2  --> The partition of the M.2 to be installed to
/dev/sda        --> My current SSD (forgot to plug it out for installation, did this in later tries)
/dev/sdb1       --> My current (and future) /home directory
/dev/sdc1 thru 3  --> An external USB HDD

The installation process worked smoothly until the actual installation start…
M2-Install 4

Roughly translates to:
Failure to mount a filesystem of type vfat from /dev/nvme0n1p1 as /boot/efi.
Resume the partitioning in the partitions menu.

I tried to “ignore” this, just for the sake of knowing what would happen…

Installation went as expected and I booted the system.
But it is stuck at a blinking prompt in the left upper corner with no messages or errors at all.

I tried to do, what Linux Mint assistant suggested and partitioned the M.2 with Gparted beforehand the installation
with a small “efi” partition and a larger “normal” ext4, flagged it with “boot” and hoped for the best.

Still no success in installing Mint on sayd M.2 until today.

Websearch has not shown that a special treatment is needed for M.2 installations, nor any needed partitioning.

Maybe someone can hint me in the right direction.

Did you check the basics already?

I would also recommend removing/disconnecting all unnecessary storage media from the computer, to make sure the installation only ever focuses on the storage medium, which is important to the installation. This solved a lot of issues for me in the past.

Hello and thanks for your answer.

I thought, I did, but you dug up some serious threads that I have not found and am currently plowing through ans taking notes for further tests… :flushed: (<- couldn’t find an emoji for “embarassed”).
Some of the issues seem to address the fact of not seeing the M.2 at all and not being able to partition it. Luckily this is not my major problem.
Tomorrow will be a good day for diving into some of the suggestions I’m reading right now.

You are right. Will do. And report with any changes or success.

1 Like

Hello, alltogether.
Call it coincidence, or maybe a miracle…
I tried the install today again, and it worked out fine.

Being confronted with such oddities merely on a weekly basis (from others), I can’t really explain this.
The only thing I did was partitioning the M.2 with two partitions (30 MB, FAT32, esb, boot and the rest as ordinary ext4).
But I did this the times before too…
On the install wizard I chose “other” as usual and checked the ext4 part as my root and the M.2 as host for the bootmanager.
And it worked from there, without any of the prior errors…

I would really like to give some real solution in case someone else might run into similar problems.
But I can’t. Maybe it’s the old PEBCAC situation and I did something stupidly wrong all the other times before.

Long story short: It worked.
Thanks to @Akito for helping out again.