Installing ububtu with windows 10 dual boot HDD,SSD (legacy mode)

i’ve currently windows 10 installed in legacy mode in my hdd along with ubuntu in dual mode (which i installed via legacy bios dual boot tutorial) now i’ve added an ssd to my system, and wanna remove ubuntu from hdd and install it in dual boot on ssd in legacy mood. I know there is a tutorial for it but its for uefi mode. What steps do i need to do to achieve the same in legacy mode?

The easiest way would be to use clonzilla and clone W10
and Ubuntu to the SSD.
To remove Ubuntu from the HDD, make sure you are in
Windows and delete the Linux partiton using Disk Management,
You will need either a cd or a bootable usb to boot the
pc and repair the MBR.
In the recovery console navigate to the button that
has the Command Prompt, and use bcdedit to repair the MBR. Usually two bcdedit
commands will repair the MBR " bootrec /fixmbr " and
" bootrec /fixboot ". I now keep Linux and Windows on
separate drives and use grub to boot the PC. Even then the Windows MBR can become corrupted.

Always install Linux after installing Windows–then Grub will function properly. You can use Grub Customizer to tweak Grub–it’s in the Ubuntu repository.

Grub Customizer will break Linux. Take the time to
learn how to edit grub with the " nano /etc/default/grub "
command, it isn’t hard.

no i wanna keep win10 installtion on hdd as it is, just wanna delete the linux partition on hdd and install fresh ubuntu on ssd but am confused about the boot loader part. should i install the ubuntu bootloader to ssd when it asks on the partition screen during installation or in hdd?

OK, deal with the HDD and Windows first, you will still have to repair the HDD MBR so Windows will
boot. If you do not, then you will get a grub boot error.
Install Ubuntu on the SSD and install grub to the SSD MBR. Go into bios and make the SSD the first to
boot. In Ubuntu you will need to run " sudo update-grub " and os-prober should pick up Windows. Reboot
and you will have a grub boot menu. I have grub to boot Windows first on my machine. Good Luck.

IF memory serves, Microsoft DEMANDS to be put in the FIRST sectors of ANY drive it’s installed on. Linux don’t care. ALWAYS put Windows on the first empty drive partition FIRST.
Personally, Unless your some kind of masochist, steer clear of duel boot completely. You could use two drives with each OS on a separate drives and boot with BIOS. I’ve done both before and the second option was the most stable and successful. Naturally, the data drives were separate from the OS drives.

I do believe two drives is what @Ghulam_Jilani_Raza is referring too. If grub is used to boot
the PC then the Linux drive will have to boot first. A lot easier to add Windows to grub than
to add Linux to Windows. I hope @Ghulam_Jilani_Raza has a system image of W10 before
the install of Ubuntu.

Never had a problem, 4dandl4

Here’s my biggest concern with these kinds of posts - where you can’t even be bothered spell the name of the distro (I deliberately misspell Ubuntu sometimes - for sh!ts ‘n’ giggles - but I’d NEVER start a n00b thread by mispelling the name of the distro) - what typographical errors did you inadvertantly type? If you can’t spell the distro name in your topic, can you even use the computer clipboard? It’s okay if you want to sound disrespectful of a technology or brand name if you’re familiar with it - but when your a foetal newborne - please try and SPELL every word correct - in UNIX and Linux “grep” and “gerp” are not the same thing. But I’ve been doing this shit forever - and on systems I’m gonna be using for a while (i.e. more than 6 months, I sometimes add “alias gerp=grep” and “Grep=grep” to my .profile and/or .bashrc / .bash_profile and .zshrc [and right there is the reason most times I can’t be arsed - because I never know which bash profile is gonna load]) because I do occasionally mistype “Grep” when I’m piping 'cause I’ve held down the shift key after hitting “|”…

Summary - if you’re a newbie and you can’t be bothered to type the name of the “thing” properly I’m severely disinclined to offer any assistance whatsoever, and secretly kinda hope you fail and go back to Windows…


I recently had to do a “handover” to an “off shore” UNIX “engineer”, who expected me to baby him all the way through for literally DAYS and DAYS of drawn out agony - whereas I’m a firm believer in how I was educated, “thrown in at the deep end and sink or swim” (my early education was from nuns, they were shit - I learned the alphabet by watching Sesame Street as a 10 year old!).

Anyway - I babysat this baby for THREE F–KING HOURS (it might have been 5, all I know is I will never EVER get those hours back!) while I watched as he tried to open a keepass database - we “collaboratively” tried ALL sorts of things - different drives, different copies of the keepass database, I coudn’t repeat his symptoms on Citrix - so we tried it by RDP to a Windows server from Citrix (and we had to get Wintel team to give him access to the server) - and the same issue… and - l admit - I’m lazy - I keep the master password for that keepass somewhere else, so I can copy + paste it into the password prompt from keepass (does anyone really EVER type those hideous strings of random characters into a field?)… so I double clicked on the password (instead of drag select) and this doesn’t select the WHOLE string - and when I pasted that into the keepass - I got the EXACT SAME error in keepass we’d been trouble shooting for HOURS OF MY LIFE I WILL NEVER GET BACK!

And sure - when I told him to try “drag select the whole string” - it worked! MAGIC!

It’s lucky this “UNIX Engineer” is in a different timezone to me and maybe two flights away - because I’d have hunted him down and punished him, severely (or fantasized about doing so).

Sorry - for stealing your thread mate - I’m a wordy individual…