Issue adding mesa driver ppa to Linux Mint 17.3


#1

Hey all,
Tried installing the PPA for Mesa so that I could use Proton as instructed here:

My problem is that when I try to add the ppa it tells me it can’t add the repository to trusty. I’m using an Intel graphics card.
This is the command I ran (Straight from bash history)

apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386

Unfortunately, I do not have the root password, FIY.

Any help would be appreciated, Thanks!


#2

Are you trying to install software on your system without having a root or corresponding sudo password?


#3

Change the above command to sudo apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386
you will have to enter your user password.


#4

sudo != user

root has its own password, user has its own password and sudo has its own password.


#5

sudo != user

root has its own password, user has its own password and sudo has its own password.
in Mint 17.3 if it was installed in it’s original form only user password is required. So user password will work as administrator’s password as well there normally is nor root password set in ubuntu/mint.

If op doesn’t know his user password then he would not be able to login to desktop.
sudo is the protocol used to access root privileges on stock ubuntu/mint systems.


#6

Yes and one needs root privileges to install software. So if the user logs in using their user password, that doesn’t require them to know their sudo password, if they are in the sudo group, in the first place.


#7

It’s not my computer, but I can get someone to put in the password for me. Sorry, should have clarified.

Also, I did use sudo, I just realized I copied from the wrong bash history. I used su in my user for the administrator account.


#8

It’s important that you either use sudo or run the commands as root. If you still get the error once making sure you have enough privilege to execute the commands, you should elaborate on the errors given when trying and failing to execute the desired commands.


#9

Alright. I’ll report back with specific error messages when I try again later today. Thanks for being willing to help.


#10

and this is exactly why we use a root password.