Issue w/ Pulseeffects on Ubuntu Studio 22.04


I’m on Ubuntu Studio 22.04 LTS. Installed Pulseeffects and noted that it doesn’t work. Once it worked for speakers only (no output for earphones) and then it stopped even for those.

I’ve another laptop with MX Linux and Pulseeffects work perfectly on it.

Perhaps some support files/library etc. is broken…? I’m no Linux expert but can run simple commands, diagnosis etc.

Please help.


1 Like

Let’s find out by completely wiping pulseeffects and giving it a clean reinstall. Please enter the following commands and then try it again and see what happens :

sudo apt remove pulseeffects
sudo apt autoclean && sudo apt autoremove
sudo apt update
sudo apt install pulseeffects

That should rule out a bad install…if that was the problem…

1 Like

Thank you for the prompt reply.

Just ran all the commands and then played something. Still no output via pulseeffects.

1 Like

Ok let’s try clearing the config. Do the following :

Rename the “pulse” folder located at /home/.config to anything - just to back it up
In a terminal:

pulseaudio --kill
pulseaudio --start

See if that does any good…


Just did it, then log out, log in. Nothing happens. Same thing. No output if pulseffects selected under configure audio devices…

Ok… please paste the output of the following command :

lsmod | grep snd_hda_intel

snd_hda_intel 53248 11
snd_intel_dspcfg 28672 1 snd_hda_intel
snd_hda_codec 159744 4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core 110592 5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_pcm 143360 10 snd_hda_codec_hdmi,snd_pci_acp6x,snd_hda_intel,snd_hda_codec,snd_compress,snd_soc_core,snd_hda_core,snd_acp3x_pdm_dma,snd_pcm_dmaengine
snd 106496 39 snd_ctl_led,snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm,snd_rawmidi

Do this (make sure you do it only once though)

echo "options snd-hda-intel model=generic" | sudo tee -a /etc/modprobe.d/alsa-base.conf

After that reboot your system and see if anything works…

[Thank you for helping me in almost real time man!]

Amazing! That command enabled my Renoir Radeon High Definition Audio Controller
However, still nothing happens if you select audio via pulseeffects!

Guess Ubuntu+Pulseeffects is jinxed… :frowning:

1 Like

Glad to hear I did something… lol … it might just be an incompatibility somewhere…

One more thing you can try is this :

nano /etc/modprobe.d/alsa-base.conf
change “generic” to “auto”
If it still doesn’t work, then reboot and see what happens…


Yes, seems so.

Thanks again.

my prompt says…File is unwritable

gah … make that:
sudo nano /etc/modprobe.d/alsa-base.conf

Nothing happens. Screw this. Some kind of serious incompatibility between Ubuntu and pulseeffects. Let it be.

Thank you again Doron!


alright, I’ll keep my eyes peeled for something different.