Issues with making EasyOS run (in a virtual machine)

Rosika, I think what you get in return for helping is learning something yourself. The returns come more from your thinking and learning, less so from the other person.

You have taught me a lot about various aspects of computing, just by dragging me into thinking about issues. I appreciate that from you and from all itsFOSS contributors. The benefits for me are far greater than anything I give, and I think that applies to you too.

There is a saying among scientists
" keep turning over stones"
meaning you will never discover anything unless you look

And I think this is an appropriate place to say that we all appreciate the effort @Akito makes to keeping us all looking and sometimes opening doors to whole new areas.


1 Like

I would strongly suggest she learns the most from her personal projects. Every IT guy, who helps people, knows that 99.99% of problems someone is asking you to help for is something boring, you already have done a thousand times and it’s always the same. I guess the same happens to @Rosika. Especially, since most problems wouldn’t have happened in the first place, if they just followed the advice of using Clonezilla for backups.

Thanks for the appreciation, though I don’t think it’s really that justified.

1 Like

I dont find it like that. I guess I must be different. Every situation is different, even the classic “no backup” scene. Everything prompts me to look into something . I learn as I go. Maybe my inexperience in the real world is showing?

And, what you learn, is not a whole lot of facts, but how to investigate things.

Most people like mystery stories ( or detective stories)… because they are about restoring order out of chaos ( or triumph of good over evil , if you like). Computer problems are like mystery stories. The attraction is setting everything right, in a scene where it is always possible to ‘solve’ the problem.
Not all issues in our world are susceptible to ‘problem solving’ . For example issues like unemployment, war, climate change… they are not closed systems like a computer. You can not deduce a solution… they require a creative approach.
So computer problems are like a game… an escape from real world issues to something easy where a solution is always possible, just by logic.

OK enough philosophy… wife says I have to go and clean the house. More real world issues I am afraid.

1 Like

I fully agree with what you said – your description is very accurate and to the point.

However, I think it does not apply to things you have done over and over and over and the difference between each time is so small, you do not notice the difference. If you do stuff like this, you barely learn anything. You perhaps perfect a relatively simple process, though I do not consider this big progress.

For example, if a car mechanic changes tires for cars and then has to change tires for an aeroplane, then of course this is new, exciting and there is much to learn from. However, if a mechanic already changed tires a thousand times, then the thousand first time won’t be any different, to the brain.

I am pretty sure, there must be a graph somewhere that shows how the amount of how much is learnt decreases every time you repeat a process. If you do a certain process a thousand times, you can still technically learn the thousand first time. Though, my point is, the amount of what you learn between the thousandth and the thousand first time is so minuscule, it does not have any meaning or impact, at all.
It’s better to just do something else altogether, as there is so much more to learn.

1 Like

Thats why I like research. You are always doing something new
Lets try and make itsFOSS like that… we should be always asking questions.
You actually get very few simple help requests… posts are mostly new issues.


Hi Neville, :wave:

You´re very right, Neville. In fact it was on many occasions I was thinking the same. :wink:

That´s a great compliment, dear Neville. Thanks a lot. :heart:
Yet I have to say it´s me who has learnt a lot from you @nevj , @Akito and all the other kind folk here on the forum. Be thanked a thousand times. :heart:

Yes, I couldn´t agree more. Thanks so much @Akito. :heart_decoration:


Hi and thanks to you as well.

How nice of you to say so. I also try to keep it seeing this way.

Yes, it seems that way. :wink:

It is justified, Akito, it really is. :+1:
Please accept my thank-you as well. :heart:


Believe it or not:
I just finished another anydesk session helping another friend who just returned from her holidays in Norway - completely unrelated to the one I helped yesterday.:wink:
What a coincidence…

Many greetings to all of you.
Rosika :slightly_smiling_face:


Hi all, :wave:

just wanted to to tell you I received a threefold answer by Barry Kauler:


This link outlines the partitions of the image file and how to mount them:

How to update EasyOS

…look near bottom of page.

4.0 is a rather old version, the current is 4.3.4. It has the Limine
bootloader in the esp partition. 4.0 has rEFInd bootloader. Limine is
introduced here:

Limine bootloader

I have never tried to run EasyOS in a virtual machine, and I don’t
recall if anyone has done it. But, I don’t see why it cannot be done.


Note also, the online docs are being updated and require Easy 4.2.2 or
later. There were major structural changes in 4.2, 4.2.1 and 4.2.2.

The two links I provided are for 4.2.2 or later.


I had a vague memory that at least one person reported success running
EasyOS in qemu, so did a quick search. Success report:

EasyOS 32-bit Dunfell-series version 4.3.2 - Puppy Linux Discussion Forum

So it seems I downloaded an older IMG file which makes use of the rEFInd bootloader as opposed to the Limine bootloader used by later versions.

I´ll still have to take a closer look at the link he kindly provided in 3.)

Many greetings from Rosika :slightly_smiling_face:


@Rosika Do you use virt-manager?

If not, why not?

If you do, which version are you using?

I think using virt-manager makes the process very straight forward.

1 Like

Top bloke, lives in Perth (like me) and had him as a lecturer at Uni - a study unit for x86 assembler programming, and his excellent book (“PC Architecture & Assembly Language”) was part of the curriculum, and one by Peter Norton, about x86…

AFAIK (as far as I know) rEFInd bootloader was mostly for cases in early implementations of UEFI and intel based Apple hardware - and not needed on more modern distros and UEFI implementations. I last used it on an old iMac (2,1 circa 2006) to boot Xubuntu…

1 Like

Hi all, :wave:


Thanks for your reply, Ahmet.

Yes, indeed, I have virt-manager available on my system.
The version is 1:2.2.1-3ubuntu2.1 .

I see. Well, I´ve got to dig a bit deeper to see how it´s done. Thanks for the suggestion. :+1:


Wow, that´s great. I´m impressed. :+1:

Well, as soon as I will have saved up enough data I´ll try downloading version 4.3.4, as was suggested.
Perhaps I´ll be more successful with that one.

Many greetings to you all.
Rosika :slightly_smiling_face:

@Rosika we might be talking about two different apps. My version is 4.0.0

I was able to use it easily after this video.

At some point, I also remember doing KVM/Installation - Community Help Wiki but it is not mandatory. I was exploring Android development and and I think I see somewhere that it improves the performance of the emulator.

1 Like


Hi Ahmet, :wave:

sorry I couldn´t reply earlier.

Thanks for your latest comments.

Right. I was under the impression you were talking about cli-commands.
I see now you were referring to the GUI. :wink:

Well, I have that installed as well. My version however seems to be lower than yours:


It´s version 2.2.1.

But it works very well and apart from trying EasyOS to get to run/install I never ran into any problems.

I guess I still have to download the latest EasyOS version 4.3.4 and see whether this is better suited for running in a vm.

Thanks also for the link and many greetings.
Rosika :slightly_smiling_face:

Hi all, :wave:

in the meantime I posted the install issue on Barry Kauler´s forum ( EasyOS 32-bit Dunfell-series version 4.3.2 - Puppy Linux Discussion Forum ) and after a bit of work I got EasyOS running in my vm:

  • note: good instructions here: How to write EasyOS to a flash drive
  • Debian10 is already installed in the vm (virt-manager/qemu/kvm)
  • I downloaded easydd from , unpacked it and set the correct permissions. Easydd is a frontend for dd. It´s a clever script as it turned out :wink:
  • performing sudo ./easydd easy-4.3-4-amd64.img (the script asked about the drive I wanted to write to beforehand)
  • so this isn´t going to work with ventoy (at least not for the latest version of EasyOS).
    Therefore I needed a dedicated stick for EaysOS alone.
  • After the write was complete I chose in the settings of my Debian vm: “add device”
  • I chose “USB host-device” and from the popup menu the respective stick
  • in “boot options” this is the boot order: the usb-stick - VirtIO - NIC
  • ( topic also dealt with in Virt-manager: redirection of USB-stick )
  • the vm boots EasyOS from the stick

All that worked well in the end :slightly_smiling_face: .

Yet the running EasyOS presents another problem:

I cannot connect to the internet. :frowning_face:

Although EasyOS is supposed to automatically recognize available network devices it doesn´t seeem to…

When running Debian in the vm it automatically connects to the virtual LAN. BodhiLinux as well. So theoretically there shouldn´t be any problems. :thinking:

No idea why EasyOS cannot do the same…:question:

Many greetings from Rosika :slightly_smiling_face:


Hi again, :wave:

I was considering alternative ways for not having to plug in a dedicated EasyOS stick and came up with the following (I don´t know whether this would be applicable to my scenario but it might be).

I was thinking: what about creating a virtual disk or virtual block device and then performing
step 4 in the above mentioned method

performing sudo ./easydd easy-4.3-4-amd64.img

and here using the newly created device as the target drive :thinking:

Well, on How to create virtual block device (loop device/filesystem) in Linux – The Geek Diary I found the respective steps for creating a virtual block device.
I successfully tried them out in my Debian vm. :smiley:

This is the example used for creating a 1 GB device (all commands with sudo):

  • dd if=/dev/zero of=loopbackfile.img bs=100M count=10 # create a file of desired size

  • du -sh loopbackfile.img # Verify the size of the file

  • losetup -fP loopbackfile.img # create a loop device with the file

  • losetup -a # print the loop device, example: /dev/loop5: [64769]:4199216 (/root/loopbackfile.img)

  • mkfs.ext4 /root/loopbackfile.img # create a ext4 filesystem on the loopback device

  • mkdir /loopfs

  • mount -o loop /dev/loop5 /loopfs # mount the loopback filesystem

  • df -hP /loopfs/ # Verify the size of the new mount point

  • mount | grep loopfs # verify type of filesystem

Well, these are sthe steps that worked. :smiling_face:
On my Debian vm I got these block devices with lsblk:

loop0    7:0    0  61,9M  1 loop /snap/core20/1518
loop1    7:1    0 386,5M  1 loop /snap/anbox/213
loop2    7:2    0 113,9M  1 loop /snap/core/13308
loop3    7:3    0 101,3M  1 loop /snap/lxd/23155
loop4    7:4    0 310,8M  1 loop 
loop5    7:5    0  1000M  0 loop   # this is new
loop6    7:6    0  1000M  0 loop /loopfs  # and this one as well
vda    254:0    0    30G  0 disk 
├─vda1 254:1    0  10,3G  0 part /
├─vda2 254:2    0     1K  0 part 
├─vda5 254:5    0   976M  0 part [SWAP]
└─vda6 254:6    0  18,8G  0 part /home

As well as it worked this situation still leaves me with loop devices.

For the easydd-script to work I guess I´d have to have a virtual device like so: /dev/[...] as the script scans the system for disks.

Does anyone have any idea how to make that happen :question:
Basically I´d have to make loop6 appear as /dev/vda7 or something like that.

On my host it would be e.g. /dev/sdg

Thanks so much and many greetings
Rosika :slightly_smiling_face:


Hi Rosika,
I think you mean you want to setup a loop mount. What that does is make a file on your HD look, to the OS, as if it were a block device. It can be used for .iso files ( and I presume .img), and it enables you to boot from an .iso file on HD, so you dont have to write it to a usb drive.
You can write a 40_custom file for grub, to tell it to boot from a loop mount.

I will get you a recipe… I need to look it up… its not in my memory.
You might find it in that old post which was about missing /dev/loopx files … I think it was titled something like Gnome Device Mounter command.

If you cant find it I will look it up tomorrow on the PC.


1 Like

Thanks Neville, :wave:

Yes, the steps described above seem to do just that. What I actually wanted to achieve is creating a virtual “disk” … a device that´s listed in the form of /dev/sdg

That would be the goal. Right. :+1:

Ah, I see. I´ll have to investigate further. Thanks for helping me. :heart:

I think you have Gnome-disk-image-mounter in mind.
I´ll take a look at it.

Thanks so much and many greetings
Rosika :slightly_smiling_face:

1 Like

A loop mount will be listed as /dev/loopx. It is a virtual disk.
If it has to be /dev/sdg you might be able to make a link.

Custom_40 files for loop mounts are difficult. They vary depending on the structure of the .iso file.


1 Like

Hi, :wave:

I see.
Well, I guess making a link would be the way to go then.
I´ll look into it.

Thanks a lot, Neville.
Many greetings from Rosika :slightly_smiling_face:

1 Like

I will find you an example of a 40_custom file to boot from an .iso .
It will be tomorrow. What happens is grub actually does the loop mount itself, and you get a line in the grubmenu offering to boot the iso file.
That is not exactly what you want. You want to boot it into the VM.
Not sure how that translates. … In VirtualBox you can boot directly from an iso file on HD… so I guess it does some sort of loop mount internally. Dont know about qemu.


1 Like

Thanks Neville,

you´re too kind. :heart:

I think it should be bed-time by know in your part of the world :blush:

I wish you a good night.

Many greetings.
Rosika :slightly_smiling_face:

1 Like