Issues with making EasyOS run (in a virtual machine)

Hi all,:wave:

at the end of my previous 28-days-option-period for my mobile internet connection I had a bit of data left, so I decided to download “EasyOS” (DistroWatch.com: EasyOS ) for experimental purposes.

It was /easyos/amd64/releases/dunfell/2022/4.0/ (on Index of /easyos/amd64/releases/dunfell/2022/4.0/) an it came as an IMG instead of an ISO.

My aims are the following:

  • getting EasyOS to run as a live system (in a vm: qemu/KVM).
    Distrowatch claims: “Category: Desktop, Live Medium, Specialist”, so theoretically it could be done.
  • or: running EasyOs installed in a vm

Alas I couldn´t achieve any my goals. :slightly_frowning_face:

I managed to get two snapshots of the failed vm instance:

and

I also tried to mount the IMG file but it failed as well: :frowning_face:

env LANG=en_GB:en sudo mount -o loop,ro /media/rosika/f14a27c2-0b49-4607-94ea-2e56bbf76fe1/DATEN-PARTITION/Dokumente/prov_kgw/für_easyOS/easy-4.0-amd64.img /media/usb/
mount: /media/usb: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error.

Hmm. :thinking:

But curiously enough I could mount it with “Open with Disk Image Mounter” from within thunar (right-click-menu). :smiling_face_with_tear:
So theoretically the IMG file can be mounted. Perhaps my command issued within the terminal was wrong :grey_question:

To be clear:
I´d like to get a look at a running EasyOS within a virtual machine (qemu/KVM), not on bare metal.
Whether it´s installed then or running as a live-system doesn´t matter, but neither of them I seem to be able to get running.

Does anyone have any ideas?

Many thanks in advance and many greetings.

Rosika :slightly_smiling_face:

2 Likes

https://forum.puppylinux.com/viewtopic.php?t=4160

https://forum.puppylinux.com/viewtopic.php?t=4896

2 Likes

Hi Rosika,
If you can find out how the .img file was made… for example did they use squashfs?.. then you could unpack it onto a usb stick. Format the usb stick to ext4 first.
What you would then have is an exact copy of EasyOS, just like it would be on a hdd partition.
Then you would just need to add grub to the USB stick, and it would be bootable.

See my doc at

get the file makeusb.pdf

I cant help with qemu… have only used Vbox and Gnome boxes. I find both of them difficult. Does qemu have the capability to read .img files?
Which types of .img files?

I have tried to boot a squashfs.img file directly by telling grub to loop mount it. I failed .

All .iso files contain a .img file internally, along with other stuff to make it bootable. It might be possible to turn the .img file into,a .iso file. Think before you go down that path. It would be difficult.

Not much help I am afraid. I would like to see ypu try the usb stick option

Regards
Neville

PS This may be simple or stupid
Try renaming the file
mv x.img x.iso
qemu might be happy then
because an iso file is just one type of img file

1 Like

Hi again, :wave:

thanks a lot to both of you @Akito and @nevj . :heart:

I´ve looked intio the links you provided. But sadly most comments seem to refer to get EasyOS to work with virtualbox.
Never mind.

Yet the hint referring to conversion brought me one step closer to success :wink:.

I converted the IMG file to qcow2:

qemu-img convert -f raw -O qcow2 easy-4.0-amd64.img easy.qcow2

Here are the filetype characteristics of the two images:


file easy-4.0-amd64.img 
easy-4.0-amd64.img: DOS/MBR boot sector; partition 1 : ID=0xef, active, start-CHS (0x1,1,3), end-CHS (0x318,24,48), startsector 2048, 1570816 sectors; partition 2 : ID=0x83, start-CHS (0x61,231,7), end-CHS (0x62,138,40), startsector 1572864, 10240 sectors

file easy.qcow2 
easy.qcow2: QEMU QCOW2 Image (v3), 810549248 bytes


With the newly created qcow2 image I got EasyOS at least trying to boot.
Alas it ultimately failed (once more) :slightly_frowning_face: :

Taking a closer look at the output messages I realized what might be the culprit:

Mounting squashfs file easy.sfs
mount: mounting /mnt/sda2/easyos/releases/easy-4.0/easy.sfs on /easy_ro/easy_sfs
failed: No such file or directory

However I don´t know why that is and what can be done about it. :thinking:

Hmm, I´d have to dig a bit further. No idea if I can find out more that I already know…

Thanks, Neville, for your link as well. I´ll read it through. :slightly_smiling_face:
Even the title sounds very interesting. I´m amazed at what you can come up with. :+1:

I should think so.
E.g.: according to QEMU › Wiki › ubuntuusers.de :

Entire partitions can be copied to an .img file via dd and integrated into QEMU as a second hard drive

(translated from German)

O.K., now you got me. That I cannot answer… :blush:

I tired that by simply renaming…

It went well, but I got the same error messages (see pics above).
Yet it was worth a shot. :wink:

O.K., I´ll keep digging.

Thanks again to both of you for your help and suggestions… :heart:

Many greetings
Rosika :slightly_smiling_face:

2 Likes

@Rosika
If you can get hold of that easy.sfs file, I know how to unpack that onto a usb drive.
Neville

1 Like

@Rosika

file easy-4.0-amd64.img easy-4.0-amd64.img: DOS/MBR boot sector; partition 1 : ID=0xef, active, start-CHS (

That looks like just a raw image.
Try copying it to somewhere safe ( like a usb drive) with dd
You might just get the full easyos filesystem, just like you would get with an install.
It needs to be copied with dd to a whole disk device, not to a file… ie
dd if= easyxx.img of=/dev/sdx
be careful what you put for sdx… one slip and it overwrites something valuable.

Neville

1 Like

Hi Neville,:wave:

thanks.

I mounted the easyOS IMG with Disk Image Mounter to take a closer look at what´s inside.
From a terminal I issued the command
sudo find ./ -type f -name 'easy.sfs' -print
which returned nothing.

Yet there´s a folder called sfs . Here´s the structure of the complete EasyOS image as far as could get it with

exa --tree --level=3


├── containers
│  ├── console
│  │  ├── bk-notes
│  │  ├── configuration
│  │  ├── container
│  │  ├── desktop
│  │  └── snapshot-comments
│  ├── dunfell
│  │  ├── bk-notes
│  │  ├── configuration
│  │  ├── container
│  │  ├── desktop
│  │  └── snapshot-comments
│  ├── ssh0
│  │  ├── configuration
│  │  ├── container
│  │  └── snapshot-comments
│  └── www
│     ├── configuration
│     ├── container
│     ├── desktop
│     └── snapshot-comments
├── data
├── files
│  ├── archive
│  │  └── <Permission denied (os error 13)>
│  ├── documents
│  │  └── <Permission denied (os error 13)>
│  ├── downloads
│  │  └── <Permission denied (os error 13)>
│  ├── media
│  │  └── <Permission denied (os error 13)>
│  ├── other
│  │  └── <Permission denied (os error 13)>
│  ├── personal
│  │  └── <Permission denied (os error 13)>
│  ├── portable
│  │  └── <Permission denied (os error 13)>
│  ├── projects
│  │  └── <Permission denied (os error 13)>
│  └── shared
│     └── <Permission denied (os error 13)>
├── releases
│  └── easy-4.0
│     └── initrd
└── sfs
   ├── easyos
   │  ├── debian
   │  └── oe
   ├── puppy
   │  └── t2
   └── settings
      ├── initrd
      └── readme.txt

What about a virtual disk device? Can anything be accomplished by going down this road?

I´d very much like to get EasyOS running in qemu VM after all… :blush:

Many greetings from Rosika :slightly_smiling_face:

. Here´s the ***structure*** of the complete EasyOS image as far as could get it with

I dont recognize it.
Certainly not a raw image of a linux filesystem
So forget that idea about copying it with dd … I take this back later !

It has containers?

Inside sfs there is easyos, debian, puppy, and a readme file, and an initrd … that looks like the bit with all the linux files… but it is not a squashfs? sfs must mean something else?

We dont know enough about its structure to be able to copy the relevant bits out of it and make them run.

So there are 2 options

  • persist with qemu … like you want
  • do a hard install onto a usb drive… you must have some hard install instructions. That will unpack it and give you the Linux filesystem without damaging your hdd.

Dont give up. There will be a way to do it

Regards
Neville

1 Like

@Rosika
Follow this
https://easyos.org/install/how-to-install-easyos-on-your-hard-drive.html
only use a usb drive, not your hdd

I cant see vmlinuz or easy.sfs in your loop mounted file?
Maybe those install instructions are out of date?
Are you sure you downloaded the correct file?

Its a mystery
Regards
Neville

Neville

1 Like

@Rosika
This seems to say you do just what I was originally suggesting… just copy it with dd

https://easyos.org/install/how-to-install-easyos-on-a-new-ssd.html

So we still have that option, even though it looks to contain much more than a raw image of a linux filesystem. It must have a very special filesystem
I am going to sleep on it
Regards
Neville

This might help

1 Like

Hi Neville,:wave:

thanks a lot for your suggestions and the links. :heart:

I realize you put a lot of time and effort into doing quite a lot of research on my behalf.
I almost feel bad about it. :face_holding_back_tears: But thanks so much.

Taking up the last link you provided I installed ccd2iso as well as iat. Curiously enough neither of them worked as expected:

1.)


ccd2iso easy-4.0-amd64.img easy.iso

Unrecognized sector mode (c0) at sector 0!

I looked up the error message on the internet and found out I´m not alone with it. Yet I couldn´t see any possible solutions to the problem.
So I tried iat:

2.)

iat easy-4.0-amd64.img easy.iso
Iso9660 Analyzer Tool v0.1.3 by Salvatore Santagati
Licensed under GPL v2 or later

Detect Signature RAW at 2646343
Detect Signature RAW at 2646439
Detect Signature RAW 2 at 2862362
[...]
Detect Signature RAW 2 at 7771439
Detect Signature RAW 2 at 7781369
^C⏎

iat at least started. First I thought it would go through but the process seemed to have stalled at a certain point. I had to cancel it with ctrl+c. :slightly_frowning_face:

So I had no luck converting the IMG file to an ISO file.

However:

iat does work in principle. I tried it by converting a clonezilla image:

iat clonezilla.img clonezilla.iso
Iso9660 Analyzer Tool v0.1.3 by Salvatore Santagati
Licensed under GPL v2 or later

Detect Signature ISO9660 START at 32768
Detect Signature ISO9660 at 36864

 Image offset start at 0
 Sector header 0 bit
 Sector ECC 0 bit
 Block 2048
Done

Hmm, seems it has something to do with the weird nature of the EasyOS image…:thinking:

As far as your other links are concerned, I still have to look into them. Perhaps I can come up with something.

In the meantime: thanks again, Neville, and many greetings.
Rosika :slightly_smiling_face:

P.S.:

Well, I´m pretty sure:

On DistroWatch.com: EasyOS I followed the link for the download: Index of /easyos/amd64/releases/ . This way I got the IMG file.

1 Like

Hi Rosika,
Yes it looks like the easyos image is unique
I might try downloading it myself , and see if I can do anything useful with it. The structure you looked at is interesting… it has containers…
I would like to learn qemu, and I could try with Vbox too

Those tools ccd2iso and iat, I want to look at. I have a long term activity attempting to understand how to make .iso files. They may help.

Another idea… get Ventoy and try with that on a usb drive, instead of my complicated method.

Keep reading, you will find the solution
Regards
Neville

1 Like

Instead of poking around into every bush inside the huge forest, I would suggest contacting the maintainer or even author of the whole thing.

https://bkhome.org/contact/

Ask, what’s going on with the image and what to do. Maybe it’s not even possible to run it in a VM yet, and you both are wasting time on this issue.

1 Like

Hi again, :wave:

@nevj:

Well, that might be an option of course. Thanks. :heart:

@Akito:
Thanks for the link, Akito.
I think that´s the way to go. Hmm, I have to admit I wouldn´t have thought of that… :blush:

I´ll keep you all posted.
Thanks a lot.

Many greetings from Rosika :slightly_smiling_face:

2 Likes

Hi, :wave:

I only want to let you know I´ve just posted a query regarding our topic to Barry Kauler via the link @Akito kindly provided.
So I´m interested to see what he may come up with. :wink:

BTW (offtopic):

I’m completely exhausted now as I had to help a friend of mine via telephone and anydesk getting her Ubuntu laptop to work again.
She was unfortunate enough to have triggered an inline upgrade to 22.04 resulting in a not-so-good system now (she had no clonezilla backup available). :frowning_face:

In the end we seemed to have been successful in getting a timeshift snapshot from last Friday as a “helper”.
The restore process had to be issued from a LinuxMint live system.
All in all (as we tried some other potential solutions first) took about 2 hs today plus 3 hs the day before yesterday…

Time to relax now… :wink: :smiley:

2 Likes

I hope your friend is giving something in return for all the effort you put into her PC situation, several times already.

How? :laughing: You helped her with that, too.

2 Likes

Dear Akito,:wave:

how nice of you to respond even to my offtopic. :heart:

Well, it´s very kind of you to say so but I got a “thank you” via telephone. I guess that´s it then. :wink:
Nothing more to be expected, I´m afraid.

The thing with helping others - as far as IT-related problems are concerned - is: most of them won´t appreciate the effort due to some “lack of understanding”, I guess.

If (and I´m amphasizing if) I am successful in getting some problem solved … for them it seems to be nothing, i.e. nothing to be considered noteworthy.
They tend to think: “Well, she can help me, so what´s the deal?” :thinking:

On the other hand: I cannot bring myself not to help if I can. So what´s left for me to do…
Oh well.

Well, the friend I was helping today could never be bothered to make backups of any kind.
God knows I tried to persuade her. :wink:

Actually there are two other friends of mine I more or less regularly help with their laptops.
Neither of them cares about backups in the least. :frowning_face:

Many greetings from Rosika :slightly_smiling_face:

1 Like

So, they are basically not respecting your recommendation, even though they are asking for help. Does only make sense, if they are egoistic to a certain degree.

2 Likes

It´s kind of you to say so, Akito.
I myself wouldn´t have wanted to state it so explicitly. :blush:

To be fair: I get so much help from you and all of the other members in this forum (thanks so much for that :heart:) I think I wouldn´t feel comfortable denying others my help (if I can help.)

Thanks for your link as well. I just downloaded the audio-part of it.

Many greetings from Rosika :slightly_smiling_face:

2 Likes

@Akito:

I´ve just finished listening to what the computer/IT guy had to say (thanks to your link) and I have to confess I recognized many of the scenarios described. :blush:

It´s very true “friends” turn up whenever they want something to be done.
In fact I haven´t heard from my friend I was helping today for quite a while.

So thanks again for the link, Akito.
At least now I know I´m not alone with this “helper scenario”. :wink:

Many greetings from Rosika :slightly_smiling_face:

2 Likes