It's FOSS website returns server error 520

I am not sure if it is your problem or cloudflare?

Cloudflare… it was happening with a few users but now it’s spreading.

Which browser are you using? Try Firefox please.

It is Firefox-esr

[*] firefox-esr-102.9.0_1 Mozilla Firefox web browser - Extende…

Will try Waterfox

It works in Waterfox


I have submitted a support ticket with Cloudflare. Let’s see if and when they respond.


Tried Android Tablet
Samsung Internet Browser does not work
Firefox Focus works
Google Chrome works

1 Like

Works for me in Brave on Ubuntu 23.04 and Brave on Pop!_OS

Firefox-esr was in Void Linux

In MX Linux I have firefox 114.0.2 and it works.
I also have LibreWolf 114.0.2-1 and it works

I’ve noticed I have had problems connecting to It’s Foss (but not Linux Handbook) on my Android phone (using Google Chrome, although I really need to switch to Firefox on my phone…I should do that soon). I get the same error @nevj. I haven’t had any problems on my desktop though.

Could you provide me a screenshot… most importantly the Ray ID at the bottom of the page?

Cloudflare Ray ID: 7e1f6fbfa7fda888


Thank you. I shared it with the Cloudflare support team.

Hey Abhishek, I hope you don’t feel I am rushing you, but are there updates on this issue? Still having trouble accessing both It’s Foss and It’s Foss community from my phone. Obviously its not a huge deal for me because my desktop never has any problems, but I am concerned others are having similar issues.

This is the Ray ID I am seeing: 7eaee0a897b42ad5

I contacted Cloduflare. They gave me a generic reply to add something in Ngnix logs… but don’t tell how it is going to fix/help with the problem.

Sounds like Cloudflare have caught microsoft disease…apply fix No 23