Kindle Fire wont connect


#1

Since moving from Ubuntu 16.04 to Kubuntu 18.04 Ive not had to load files on my kindle. I find now that when I plug it in I can no longer access it to load files. Before - it just worked. Is this a kde thing or something that was removed thing?


#2

Please make sure that you have selected MTP mode in the Kindle settings when you connect the cable.

If it doesn’t work even after that, try using a tool like gMTP: https://itsfoss.com/how-to-connect-kindle-fire-hd-with-ubuntu-12-10/


#3

Tried that before posting here.
It didnt see it either.
Thankfully my laptop is still 16.04 and I uploaded my files for reading so I could do work on my trip.


#4

If you just want to load eBooks in your Kindle, you can email it to your Kindle as well. I prefer this way.


#5

True, and that works for some documents but for others is a problem. Its a unnecessary step.


#6

i know it doesn’t exactly solve your issue, but you could live boot a regular ubuntu 18.04 image to see how it interacts with your kindle.


#7

Had an issue like yours with my Kindle Paperwhite when I tried to connect it with Calibre on my Ubuntu 18.04 system. I could not see the Kindle at all.

I pursued a fix like you but could not find anything that seemed to fit. I did find others who were having the same experience on Linux and WIndows. I dropped it since using Calibre was not critical to my use of the Kindle.

Jump ahead a few weeks and my Kindle goes through a software upgrade. Now when I plug it into my PC, it is visible as a disk drive and to Calibre.

The moral is to make sure your device is at the latest release level. Best of luck!


#8

It is already on the latest update.

Works fine still with my Ubuntu 16.04 laptop.
Frustration though.