Kubuntu 18.04, on startup only tty screen showing up

I think I may have accidently deleted the sddm. I am a sort of beginner at linux, getting through linux by watching tutorials and videos online. Please help me out.
The system was running fine after I removed and reinstalled python3-apt as per one of the tutorials online.
But when I booted again onto kubuntu, the system shows only the tty1-tty6 screens.
I have dual booted the system with Windows 10.

Thanks

How?

I don’t remember how :sweat_smile:
I followed the instructions on the link you sent, but it reports certain errors and at last says “some packages missing, try apt-update”

Hi @Divyansh, firstly welcome to our community.
If I may offer some advice; a lot of so called tutorials are really quite confusing when starting out on any Linux OS no matter what it is. I found that out when I started out. As you are on here have you searched the it’s Foss site for an answer? Personally it is the first thing I do.
I am sorry I can’t answer your question directly - I see that @Akito has tried to do so for you. The only thing I can suggest is, if you have a restore point before you started to do things and you should always have one, before you do anything, then go back and restore to that and see if they system works correctly. If it does then leave it well alone,

Hey, I followed the instructions on the link you had sent me (https://vitux.com/how-to-install-the-kde-plasma-desktop-on-ubuntu-18-04-lts/)
It asked me to install tasksel and then the kubuntu-desktop and sddm

I followed the steps given but I’ve got some errors that I don’t know how to solve. Here they are:
In tty1, after logging in to my account
On sudo apt install tasksel :

I request you to please help me out, I have not been able to find any solution on net that works for me.

Thanks,
Divyansh

Divyansh-ji, it looks like the repository in India is temporarily down. I’m sure this is not so unusual :slight_smile:

I suspect two commands will solve some problems:

sudo apt update && sudo apt upgrade

and, as per the suggestion

sudo apt upgrade --fix-missing

It seems like some of the Indian APT repository servers for Ubuntu are either temporarily down or have a major issue. I would exclude a problem with your DNS for now, if you are able to reach normal Internet, at all.
Comment out the old entries in your /etc/apt/sources.list and replace them with something that definitely works.

  1. Comment out the current entries.
sudo nano /etc/apt/sources.list
  1. Search on https://duckduckgo.com/ for Ubuntu repository servers. There should be a website somewhere that shows you a complete list of all available Ubuntu repositories.

  2. Select a link from the list and ping it. If successful, visit the website and see if the repository directories are walkable. If again successful, add this link to your /etc/apt/sources.list and execute sudo apt update.
    If at least one of the previous conditions was unsuccessful, try another link from the list and repeat the process.

  3. If apt update was successful in the last step, you should be able to install tasksel, now.

I tried what you said, it asks me to confirm the downloads and then at the end it says :

“E: Failed to fetch http://in.archive.ubuntu.com/…(some url)” "Temporary failure resolving ‘in.archive.ubuntu.com’ "

You addressed me as Divyansh-ji! Have you been to India before?

Ok thanks! I’ll try that and see what happens