Kubuntu boots into TTY1 instead of GUI

Hello altogether,

I installed Kubuntu 18.04.2 LTS, 32-bit as a virtual machine (VMWare Workstation Player 15). My main system is Lubuntu 18.04.2. LTS, 64 bit. That´s been a success at first.

I rebooted several times and performed all available updates which also went well.

Yet after that I´ve got a problem.
When trying to boot Kubuntu now I just get into the virtual terminal TTY1. It does not boot into the GUI any more.

After quite some research I found some sort of workaround on the page https://askubuntu.com/questions/436546/ubuntu-12-04-boots-to-tty1 .

By applying the command startx in TTY1 I get into the GUI and everything works fine. But I shouldn´t be supposed to do this and the GUI should start anyway.

Does anyone know why that is and what can be done about it?

Thanks a lot in advance.

Greetings.
Rosika :pensive:

1 Like

my first thought would be whether or not a fresh install wouldn’t be easier (if this is a fairly fresh install itself) than trying to run down what the problem might be.

my second (if a fresh install isn’t your preference) would be to try and reinstall the desktop. of course it might be a lightdm issue as well. your askubuntu link combined with this one (keeping in mind they are both older articles) suggest that you might be able to do so with sudo apt install --reinstall kubuntu-desktop.

if that doesn’t work or you are still just trying to troubleshoot dmesg --level=err (usually a shorter list) or dmesg --level=warn might be able to give you some idea of what is going wrong with the boot.

Hi cordx and thank you for your suggestions,

As far as fresh install is concerned I´d rather opt out of that one.
I´m funding my whole internet experience by using an umts-stick with a data volume of 6 GB per month. A new installation with all the updates would be less than optimal in that respect. :unamused:

Even if I have to use Kubuntu by typing “startx” in TTY1… That would be a bit of a nuisance at most.

Still I´d like to get things back to normal again and thus I consider the other steps you suggested. As soon as I know more I´ll get back here.

Thanks again in the meantime.

Geetings.
Rosika

i remember your mention of that umts-stick before. i wasn’t thinking about data caps and iso’s + plus initial updates certainly do weigh heavy in that regard. hopefully we can get you past having to use startx :slight_smile:

Rosika, don’t know if this will help as if is from a few years ago, but it might be worth having a look through it to see if anything does help you. https://ubuntuforums.org/showthread.php?t=1646693

one more thought i had was to check in synaptic package manager (or install it if you need to) and check if it shows any broken packages. i’ve not used kubuntu so i don’t know if it has a software center or the like. i think the install should be sudo apt install synaptic.

Hello again and thanks a lot for all your answers.

@cordx:

Good thinking. I´ll do that as soon as possible and get back here.

@ElectricDandySlider:

tnx for the link. I´ll look it through.

@all:
Out of curiosity I thought it might be worthwhile taking a look at /etc/default/grub
of both my host (Lubuntu) and guest (Kubuntu, running in VMWare Wrkstation Player).

I found a significant difference in GRUB_CMDLINE_LINUX and was wondering whether that could have something to do with my problem:

Lubuntu:
[...]
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""           #!!!!!!!!!!!!!!!!!!!!
[...]

Kubuntu:
[...]
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="find_preseed=/preseed.cfg auto noprompt priority=critical locale=en_US"           #!!!!!!!!!!!!!!!!!!!!
[...]

Greetings.
Rosika :slightly_smiling_face:

1 Like

You could try changing GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash” to GRUB_CMDLINE_LINUX_DEFAULT=“elevator=deadline quiet splash” and then doing sudo update-grub. As you know how to get there I don’t think you need this, but just in case you’re not 100% sure- getid admin:///etc/default/grub into terminal to get this up. It is important to do the grub update or it won’t work

Let us know how you get on as it will help others who may have the same problem at some time - Thanks

@ElectricDandySlider:

Tnx for the suggestion.

I changed the entry according to what you said and after that performed a
sudo update-grub. Alas it had no effect. After a reboot a still get into TTY1.

Greeetings.
Rosika

1 Like

for what it’s worth, your lubuntu GRUB_CMDLINE_LINUX matches that of my bodhi 5.0 (based on ubuntu 18.04) install.

Oh well if nothing else it got that one off the list of things to try. Sad it didn’t help, perhaps @abhishek will have an answer for you.

community procedural question: any objection to adding this discussion to the Ubuntu category for classification purposes and possibly to help anyone looking for the same info?

@cordx

No objection on my part. Thanks.

@all:

!!!SUCCESS!!!

I finally managed to get it working.
ChickenLipsRfun2eat from ubuntuusers.de lead me in the right direction. He suggested that possibly the displaymanager was getting de-installed.

The procedure was thus:

sudo dpkg --configure -a #unkonfigurierte Pakete bearbeiten
sudo apt-get -f install #Abhängigkeiten auflösen
sudo apt-get clean && sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get autoremove #Paketcache leeren, System aktualisieren

And after that:

sudo apt install --reinstall sddm

This I think is what got it working again.
When firing up Kubuntu or rebooting I get into the GUI again.

Finally I´d like to thank all of you for your help. I once again learned a lot.

Many greetings and have a nice Sunday.
Rosika :slightly_smiling_face:

P.S.:
For anyone interested: the link of the complete discussion (yet in German) is:
https://forum.ubuntuusers.de/topic/kubuntu-bootet-stets-nach-tty1/

2 Likes

it seems like reinstalling the desktop display manager (sddm) has solved your issue. if you would like to mark this post as the solution, i believe that might be helpful to someone who has a similar issue in the future. if not, i will probably circle back around in a few days and do so :slight_smile:

i found an informative article (link below) about common ubuntu display managers. i’m including it in case someone else does indeed run into a similar issue, but doesn’t happen to be running sddm. an easy way to check a system’s current display manager is by running cat /etc/X11/default-display-manager. a few other display managers listed in the article are gdm, gdm3, lightdm and kdm.

OK, I got curious and ran that command. I have gdm3.
I also ran the command the article gave for switching:

sudo dpkg-reconfigure gdm3

Nothing. No window. Does that mean I ONLY have gdm3?

1 Like

i tried that on my system and got the same result. when i read the article a little more closely, i found:

You can switch from one display manager to another by first installing that display manager if it is already not installed and then using the following command to switch to a new one:

(bold/emphasis mine) i didn’t want to install another (and maybe mess something up :slight_smile:) just to check out the functionality though.

@cordx:

Thanks for the additional info and the link. Good to know.

Greetings.
Rosika :smiley:

1 Like

thank you for sharing the solution you found :slight_smile:

Thanks for showing it has been solved. Glad you were able to get the solution to it Rosika, have a great day :sunglasses: