"kworker" CPU chewer-upper-of-cores

This just started happening the other day…

Ubuntu 18.10 - latest patches updates etc…

All of a sudden my cpu fan will spin up and start whining (Dell Latitude E7250 - 4 x Intel® Core™ i7-5600U CPU @ 2.60GHz, 16 GB DDR3 and 500 GB mSATA SSD) and one of my cores will be maxed out :

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                                                                         
23153 root      20   0       0      0      0 R  80.0   0.0   1:09.92 kworker/0:0+pm

Tried killing them a few times - but parent just spawns replacements …

Also up near the top is “ksoftirqd” proc (with a much lower PID - e.g. 9).

The only “fix” I’ve found - is to reboot, which is a really crap solution from Windows land… PITA… I might see what happens with Kernel 5 when I do-release-upgrade to Disco Dingo over the weekend or early next week… if it persists, I’ll probably go back to Ubuntu 18.04…

Maybe I need to install some sort of CPU “governor”?

Done a heap of google searches - but it always seems to be Ubuntu 16.04 or earlier and/or with NVidia GPU’s (this thing only has integrated Intel GPU).

1 Like

I know this won’t help with this, but perhaps tomorrow 18. April with the new Ubuntu release 19.04 the problem will be solved - it might be worthwhile waiting and upgrading to see if it does as it will have the 5 kernel included and that might solve many things that are causing problems at the moment .
Sorry can’t offer anything else at things time


that’s pretty much my plan of action… I’ll bring it home when I knock off work tomorrow for the Easter long weekend, and try “do-release-upgrade” to 19.04 when it’s available - and see if that fixes it… if not - I’ll wipe it and go back to 18.04.2 LTS…


Let us know how you get on with it please - I know you probably will do so as you usually update things. So thanks in advance.