LEAP does not start in graphical mode

Hi all,
I have installed Suse LEAP in a Vmware player virtual machine. It runs quite well for along time already, but since an update some weeks ago it does not start anymore in the graphical environment (KDE). I allways have to give it a “sudo reboot” and then it starts right away in the graphical KDE einvironment.
Does anybody have any idea where I could have a look at to make its start in graphical environment right first time?

There should be a display manager (like gdm or sddm or lightdm or slim) which starts up at boot and offers a graphical login. When you login it should start KDE automatically.

Without a display manager, you get a console login prompt.
You have to type startx or something similar to start KDE.
Startx requires a .xinitrc file.

If there is no display manager, you can install one using the package system


Hi Nevj,
I think I have a display manager installed as it always starts into KDE when I enter “sudo reboot” after the reboot…

If it starts in command line you could try systemctl restart sddm.service
and then to see the errors:
systemctl status sddm.service

1 Like

It sounds like you have set it to automatic login on boot.
ie you dont have to give a username or passwd?
You must have set that when you installed.

It is bypassing the display manager and you get no login prompt.
cold boot leads to a console, soft boot leads to kde.

I think that is normal behaviour for autologin

If you dont want that, look up the manual and find out how to
go back to username and password.

1 Like

Thanks all,
I have removed the autologin and now the graphical screen comes on and I have to enter my password.
Then it starts in KDE…

Please remember to mark the topic solved

…not really as before it worked with autologin and I got into the graphical KDE environment directly after starting the computer.
I wonder if there also is a solution with autlogin activated to get the the KDE environment right from the start…
And of course I can further understand the depth of Linux… :slight_smile:

There may be .
I would look at putting something to start KDE in .profile
Be careful, you can get things like that wrong and not be able to start at all.
Do you know what the command is to start KDE at thr CLI?
It may be startx or there may be a special command… for
example for Xfce it is startxfce4

1 Like