Libre Office locked

I have used Libreoffice for years. Suddenly, all documents are locked, and I can’t find a way to get to them. The web is full of suggestions that don’t seem to help, and the Libre office help site is hopeless.
I am on Linux Mint 21 and would appreciate any help in getting my documents.

Some questions

  • did you do anything to the filesystem where LibreOffuce stores your documents?
  • has LibreOffice had a recent update?
  • have you recently changed any settings in LibreOffice?

You have to look for something that has changed. Things like this dont just hapoen without a cause.


To add to the questions posed by @nevj

  • What version of LO have you installed on your system ie Snap, Flatpak or deb as that may be significant too.

Thanks to both for getting in touch. I might begin by saying that with my luck, things do seem to happen without cause!! As far as I can know, I have made no changes at all, although it is possible that Libre office offered an update that I accepted. I just don’t remember doing that. I have the deb version installed: version

1 Like

Sorry, I meant to mention that my surfing of the website suggests that this may be a long-standing bug with Libreoffice, but I have seen no suggestions of how to deal with it.

I would do 2 things

  • look at the files with the command line. Use ls -l . What are their permissions… they need to be at least readable by the owner
  • if you think Libreoffice has got itself into some bug driven state, purge it and reinstall it.
    That is easy with a deb package. Just use apt-get purge then apt-get install.

Sorry, I cant be more specific, I have never used Libreoffice, so I dont know the details.
Can other programs access their files in your computer?

1 Like

To Neville Jackson. I thank you for your help on this and previous occasions. I want to refer to your comment that things don’t go wrong without a cause. Although I have a scientific mind, I am on the verge of disagreement. I spent several days trying to solve this problem, and that included a lot of search on the web. I then tried to follow your suggestions. Nothing worked, and I gave up in despondence. Just now, I opened libre office and that problem had disappeared. I had done nothing in the interval and had not logged out from earlier in the day. I just hope that it doesn’t revert after having written this.
Kind regards.

I’ve seen cases on our servers where a drive corruption of some sort occurred, and it was mounted read-only. If something like that happened, it could have caused Libre Office issues when trying to open the files. Then if some sort of automatic (or manual) disk repair happened the drive could have been mounted again read-write.

Maybe there is only one drive or partition in question here and none of the above applies. Just a thought.

1 Like

I am glad it is working again.
I agree with @pdecker … intermittant problems without apparent cause are most like
y due to failing hardware.
I would use SMART to check your hard disk
and I would make sure I had done backups of all personal data.
Thank you for kind words

Have a look at the post “Cant save documents to my external drives…”
I hope you dont have any NTFS filesystems?

Thank you to all for suggestions and advice. My computer is new to me, although it is a refurbished one, and it has been working well. I’ll follow up on SMART when I can learn how to do it.

It’s easy.
On GUI the Gnome disks can display those attributes.
On cli you need to install smartmontools first
sudo apt install smartmontools

Then you get the attributes with smartctl:

sudo smartctl -a /dev/sdX

Wheren sdX is your disk in question.

Smartctl gives a lot of text output, copy that here, so we can have a look at it.

1 Like

I’m sorry to be late in thanking Kovaslt for the helpful advice. I shall copy the information when I have a bit more time. In the interval, although it shows my ignorance, sdX refers to the disk in question, but I don’t know which that is. Sorry!

You can list all the disk device names with
from the command line.
It will be something like /dev/sda or /dev/sdb or whatever
sdX is just a cryptic way of referring to whatever your disk is named

The delay in my response is a result of my wanting to work things out before adding to the the queries I have raised. Also I have always been instructed not to send anything that might lead to identification. I have tried to follow suggestions but get mixed messages. Before sending a screen shot, is it a good idea when one’s identity would be revealed?

Its up to you.
You can always edit the screenshot image file and blank out things like passwirds or internet addresses.