LibreOffice: Insert Special Character

libreoffice
#1

Why doesn’t LibreOffice’s Insert Special Character option show all characters [[in the fonts housed in /usr/share/fonts/truetype/msttcorefonts/]]? Character Map (under Accessories) reports that Georgia, for example, has a Latin-1 Supplement block, a Latin Extended-B block that goes all the way to U+024F (ɏ) and an IPA Extensions block.


I can copy and paste any character from there into any LibreOffice application. But if I open Insert Special Character (in Writer or Calc) and choose Georgia, Latin-1 Supplement and IPA Extensions are missing altogether, and Latin Extended-B ends at U+01FF (ǿ).

Similar things happen with Times New Roman, Courier New and the rest, though not to the same extent: for example, some have one IPA character, namely U+0259 (ə), but again Character Map attests that there are many more.

I’m getting this with LibreOffice 6.1.5.2 under Linux Mint 19.1, but my older computer, with LibreOffice 6.1.4.2 under Ubuntu 16.04, suffers from a softer version of this thing also (Times New Roman is all right, but Georgia misbehaves in the same way).

Update. I was wrong about only the fonts in msttcorefonts being affected; in DejaVu Serif the Insert Special Character dialogue displays the entire IPA Extensions block (U+0250 to U+02AF), but the Cyrillic block goes from U+0400 to U+04F9 rather than U+04FF; and in Ubuntu (the font, not the Linux distribution) the IPA Extensions block is limited to one character, U+0292 (ʒ).

0 Likes

#2

Hi
I have just checked this with version 6.2.0.3 which is available in flat packs via software manager in Mint 19.1 and was able to do all of them by using insert. I did a few to check. So I think that if you do the upgrade that might answer your question. Just one thing, uninstall the version you have now or you will have to copies of Libre Office, but with different version numbers.

0 Likes

#3

Tried 6.2.0.3, tried 6.2.1.2 (removing and purging the old version every time before installing the new one), all with the same results. Evidently the version doesn’t make a difference.

0 Likes

#4

Sorry then I can’t help any further, because when I pressed insert and then went to special character it worked every time without fail no matter where it was in the document or if I was in bold or not. Oh I have found that there are two symbols that are for putting special characters. Sorry I don’t know the name of them, but they look like horse shoes and if you enable both of them, you extra characters to insert.

0 Likes